summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-07-16 09:34:29 +0200
committerHans de Graaff <graaff@gentoo.org>2018-07-16 09:34:47 +0200
commit15ba2bca25c5d4539c61705668724bf38be64217 (patch)
treec81b071f4c528b36f5dbab64346a2c7b62e60b0a /dev-lang/ruby
parentapp-portage/repoman: version bump to repoman-2.3.10 (diff)
downloadgentoo-15ba2bca25c5d4539c61705668724bf38be64217.tar.gz
gentoo-15ba2bca25c5d4539c61705668724bf38be64217.tar.bz2
gentoo-15ba2bca25c5d4539c61705668724bf38be64217.zip
dev-lang/ruby: EAPI 7, fix libressl 2.7
Convert to EAPI 7 Fix compilation with libressl 2.7, bug 656584 Use patches in FILESDIR instead of patchset Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/files/2.4/002_windows_crossdev.patch64
-rw-r--r--dev-lang/ruby/files/2.4/005_no-undefined-ext.patch11
-rw-r--r--dev-lang/ruby/files/2.4/009_no-gems.patch112
-rw-r--r--dev-lang/ruby/files/2.4/010-libressl_2.7.patch15
-rw-r--r--dev-lang/ruby/files/2.4/011-gcc8.patch64
-rw-r--r--dev-lang/ruby/ruby-2.4.4-r1.ebuild229
6 files changed, 495 insertions, 0 deletions
diff --git a/dev-lang/ruby/files/2.4/002_windows_crossdev.patch b/dev-lang/ruby/files/2.4/002_windows_crossdev.patch
new file mode 100644
index 000000000000..7e290d434f03
--- /dev/null
+++ b/dev-lang/ruby/files/2.4/002_windows_crossdev.patch
@@ -0,0 +1,64 @@
+Bug: https://bugs.gentoo.org/show_bug.cgi?id=618878
+
+A few patches to make crossdev for mingw-w64 play nice with ruby's ebuilds.
+Basic gist is that without the following patch to configure.in ruby-2.4.1
+hardcodes 240 into the shared, static, and import library names, which when
+built with the current ruby ebuilds results in names like libx64-msvcrt-ruby24240.dll and so on. The patch is in ruby-trunk[1], but may take a while
+to hit the tarballs that gentoo uses.
+
+Index: configure.in
+===================================================================
+--- a/configure.in (revision 57824)
++++ b/configure.in (revision 57825)
+@@ -3825,7 +3825,23 @@
+
+ AC_ARG_WITH(soname,
+ AS_HELP_STRING([--with-soname=SONAME], [base name of shared library]),
+- [RUBY_SO_NAME=$withval], [RUBY_SO_NAME='$(RUBY_BASE_NAME)'])
++ [RUBY_SO_NAME=$withval],
++ [
++ AS_CASE(["$target_os"],
++ [darwin*], [
++ RUBY_SO_NAME='$(RUBY_BASE_NAME).$(RUBY_PROGRAM_VERSION)'
++ ],
++ [cygwin*], [
++ RUBY_SO_NAME='$(RUBY_BASE_NAME)$(MAJOR)$(MINOR)0'
++ ],
++ [mingw*], [
++ RUBY_SO_NAME="${rb_cv_msvcrt}"'-$(RUBY_BASE_NAME)$(MAJOR)$(MINOR)0'
++ AS_IF([test x"${target_cpu}" != xi386], [
++ RUBY_SO_NAME="${target_cpu}-${RUBY_SO_NAME}"
++ ])
++ ],
++ [RUBY_SO_NAME='$(RUBY_BASE_NAME)'])
++ ])
+
+ LIBRUBY_LDSHARED=$LDSHARED
+ LIBRUBY_DLDFLAGS=$DLDFLAGS
+@@ -3925,7 +3941,6 @@
+ SOLIBS='-lm -lc'
+ ],
+ [darwin*], [
+- RUBY_SO_NAME="$RUBY_SO_NAME"'.$(RUBY_PROGRAM_VERSION)'
+ LIBRUBY_LDSHARED='$(CC) -dynamiclib'
+ if test "$load_relative" = yes; then
+ libprefix="@executable_path/../${libdir_basename}"
+@@ -4157,7 +4172,6 @@
+ fi
+ ],
+ [cygwin*|mingw*], [
+- RUBY_SO_NAME="${RUBY_SO_NAME}"'$(MAJOR)$(MINOR)0'
+ LIBRUBY_DLDFLAGS="${DLDFLAGS}"' -Wl,--out-implib=$(LIBRUBY)'
+ AS_CASE(["$target_os"],
+ [cygwin*], [
+@@ -4167,10 +4181,6 @@
+ fi
+ ],
+ [mingw*], [
+- RUBY_SO_NAME="${rb_cv_msvcrt}-${RUBY_SO_NAME}"
+- if test x"${target_cpu}" != xi386; then
+- RUBY_SO_NAME="${target_cpu}-${RUBY_SO_NAME}"
+- fi
+ if test x"$enable_shared" = xyes; then
+ LIBRUBY_SO='$(RUBY_SO_NAME)'.dll
+ LIBRUBY_DLDFLAGS="${LIBRUBY_DLDFLAGS}"' $(RUBYDEF)'
diff --git a/dev-lang/ruby/files/2.4/005_no-undefined-ext.patch b/dev-lang/ruby/files/2.4/005_no-undefined-ext.patch
new file mode 100644
index 000000000000..f27993240128
--- /dev/null
+++ b/dev-lang/ruby/files/2.4/005_no-undefined-ext.patch
@@ -0,0 +1,11 @@
+--- ruby-1.9.3-preview1.orig/configure.in
++++ ruby-1.9.3-preview1/configure.in
+@@ -2038,7 +2038,7 @@ if test "$with_dln_a_out" != yes; then
+ [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
++ LDFLAGS="$LDFLAGS -Wl,-export-dynamic -Wl,--no-undefined"
+ fi
+ rb_cv_dlopen=yes],
+ [interix*], [ : ${LDSHARED='$(CC) -shared'}
diff --git a/dev-lang/ruby/files/2.4/009_no-gems.patch b/dev-lang/ruby/files/2.4/009_no-gems.patch
new file mode 100644
index 000000000000..6e4e2643d4c0
--- /dev/null
+++ b/dev-lang/ruby/files/2.4/009_no-gems.patch
@@ -0,0 +1,112 @@
+--- a/tool/rbinstall.rb.~1~ 2016-10-17 09:17:07.000000000 +0200
++++ b/tool/rbinstall.rb 2016-12-25 08:20:07.873491045 +0100
+@@ -695,107 +695,11 @@
+ # :startdoc:
+
+ install?(:ext, :comm, :gem) do
+- gem_dir = Gem.default_dir
+- directories = Gem.ensure_gem_subdirectories(gem_dir, :mode => $dir_mode)
+- prepare "default gems", gem_dir, directories
+-
+- spec_dir = File.join(gem_dir, directories.grep(/^spec/)[0])
+- default_spec_dir = "#{spec_dir}/default"
+- makedirs(default_spec_dir)
+-
+- gems = Dir.glob(srcdir+"/{lib,ext}/**/*.gemspec").map {|src|
+- spec = Gem::Specification.load(src) || raise("invalid spec in #{src}")
+- file_collector = RbInstall::Specs::FileCollector.new(File.dirname(src))
+- files = file_collector.collect
+- next if files.empty?
+- spec.files = files
+- spec
+- }
+- gems.compact.sort_by(&:name).each do |gemspec|
+- full_name = "#{gemspec.name}-#{gemspec.version}"
+-
+- puts "#{" "*30}#{gemspec.name} #{gemspec.version}"
+- gemspec_path = File.join(default_spec_dir, "#{full_name}.gemspec")
+- open_for_install(gemspec_path, $data_mode) do
+- gemspec.to_ruby
+- end
+-
+- unless gemspec.executables.empty? then
+- bin_dir = File.join(gem_dir, 'gems', full_name, gemspec.bindir)
+- makedirs(bin_dir)
+-
+- execs = gemspec.executables.map {|exec| File.join(srcdir, 'bin', exec)}
+- install(execs, bin_dir, :mode => $script_mode)
+- end
+- end
++ # gems are unbundled in Gentoo
+ end
+
+ install?(:ext, :comm, :gem) do
+- gem_dir = Gem.default_dir
+- directories = Gem.ensure_gem_subdirectories(gem_dir, :mode => $dir_mode)
+- prepare "bundle gems", gem_dir, directories
+- install_dir = with_destdir(gem_dir)
+- installed_gems = {}
+- options = {
+- :install_dir => install_dir,
+- :bin_dir => with_destdir(bindir),
+- :domain => :local,
+- :ignore_dependencies => true,
+- :dir_mode => $dir_mode,
+- :data_mode => $data_mode,
+- :prog_mode => $prog_mode,
+- :wrappers => true,
+- :format_executable => true,
+- }
+- gem_ext_dir = "#$extout/gems/#{CONFIG['arch']}"
+- extensions_dir = Gem::StubSpecification.gemspec_stub("", gem_dir, gem_dir).extensions_dir
+- Gem::Specification.each_gemspec([srcdir+'/gems/*']) do |path|
+- dir = File.dirname(path)
+- spec = Dir.chdir(dir) {
+- Gem::Specification.load(File.basename(path))
+- }
+- next unless spec.platform == Gem::Platform::RUBY
+- next unless spec.full_name == path[srcdir.size..-1][/\A\/gems\/([^\/]+)/, 1]
+- spec.extension_dir = "#{extensions_dir}/#{spec.full_name}"
+- if File.directory?(ext = "#{gem_ext_dir}/#{spec.full_name}")
+- spec.extensions[0] ||= "-"
+- end
+- ins = RbInstall::UnpackedInstaller.new(spec, options)
+- puts "#{" "*30}#{spec.name} #{spec.version}"
+- ins.install
+- File.chmod($data_mode, File.join(install_dir, "specifications", "#{spec.full_name}.gemspec"))
+- unless spec.extensions.empty?
+- install_recursive(ext, spec.extension_dir)
+- end
+- installed_gems[spec.full_name] = true
+- end
+- installed_gems, gems = Dir.glob(srcdir+'/gems/*.gem').partition {|gem| installed_gems.key?(File.basename(gem, '.gem'))}
+- unless installed_gems.empty?
+- install installed_gems, gem_dir+"/cache"
+- end
+- next if gems.empty?
+- if defined?(Zlib)
+- Gem.instance_variable_set(:@ruby, with_destdir(File.join(bindir, ruby_install_name)))
+- silent = Gem::SilentUI.new
+- gems.each do |gem|
+- inst = Gem::Installer.new(gem, options)
+- inst.spec.extension_dir = with_destdir(inst.spec.extension_dir)
+- begin
+- Gem::DefaultUserInteraction.use_ui(silent) {inst.install}
+- rescue Gem::InstallError => e
+- next
+- end
+- gemname = File.basename(gem)
+- puts "#{" "*30}#{gemname}"
+- end
+- # fix directory permissions
+- # TODO: Gem.install should accept :dir_mode option or something
+- File.chmod($dir_mode, *Dir.glob(install_dir+"/**/"))
+- # fix .gemspec permissions
+- File.chmod($data_mode, *Dir.glob(install_dir+"/specifications/*.gemspec"))
+- else
+- puts "skip installing bundle gems because of lacking zlib"
+- end
++ # gems are unbundled in Gentoo
+ end
+
+ parse_args()
diff --git a/dev-lang/ruby/files/2.4/010-libressl_2.7.patch b/dev-lang/ruby/files/2.4/010-libressl_2.7.patch
new file mode 100644
index 000000000000..2e25ab095858
--- /dev/null
+++ b/dev-lang/ruby/files/2.4/010-libressl_2.7.patch
@@ -0,0 +1,15 @@
+--- a/ext/openssl/extconf.rb.orig 2017-09-08 14:38:12 UTC
++++ b/ext/openssl/extconf.rb
+@@ -157,8 +157,11 @@ OpenSSL.check_func_or_macro("SSL_get_ser
+ have_func("SSL_is_server")
+
+ # added in 1.1.0
++if !have_struct_member("SSL", "ctx", "openssl/ssl.h") ||
++ try_static_assert("LIBRESSL_VERSION_NUMBER >= 0x2070000fL", "openssl/opensslv.h")
++ $defs.push("-DHAVE_OPAQUE_OPENSSL")
++end
+ have_func("CRYPTO_lock") || $defs.push("-DHAVE_OPENSSL_110_THREADING_API")
+-have_struct_member("SSL", "ctx", "openssl/ssl.h") || $defs.push("-DHAVE_OPAQUE_OPENSSL")
+ have_func("BN_GENCB_new")
+ have_func("BN_GENCB_free")
+ have_func("BN_GENCB_get_arg")
diff --git a/dev-lang/ruby/files/2.4/011-gcc8.patch b/dev-lang/ruby/files/2.4/011-gcc8.patch
new file mode 100644
index 000000000000..cb2443631dd8
--- /dev/null
+++ b/dev-lang/ruby/files/2.4/011-gcc8.patch
@@ -0,0 +1,64 @@
+From 027b576b31cd12bad575b3a39476726273f58c41 Mon Sep 17 00:00:00 2001
+From: naruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
+Date: Mon, 18 Dec 2017 09:03:59 +0000
+Subject: [PATCH] suppress warning: 'const' attribute on function returning
+ 'void'
+
+git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@61323 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
+---
+ include/ruby/intern.h | 4 ++--
+ include/ruby/ruby.h | 2 +-
+ internal.h | 4 ++--
+ 3 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/include/ruby/intern.h b/include/ruby/intern.h
+index 5684b3230a67..a711b861159f 100644
+--- a/include/ruby/intern.h
++++ b/include/ruby/intern.h
+@@ -249,9 +249,9 @@ PRINTF_ARGS(NORETURN(void rb_name_error_str(VALUE, const char*, ...)), 2, 3);
+ NORETURN(void rb_invalid_str(const char*, const char*));
+ NORETURN(void rb_error_frozen(const char*));
+ NORETURN(void rb_error_frozen_object(VALUE));
+-CONSTFUNC(void rb_error_untrusted(VALUE));
++void rb_error_untrusted(VALUE);
+ void rb_check_frozen(VALUE);
+-CONSTFUNC(void rb_check_trusted(VALUE));
++void rb_check_trusted(VALUE);
+ #define rb_check_frozen_internal(obj) do { \
+ VALUE frozen_obj = (obj); \
+ if (OBJ_FROZEN(frozen_obj)) { \
+diff --git a/include/ruby/ruby.h b/include/ruby/ruby.h
+index 9c7d2fb68439..3210103c648a 100644
+--- a/include/ruby/ruby.h
++++ b/include/ruby/ruby.h
+@@ -628,7 +628,7 @@ int ruby_safe_level_2_warning(void) __attribute__((const,warning("$SAFE=2 to 4 a
+ # define rb_set_safe_level(level) rb_set_safe_level(RUBY_SAFE_LEVEL_CHECK(level, error))
+ #endif
+ void rb_set_safe_level_force(int);
+-CONSTFUNC(void rb_secure_update(VALUE));
++void rb_secure_update(VALUE);
+ NORETURN(void rb_insecure_operation(void));
+
+ VALUE rb_errinfo(void);
+diff --git a/internal.h b/internal.h
+index d0257a8d8ba0..4ccf3218c6ca 100644
+--- a/internal.h
++++ b/internal.h
+@@ -1110,7 +1110,7 @@ VALUE rb_invcmp(VALUE, VALUE);
+ struct rb_block;
+ int rb_dvar_defined(ID, const struct rb_block *);
+ int rb_local_defined(ID, const struct rb_block *);
+-CONSTFUNC(const char * rb_insns_name(int i));
++const char * rb_insns_name(int i);
+ VALUE rb_insns_name_array(void);
+
+ /* complex.c */
+@@ -1136,7 +1136,7 @@ void Init_ext(void);
+
+ /* encoding.c */
+ ID rb_id_encoding(void);
+-CONSTFUNC(void rb_gc_mark_encodings(void));
++void rb_gc_mark_encodings(void);
+ rb_encoding *rb_enc_get_from_index(int index);
+ rb_encoding *rb_enc_check_str(VALUE str1, VALUE str2);
+ int rb_encdb_replicate(const char *alias, const char *orig);
diff --git a/dev-lang/ruby/ruby-2.4.4-r1.ebuild b/dev-lang/ruby/ruby-2.4.4-r1.ebuild
new file mode 100644
index 000000000000..dec2991fe7a8
--- /dev/null
+++ b/dev-lang/ruby/ruby-2.4.4-r1.ebuild
@@ -0,0 +1,229 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic multilib
+
+MY_P="${PN}-$(ver_cut 1-3)"
+S=${WORKDIR}/${MY_P}
+
+SLOT=$(ver_cut 1-2)
+MY_SUFFIX=$(ver_rs 1 '' ${SLOT})
+RUBYVERSION=${SLOT}.0
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="https://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/${SLOT}/${MY_P}.tar.xz"
+
+LICENSE="|| ( Ruby-BSD BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="berkdb debug doc examples gdbm ipv6 jemalloc libressl +rdoc rubytests socks5 ssl static-libs tk xemacs"
+
+RDEPEND="
+ berkdb? ( sys-libs/db:= )
+ gdbm? ( sys-libs/gdbm:= )
+ jemalloc? ( dev-libs/jemalloc )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+ socks5? ( >=net-proxy/dante-1.1.13 )
+ tk? (
+ dev-lang/tcl:0=[threads]
+ dev-lang/tk:0=[threads]
+ )
+ dev-libs/libyaml
+ virtual/libffi
+ sys-libs/zlib
+ >=app-eselect/eselect-ruby-20161226
+ !<dev-ruby/rdoc-3.9.4
+ !<dev-ruby/rubygems-1.8.10-r1"
+
+DEPEND="${RDEPEND}"
+
+BUNDLED_GEMS="
+ >=dev-ruby/did_you_mean-1.1.0:2.4[ruby_targets_ruby24]
+ >=dev-ruby/minitest-5.10.1[ruby_targets_ruby24]
+ >=dev-ruby/net-telnet-0.1.1[ruby_targets_ruby24]
+ >=dev-ruby/power_assert-0.4.1[ruby_targets_ruby24]
+ >=dev-ruby/rake-12.0.0[ruby_targets_ruby24]
+ >=dev-ruby/test-unit-3.2.3[ruby_targets_ruby24]
+ >=dev-ruby/xmlrpc-0.2.1[ruby_targets_ruby24]
+"
+
+PDEPEND="
+ ${BUNDLED_GEMS}
+ virtual/rubygems[ruby_targets_ruby24]
+ >=dev-ruby/json-2.0.2[ruby_targets_ruby24]
+ rdoc? ( >=dev-ruby/rdoc-5.1.0[ruby_targets_ruby24] )
+ xemacs? ( app-xemacs/ruby-modes )"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${SLOT}/*.patch
+
+ einfo "Unbundling gems..."
+ cd "$S"
+ # Remove bundled gems that we will install via PDEPEND, bug
+ # 539700. Use explicit version numbers to ensure rm fails when they
+ # change so we can update dependencies accordingly.
+ rm -f gems/{did_you_mean-1.1.0,minitest-5.10.1,net-telnet-0.1.1,power_assert-0.4.1,rake-12.0.0,test-unit-3.2.3,xmlrpc-0.2.1}.gem || die
+
+ einfo "Removing bundled libraries..."
+ rm -fr ext/fiddle/libffi-3.2.1 || die
+
+ # Fix a hardcoded lib path in configure script
+ sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
+ configure.in || die "sed failed"
+
+ eapply_user
+
+ eautoreconf
+}
+
+src_configure() {
+ local modules= myconf=
+
+ # -fomit-frame-pointer makes ruby segfault, see bug #150413.
+ filter-flags -fomit-frame-pointer
+ # In many places aliasing rules are broken; play it safe
+ # as it's risky with newer compilers to leave it as it is.
+ append-flags -fno-strict-aliasing
+ # SuperH needs this
+ use sh && append-flags -mieee
+
+ # Socks support via dante
+ if use socks5 ; then
+ # Socks support can't be disabled as long as SOCKS_SERVER is
+ # set and socks library is present, so need to unset
+ # SOCKS_SERVER in that case.
+ unset SOCKS_SERVER
+ fi
+
+ # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+ if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+ append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+ fi
+
+ # ipv6 hack, bug 168939. Needs --enable-ipv6.
+ use ipv6 || myconf="${myconf} --with-lookup-order-hack=INET"
+
+ # Determine which modules *not* to build depending in the USE flags.
+ if ! use berkdb ; then
+ modules="${modules},dbm"
+ fi
+ if ! use gdbm ; then
+ modules="${modules},gdbm"
+ fi
+ if ! use ssl ; then
+ modules="${modules},openssl"
+ fi
+ if ! use tk ; then
+ modules="${modules},tk"
+ fi
+
+ # Provide an empty LIBPATHENV because we disable rpath but we do not
+ # need LD_LIBRARY_PATH by default since that breaks USE=multitarget
+ # #564272
+ INSTALL="${EPREFIX}/usr/bin/install -c" LIBPATHENV="" econf \
+ --program-suffix=${MY_SUFFIX} \
+ --with-soname=ruby${MY_SUFFIX} \
+ --docdir=${EPREFIX}/usr/share/doc/${P} \
+ --enable-shared \
+ --enable-pthread \
+ --disable-rpath \
+ --with-out-ext="${modules}" \
+ $(use_with jemalloc jemalloc) \
+ $(use_enable socks5 socks) \
+ $(use_enable doc install-doc) \
+ --enable-ipv6 \
+ $(use_enable static-libs static) \
+ $(use_enable static-libs install-static-library) \
+ $(use_with static-libs static-linked-ext) \
+ $(use_enable debug) \
+ ${myconf} \
+ --enable-option-checking=no \
+ || die "econf failed"
+}
+
+src_compile() {
+ emake V=1 EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_test() {
+ emake -j1 V=1 test || die "make test failed"
+
+ elog "Ruby's make test has been run. Ruby also ships with a make check"
+ elog "that cannot be run until after ruby has been installed."
+ elog
+ if use rubytests; then
+ elog "You have enabled rubytests, so they will be installed to"
+ elog "/usr/share/${PN}-${SLOT}/test. To run them you must be a user other"
+ elog "than root, and you must place them into a writeable directory."
+ elog "Then call: "
+ elog
+ elog "ruby${MY_SUFFIX} -C /location/of/tests runner.rb"
+ else
+ elog "Enable the rubytests USE flag to install the make check tests"
+ fi
+}
+
+src_install() {
+ # Remove the remaining bundled gems. We do this late in the process
+ # since they are used during the build to e.g. create the
+ # documentation.
+ rm -rf ext/json || die
+
+ # Ruby is involved in the install process, we don't want interference here.
+ unset RUBYOPT
+
+ local MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
+
+ LD_LIBRARY_PATH="${S}:${ED}/usr/$(get_libdir)${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
+ RUBYLIB="${S}:${ED}/usr/$(get_libdir)/ruby/${RUBYVERSION}"
+ for d in $(find "${S}/ext" -type d) ; do
+ RUBYLIB="${RUBYLIB}:$d"
+ done
+ export LD_LIBRARY_PATH RUBYLIB
+
+ emake V=1 DESTDIR="${D}" install || die "make install failed"
+
+ # Remove installed rubygems and rdoc copy
+ rm -rf "${ED}/usr/$(get_libdir)/ruby/${RUBYVERSION}/rubygems" || die "rm rubygems failed"
+ rm -rf "${ED}/usr/bin/"gem"${MY_SUFFIX}" || die "rm rdoc bins failed"
+ rm -rf "${ED}/usr/$(get_libdir)/ruby/${RUBYVERSION}"/rdoc* || die "rm rdoc failed"
+ rm -rf "${ED}/usr/bin/"{ri,rdoc}"${MY_SUFFIX}" || die "rm rdoc bins failed"
+
+ if use doc; then
+ make DESTDIR="${D}" install-doc || die "make install-doc failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r sample
+ fi
+
+ dodoc ChangeLog NEWS doc/NEWS* README* || die
+
+ if use rubytests; then
+ pushd test
+ insinto /usr/share/${PN}-${SLOT}/test
+ doins -r .
+ popd
+ fi
+}
+
+pkg_postinst() {
+ if [[ ! -n $(readlink "${EROOT}"usr/bin/ruby) ]] ; then
+ eselect ruby set ruby${MY_SUFFIX}
+ fi
+
+ elog
+ elog "To switch between available Ruby profiles, execute as root:"
+ elog "\teselect ruby set ruby(23|24|...)"
+ elog
+}
+
+pkg_postrm() {
+ eselect ruby cleanup
+}