summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-08-25 01:14:43 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-08-25 01:14:43 -0700
commit485461e3cfdd2f7a7cfcd74e2eb81b731a5c04f9 (patch)
tree12a41dc505af68bfd69774ed76b7b8d4bf99d225 /dev-lang/rust-bin
parentdev-libs/libuv: Version 1.39.0 (diff)
downloadgentoo-485461e3cfdd2f7a7cfcd74e2eb81b731a5c04f9.tar.gz
gentoo-485461e3cfdd2f7a7cfcd74e2eb81b731a5c04f9.tar.bz2
gentoo-485461e3cfdd2f7a7cfcd74e2eb81b731a5c04f9.zip
dev-lang/rust-bin: fix rustfmt/rls/analysis error
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang/rust-bin')
-rw-r--r--dev-lang/rust-bin/rust-bin-1.44.1.ebuild7
-rw-r--r--dev-lang/rust-bin/rust-bin-1.45.2.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/dev-lang/rust-bin/rust-bin-1.44.1.ebuild b/dev-lang/rust-bin/rust-bin-1.44.1.ebuild
index 7165b90fd15d..83070baf70e6 100644
--- a/dev-lang/rust-bin/rust-bin-1.44.1.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.44.1.ebuild
@@ -45,13 +45,14 @@ multilib_src_install() {
# start native abi install
pushd "${S}" >/dev/null || die
- local std
+ local analysis std
+ analysis="$(grep 'analysis' ./components)"
std="$(grep 'std' ./components)"
local components="rustc,cargo,${std}"
use doc && components="${components},rust-docs"
use clippy && components="${components},clippy-preview"
- use rls && components="${components},rls-preview"
- use rustfmt && components="${components},rustfmt-preview,rust-analysis"
+ use rls && components="${components},rls-preview,${analysis}"
+ use rustfmt && components="${components},rustfmt-preview"
./install.sh \
--components="${components}" \
--disable-verify \
diff --git a/dev-lang/rust-bin/rust-bin-1.45.2.ebuild b/dev-lang/rust-bin/rust-bin-1.45.2.ebuild
index 3e4fa1104406..6e586df2fca7 100644
--- a/dev-lang/rust-bin/rust-bin-1.45.2.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.45.2.ebuild
@@ -45,13 +45,14 @@ multilib_src_install() {
# start native abi install
pushd "${S}" >/dev/null || die
- local std
+ local analysis std
+ analysis="$(grep 'analysis' ./components)"
std="$(grep 'std' ./components)"
local components="rustc,cargo,${std}"
use doc && components="${components},rust-docs"
use clippy && components="${components},clippy-preview"
- use rls && components="${components},rls-preview"
- use rustfmt && components="${components},rustfmt-preview,rust-analysis"
+ use rls && components="${components},rls-preview,${analysis}"
+ use rustfmt && components="${components},rustfmt-preview"
./install.sh \
--components="${components}" \
--disable-verify \