summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-05-26 17:06:35 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-05-26 17:12:58 -0700
commit3474de23b4bd438ea766e82a4c37f7ebc97c7392 (patch)
treeb7ae7c4c55ebab9fb236be02e410bda3b99f7058 /dev-lang/rust
parentnet-wireless/unifi: bump to 5.11.26 (diff)
downloadgentoo-3474de23b4bd438ea766e82a4c37f7ebc97c7392.tar.gz
gentoo-3474de23b4bd438ea766e82a4c37f7ebc97c7392.tar.bz2
gentoo-3474de23b4bd438ea766e82a4c37f7ebc97c7392.zip
dev-lang/rust: fix codegen-backends location on x86
comitting to stable without revbump so I don't force all other users to rebuild this beast Bug: https://bugs.gentoo.org/672816 Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.34.2.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/dev-lang/rust/rust-1.34.2.ebuild b/dev-lang/rust/rust-1.34.2.ebuild
index 6a8ae98793bc..c0d1a001cbc3 100644
--- a/dev-lang/rust/rust-1.34.2.ebuild
+++ b/dev-lang/rust/rust-1.34.2.ebuild
@@ -266,6 +266,18 @@ src_install() {
"${ED}/usr/${abi_libdir}" || die
done
+ # temp fix for https://bugs.gentoo.org/672816
+ if use x86; then
+ local rust_target wrongdir rightdir
+ rust_target=$(rust_abi $(get_abi_CHOST ${v##*.}))
+ wrongdir="${ED}/usr/$(get_libdir)/${P}/${P}/rustlib/${rust_target}/codegen-backends"
+ rightdir="${ED}/usr/$(get_libdir)/${P}/rustlib/${rust_target}/codegen-backends"
+ if [[ -e ${wrongdir}/librustc_codegen_llvm-llvm.so ]]; then
+ mv "${wrongdir}" "${rightdir}" || die
+ rm -r "${ED}/usr/$(get_libdir)/${P}/${P}" || die
+ fi
+ fi # end temp fix
+
dodoc COPYRIGHT
# FIXME: