summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-11-15 01:50:27 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-11-15 02:19:51 +0100
commit76023b2a81ae1927ec5857256fb65d1bec61c509 (patch)
tree37362705a9953161cdbef3ab37798263df7c5071 /dev-lang/rust
parentwww-apps/phpsysinfo: bump to EAPI=7 (diff)
downloadgentoo-76023b2a81ae1927ec5857256fb65d1bec61c509.tar.gz
gentoo-76023b2a81ae1927ec5857256fb65d1bec61c509.tar.bz2
gentoo-76023b2a81ae1927ec5857256fb65d1bec61c509.zip
dev-lang/rust: move soft blockers to RDEPEND
Closes: https://bugs.gentoo.org/671150 Package-Manager: Portage-2.3.51, Repoman-2.3.12 RepoMan-Options: --force Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.29.1-r1.ebuild (renamed from dev-lang/rust/rust-1.29.1.ebuild)10
-rw-r--r--dev-lang/rust/rust-1.29.2-r1.ebuild (renamed from dev-lang/rust/rust-1.29.2.ebuild)10
-rw-r--r--dev-lang/rust/rust-1.30.1-r1.ebuild (renamed from dev-lang/rust/rust-1.30.1.ebuild)10
3 files changed, 15 insertions, 15 deletions
diff --git a/dev-lang/rust/rust-1.29.1.ebuild b/dev-lang/rust/rust-1.29.1-r1.ebuild
index 71a52599320e..7e2cf6102204 100644
--- a/dev-lang/rust/rust-1.29.1.ebuild
+++ b/dev-lang/rust/rust-1.29.1-r1.ebuild
@@ -50,7 +50,7 @@ LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
IUSE="cargo clippy cpu_flags_x86_sse2 debug doc +jemalloc libressl rls rustfmt wasm ${ALL_LLVM_TARGETS[*]}"
-RDEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
+COMMON_DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
jemalloc? ( dev-libs/jemalloc )
cargo? (
sys-libs/zlib
@@ -60,16 +60,16 @@ RDEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
net-libs/http-parser:=
net-misc/curl[ssl]
)"
-DEPEND="${RDEPEND}
+DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
|| (
>=sys-devel/gcc-4.7
>=sys-devel/clang-3.5
)
+ dev-util/cmake"
+RDEPEND="${COMMON_DEPEND}
cargo? ( !dev-util/cargo )
- rustfmt? ( !dev-util/rustfmt )
- dev-util/cmake
-"
+ rustfmt? ( !dev-util/rustfmt )"
PDEPEND="!cargo? ( >=dev-util/cargo-${CARGO_DEPEND_VERSION} )"
REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
diff --git a/dev-lang/rust/rust-1.29.2.ebuild b/dev-lang/rust/rust-1.29.2-r1.ebuild
index a78fda48444d..724b161b99d4 100644
--- a/dev-lang/rust/rust-1.29.2.ebuild
+++ b/dev-lang/rust/rust-1.29.2-r1.ebuild
@@ -40,7 +40,7 @@ LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
IUSE="cargo clippy cpu_flags_x86_sse2 debug doc +jemalloc libressl rls rustfmt wasm ${ALL_LLVM_TARGETS[*]}"
-RDEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
+COMMON_DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
jemalloc? ( dev-libs/jemalloc )
cargo? (
sys-libs/zlib
@@ -50,16 +50,16 @@ RDEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
net-libs/http-parser:=
net-misc/curl[ssl]
)"
-DEPEND="${RDEPEND}
+DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
|| (
>=sys-devel/gcc-4.7
>=sys-devel/clang-3.5
)
+ dev-util/cmake"
+RDEPEND="${COMMOND_DEPEND}
cargo? ( !dev-util/cargo )
- rustfmt? ( !dev-util/rustfmt )
- dev-util/cmake
-"
+ rustfmt? ( !dev-util/rustfmt )"
PDEPEND="!cargo? ( >=dev-util/cargo-${CARGO_DEPEND_VERSION} )"
REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
diff --git a/dev-lang/rust/rust-1.30.1.ebuild b/dev-lang/rust/rust-1.30.1-r1.ebuild
index 1990ef1eaaa7..17118cfdb50f 100644
--- a/dev-lang/rust/rust-1.30.1.ebuild
+++ b/dev-lang/rust/rust-1.30.1-r1.ebuild
@@ -38,7 +38,7 @@ LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
IUSE="clippy cpu_flags_x86_sse2 debug doc +jemalloc libressl rls rustfmt wasm ${ALL_LLVM_TARGETS[*]}"
-RDEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
+COMMON_DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
jemalloc? ( dev-libs/jemalloc )
sys-libs/zlib
!libressl? ( dev-libs/openssl:0= )
@@ -46,16 +46,16 @@ RDEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
net-libs/libssh2
net-libs/http-parser:=
net-misc/curl[ssl]"
-DEPEND="${RDEPEND}
+DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
|| (
>=sys-devel/gcc-4.7
>=sys-devel/clang-3.5
)
+ dev-util/cmake"
+RDEPEND="${COMMON_DEPEND}
!dev-util/cargo
- rustfmt? ( !dev-util/rustfmt )
- dev-util/cmake
-"
+ rustfmt? ( !dev-util/rustfmt )"
REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
x86? ( cpu_flags_x86_sse2 )"