summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-03-15 21:31:53 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-03-15 21:33:08 +0100
commitd7878e1706e9d96f4264c6d2066859cff554056b (patch)
tree708ed5926a39a624885aee1604481bd7a5405337 /dev-lang/rust
parentRevert "dev-lang/rust-bin: move app-eselect/eselect-rust to DEPEND" (diff)
downloadgentoo-d7878e1706e9d96f4264c6d2066859cff554056b.tar.gz
gentoo-d7878e1706e9d96f4264c6d2066859cff554056b.tar.bz2
gentoo-d7878e1706e9d96f4264c6d2066859cff554056b.zip
dev-lang/rust: app-eselect/eselect-rust is only RDEPEND
Bug: https://bugs.gentoo.org/678908 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.29.1-r1.ebuild6
-rw-r--r--dev-lang/rust/rust-1.29.2-r1.ebuild6
-rw-r--r--dev-lang/rust/rust-1.30.1-r1.ebuild3
-rw-r--r--dev-lang/rust/rust-1.31.1.ebuild4
-rw-r--r--dev-lang/rust/rust-1.32.0.ebuild4
-rw-r--r--dev-lang/rust/rust-1.33.0.ebuild4
6 files changed, 14 insertions, 13 deletions
diff --git a/dev-lang/rust/rust-1.29.1-r1.ebuild b/dev-lang/rust/rust-1.29.1-r1.ebuild
index 7e2cf6102204..a1262c26086d 100644
--- a/dev-lang/rust/rust-1.29.1-r1.ebuild
+++ b/dev-lang/rust/rust-1.29.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -50,8 +50,7 @@ LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
IUSE="cargo clippy cpu_flags_x86_sse2 debug doc +jemalloc libressl rls rustfmt wasm ${ALL_LLVM_TARGETS[*]}"
-COMMON_DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
- jemalloc? ( dev-libs/jemalloc )
+COMMON_DEPEND="jemalloc? ( dev-libs/jemalloc )
cargo? (
sys-libs/zlib
!libressl? ( dev-libs/openssl:0= )
@@ -68,6 +67,7 @@ DEPEND="${COMMON_DEPEND}
)
dev-util/cmake"
RDEPEND="${COMMON_DEPEND}
+ >=app-eselect/eselect-rust-0.3_pre20150425
cargo? ( !dev-util/cargo )
rustfmt? ( !dev-util/rustfmt )"
PDEPEND="!cargo? ( >=dev-util/cargo-${CARGO_DEPEND_VERSION} )"
diff --git a/dev-lang/rust/rust-1.29.2-r1.ebuild b/dev-lang/rust/rust-1.29.2-r1.ebuild
index 724b161b99d4..472f877be50e 100644
--- a/dev-lang/rust/rust-1.29.2-r1.ebuild
+++ b/dev-lang/rust/rust-1.29.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -40,8 +40,7 @@ LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
IUSE="cargo clippy cpu_flags_x86_sse2 debug doc +jemalloc libressl rls rustfmt wasm ${ALL_LLVM_TARGETS[*]}"
-COMMON_DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
- jemalloc? ( dev-libs/jemalloc )
+COMMON_DEPEND="jemalloc? ( dev-libs/jemalloc )
cargo? (
sys-libs/zlib
!libressl? ( dev-libs/openssl:0= )
@@ -58,6 +57,7 @@ DEPEND="${COMMON_DEPEND}
)
dev-util/cmake"
RDEPEND="${COMMOND_DEPEND}
+ >=app-eselect/eselect-rust-0.3_pre20150425
cargo? ( !dev-util/cargo )
rustfmt? ( !dev-util/rustfmt )"
PDEPEND="!cargo? ( >=dev-util/cargo-${CARGO_DEPEND_VERSION} )"
diff --git a/dev-lang/rust/rust-1.30.1-r1.ebuild b/dev-lang/rust/rust-1.30.1-r1.ebuild
index f0f113a65971..425fdeb1bf66 100644
--- a/dev-lang/rust/rust-1.30.1-r1.ebuild
+++ b/dev-lang/rust/rust-1.30.1-r1.ebuild
@@ -40,7 +40,7 @@ LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
IUSE="clippy cpu_flags_x86_sse2 debug doc +jemalloc libressl rls rustfmt system-llvm wasm ${ALL_LLVM_TARGETS[*]}"
-COMMON_DEPEND=">=app-eselect/eselect-rust-20190311
+COMMON_DEPEND="
jemalloc? ( dev-libs/jemalloc )
sys-libs/zlib
!libressl? ( dev-libs/openssl:0= )
@@ -57,6 +57,7 @@ DEPEND="${COMMON_DEPEND}
)
dev-util/cmake"
RDEPEND="${COMMON_DEPEND}
+ >=app-eselect/eselect-rust-20190311
!dev-util/cargo
rustfmt? ( !dev-util/rustfmt )"
REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
diff --git a/dev-lang/rust/rust-1.31.1.ebuild b/dev-lang/rust/rust-1.31.1.ebuild
index 54605b4abc3b..21695617d4bb 100644
--- a/dev-lang/rust/rust-1.31.1.ebuild
+++ b/dev-lang/rust/rust-1.31.1.ebuild
@@ -40,8 +40,7 @@ LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
IUSE="clippy cpu_flags_x86_sse2 debug doc +jemalloc libressl rls rustfmt system-llvm wasm ${ALL_LLVM_TARGETS[*]}"
-COMMON_DEPEND=">=app-eselect/eselect-rust-20190311
- jemalloc? ( dev-libs/jemalloc )
+COMMON_DEPEND="jemalloc? ( dev-libs/jemalloc )
sys-libs/zlib
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
@@ -57,6 +56,7 @@ DEPEND="${COMMON_DEPEND}
)
dev-util/cmake"
RDEPEND="${COMMON_DEPEND}
+ >=app-eselect/eselect-rust-20190311
!dev-util/cargo
rustfmt? ( !dev-util/rustfmt )"
REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
diff --git a/dev-lang/rust/rust-1.32.0.ebuild b/dev-lang/rust/rust-1.32.0.ebuild
index 5c33bdfc722d..8a1990cfb627 100644
--- a/dev-lang/rust/rust-1.32.0.ebuild
+++ b/dev-lang/rust/rust-1.32.0.ebuild
@@ -40,8 +40,7 @@ LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
IUSE="clippy cpu_flags_x86_sse2 debug doc libressl rls rustfmt system-llvm wasm ${ALL_LLVM_TARGETS[*]}"
-COMMON_DEPEND=">=app-eselect/eselect-rust-20190311
- sys-libs/zlib
+COMMON_DEPEND="sys-libs/zlib
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
net-libs/libssh2
@@ -56,6 +55,7 @@ DEPEND="${COMMON_DEPEND}
)
dev-util/cmake"
RDEPEND="${COMMON_DEPEND}
+ >=app-eselect/eselect-rust-20190311
!dev-util/cargo
rustfmt? ( !dev-util/rustfmt )"
REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
diff --git a/dev-lang/rust/rust-1.33.0.ebuild b/dev-lang/rust/rust-1.33.0.ebuild
index ef6055f0ddf0..aff9229221d0 100644
--- a/dev-lang/rust/rust-1.33.0.ebuild
+++ b/dev-lang/rust/rust-1.33.0.ebuild
@@ -40,8 +40,7 @@ LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
IUSE="clippy cpu_flags_x86_sse2 debug doc libressl rls rustfmt system-llvm wasm ${ALL_LLVM_TARGETS[*]}"
-COMMON_DEPEND=">=app-eselect/eselect-rust-20190311
- sys-libs/zlib
+COMMON_DEPEND="sys-libs/zlib
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
net-libs/libssh2
@@ -56,6 +55,7 @@ DEPEND="${COMMON_DEPEND}
)
dev-util/cmake"
RDEPEND="${COMMON_DEPEND}
+ >=app-eselect/eselect-rust-20190311
!dev-util/cargo
rustfmt? ( !dev-util/rustfmt )"
REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )