summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2016-10-08 23:04:39 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-12 09:36:41 +0200
commit448a5dfc6ecd2f1c5d5db8c8ae0124155a5498ae (patch)
treee9ce4628c5b2d99877879e88a16211711c8e1c95 /dev-lang/solidity/solidity-0.4.2.ebuild
parentnet-im/skypeforlinux: Version bump to 1.10.0.1 (diff)
downloadgentoo-448a5dfc6ecd2f1c5d5db8c8ae0124155a5498ae.tar.gz
gentoo-448a5dfc6ecd2f1c5d5db8c8ae0124155a5498ae.tar.bz2
gentoo-448a5dfc6ecd2f1c5d5db8c8ae0124155a5498ae.zip
dev-lang/solidity: New package
Solidity is a high-level language whose syntax is similar to that of JavaScript and it is designed to compile to code for the Ethereum Virtual Machine. Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2514 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-lang/solidity/solidity-0.4.2.ebuild')
-rw-r--r--dev-lang/solidity/solidity-0.4.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-lang/solidity/solidity-0.4.2.ebuild b/dev-lang/solidity/solidity-0.4.2.ebuild
new file mode 100644
index 000000000000..0fa788e087da
--- /dev/null
+++ b/dev-lang/solidity/solidity-0.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_MIN_VERSION="3.0.0"
+
+inherit cmake-utils
+
+DESCRIPTION="The Solidity Contract-Oriented Programming Language"
+HOMEPAGE="https://github.com/ethereum/solidity"
+SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/jsoncpp:=
+ dev-libs/boost:=
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ # The build won't work without this file but it is missing from
+ # the release tarball.
+ #
+ # Reported upstream: https://github.com/ethereum/solidity/issues/1183
+
+ cp "${FILESDIR}"/${P}-commit_hash.txt "${S}"/commit_hash.txt || die "Could not copy commit hash"
+
+ # Without this file the build is marked as a developer version
+ # but it is missing from the release tarball.
+ #
+ # Reported upstream: https://github.com/ethereum/solidity/issues/1183
+
+ touch "${S}"/prerelease.txt || die "Could not mark as release version"
+}