summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-01-05 19:25:46 +0000
committerJustin Lecher <jlec@gentoo.org>2017-01-05 19:26:13 +0000
commit17331c2f15ee02bc370d3e2e6a596d377552eb42 (patch)
tree761485ebe38549f760294fc4192cbe3510412d9d /dev-lang
parentnet-analyzer/wireshark: Explicitely depend on media-libs/speex with USE=qt5 (diff)
downloadgentoo-17331c2f15ee02bc370d3e2e6a596d377552eb42.tar.gz
gentoo-17331c2f15ee02bc370d3e2e6a596d377552eb42.tar.bz2
gentoo-17331c2f15ee02bc370d3e2e6a596d377552eb42.zip
dev-lang/R: Backport patch for zlib-1.2.10 compatibility
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=604676 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/R-3.3.2.ebuild5
-rw-r--r--dev-lang/R/files/R-3.3.2-zlib-1.2.10-backport.patch20
2 files changed, 23 insertions, 2 deletions
diff --git a/dev-lang/R/R-3.3.2.ebuild b/dev-lang/R/R-3.3.2.ebuild
index ceeeaf9f4639..bc68f82456c1 100644
--- a/dev-lang/R/R-3.3.2.ebuild
+++ b/dev-lang/R/R-3.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -72,7 +72,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PN}-2.11.1-parallel.patch \
"${FILESDIR}"/${PN}-2.13.1-zlib_header_fix.patch \
- "${FILESDIR}"/${PN}-3.0.0-rmath-shared.patch
+ "${FILESDIR}"/${PN}-3.0.0-rmath-shared.patch \
+ "${FILESDIR}"/${P}-zlib-1.2.10-backport.patch
# fix packages.html for doc (gentoo bug #205103)
sed -i \
diff --git a/dev-lang/R/files/R-3.3.2-zlib-1.2.10-backport.patch b/dev-lang/R/files/R-3.3.2-zlib-1.2.10-backport.patch
new file mode 100644
index 000000000000..2cfb30da90fd
--- /dev/null
+++ b/dev-lang/R/files/R-3.3.2-zlib-1.2.10-backport.patch
@@ -0,0 +1,20 @@
+Index: R.m4
+===================================================================
+--- m4/R.m4 (revision 71152)
++++ m4/R.m4 (revision 71889)
+@@ -3105,10 +3105,11 @@
+ #include <string.h>
+ #include <zlib.h>
+ int main() {
+-#ifdef ZLIB_VERSION
+-/* Work around Debian bug: it uses 1.2.3.4 even though there was no such
+- version on the master site zlib.net */
+- exit(strncmp(ZLIB_VERSION, "1.2.5", 5) < 0);
++#ifdef ZLIB_VERNUM
++ if (ZLIB_VERNUM < 0x1250) {
++ exit(1);
++ }
++ exit(0);
+ #else
+ exit(1);
+ #endif