summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-03-09 18:32:44 -0600
committerWilliam Hubbs <williamh@gentoo.org>2017-03-09 18:33:16 -0600
commit1ab39bcc7a08c49bf75e6c993cd37cdf4da594fa (patch)
tree0948552c993ae3609ab6c01d86304d9d6a7e7b15 /dev-lang
parentsci-geosciences/gpsbabel: Add ~ppc keyword (bug 611050). (diff)
downloadgentoo-1ab39bcc7a08c49bf75e6c993cd37cdf4da594fa.tar.gz
gentoo-1ab39bcc7a08c49bf75e6c993cd37cdf4da594fa.tar.bz2
gentoo-1ab39bcc7a08c49bf75e6c993cd37cdf4da594fa.zip
dev-lang/go: fix 1.8 gccgo bootstrap wrt #606440
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/go-1.8.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-lang/go/go-1.8.ebuild b/dev-lang/go/go-1.8.ebuild
index 11d1819c35f9..1137d737fef5 100644
--- a/dev-lang/go/go-1.8.ebuild
+++ b/dev-lang/go/go-1.8.ebuild
@@ -162,10 +162,12 @@ src_compile()
export GOROOT_BOOTSTRAP="${WORKDIR}"/go-$(go_os)-$(go_arch)-bootstrap
if use gccgo; then
mkdir -p "${GOROOT_BOOTSTRAP}/bin" || die
- local go_binary=$(gcc-config --get-bin-path)/go-5
+ local go_binary=$(gcc-config --get-bin-path)/go-$(gcc-major-version)
[[ -x ${go_binary} ]] || go_binary=$(
- find "${EPREFIX}"/usr/${CHOST}/gcc-bin/*/go-5 | sort -V | tail -n1)
- [[ -x ${go_binary} ]] || die "go-5: command not found"
+ find "${EPREFIX}"/usr/${CHOST}/gcc-bin/*/go-$(gcc-major-version) |
+ sort -V | tail -n1)
+ [[ -x ${go_binary} ]] ||
+ die "go-$(gcc-major-version): command not found"
ln -s "${go_binary}" "${GOROOT_BOOTSTRAP}/bin/go" || die
fi
export GOROOT_FINAL="${EPREFIX}"/usr/lib/go