summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-03-23 11:24:39 -0400
committerMike Gilbert <floppym@gentoo.org>2017-03-23 11:24:58 -0400
commit2fb8cf8075a0a9dcc34c2515d22f0c2aa31bacef (patch)
tree7cecf9e57105b02c4cbbab631fc07997e797965f /dev-lang
parentsys-devel/libtool: add Prefix keywords and patches (diff)
downloadgentoo-2fb8cf8075a0a9dcc34c2515d22f0c2aa31bacef.tar.gz
gentoo-2fb8cf8075a0a9dcc34c2515d22f0c2aa31bacef.tar.bz2
gentoo-2fb8cf8075a0a9dcc34c2515d22f0c2aa31bacef.zip
dev-lang/python: force TZ=UTC for tests in 2.7
Bug: https://bugs.gentoo.org/610628 Package-Manager: Portage-2.3.5_p2, Repoman-2.3.2_p32
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-2.7.12.ebuild7
-rw-r--r--dev-lang/python/python-2.7.13.ebuild5
2 files changed, 11 insertions, 1 deletions
diff --git a/dev-lang/python/python-2.7.12.ebuild b/dev-lang/python/python-2.7.12.ebuild
index 005c8fe5bf5c..47235ee36b7e 100644
--- a/dev-lang/python/python-2.7.12.ebuild
+++ b/dev-lang/python/python-2.7.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -239,6 +239,11 @@ src_test() {
mv "${S}"/Lib/test/test_${test}.py "${T}"
done
+ # Daylight saving time problem
+ # https://bugs.python.org/issue22067
+ # https://bugs.gentoo.org/610628
+ local -x TZ=UTC
+
# Rerun failed tests in verbose mode (regrtest -w).
emake test EXTRATESTOPTS="-w" < /dev/tty
local result="$?"
diff --git a/dev-lang/python/python-2.7.13.ebuild b/dev-lang/python/python-2.7.13.ebuild
index 8c26e45d469a..e69b79cab444 100644
--- a/dev-lang/python/python-2.7.13.ebuild
+++ b/dev-lang/python/python-2.7.13.ebuild
@@ -239,6 +239,11 @@ src_test() {
mv "${S}"/Lib/test/test_${test}.py "${T}"
done
+ # Daylight saving time problem
+ # https://bugs.python.org/issue22067
+ # https://bugs.gentoo.org/610628
+ local -x TZ=UTC
+
# Rerun failed tests in verbose mode (regrtest -w).
emake test EXTRATESTOPTS="-w" < /dev/tty
local result="$?"