summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-06-28 17:12:31 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-06-28 17:15:16 +0100
commit3e6dd877f8a1b5a52da35813ba9518f698d26560 (patch)
treed1256482df767a3479916af0e7e98c737b0370d6 /dev-lang
parentdev-perl/Convert-ASCII-Armour: -r bump for EAPI7 (diff)
downloadgentoo-3e6dd877f8a1b5a52da35813ba9518f698d26560.tar.gz
gentoo-3e6dd877f8a1b5a52da35813ba9518f698d26560.tar.bz2
gentoo-3e6dd877f8a1b5a52da35813ba9518f698d26560.zip
dev-lang/nasm: bump up to 2.15
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/nasm/Manifest1
-rw-r--r--dev-lang/nasm/files/nasm-2.15-bsd-cp-doc.patch13
-rw-r--r--dev-lang/nasm/nasm-2.15.ebuild47
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-lang/nasm/Manifest b/dev-lang/nasm/Manifest
index 6f0a396d5bf0..1c6c01a0571b 100644
--- a/dev-lang/nasm/Manifest
+++ b/dev-lang/nasm/Manifest
@@ -1 +1,2 @@
DIST nasm-2.14.02.tar.xz 827620 BLAKE2B deb1f3c806ffbe48eefe4163271c68f02a782f75f21980331cb03e64de20da61c118621536c1c869c1629e558cab45ce98fed8443d29c1126fb4255cd6a36ce4 SHA512 c7a228095f37321d57f2813d04f58ee66949e8f81fc49ef6c4ecd391301e308217583ce1a265d4fe8c13d54b5b9c72aeb132caa3caee36e31b6555fbfff34c81
+DIST nasm-2.15.tar.xz 975180 BLAKE2B 86fe345ddcc1817471e07fe17ba9009afa02fda152301e3d1cedff624cbd6ebb0e016a2fda339bd53f30fb3d60ae19f806d21c9dbe433ebb7d0e9a74d9db1576 SHA512 c88ff62d08aac86c4ce994bb83e80f1644e0433b01c40cebf183281d31bb4c79471f78e3beab6e7cafb28b3e92298aef89d75672444ea5e8d65c3b019e219583
diff --git a/dev-lang/nasm/files/nasm-2.15-bsd-cp-doc.patch b/dev-lang/nasm/files/nasm-2.15-bsd-cp-doc.patch
new file mode 100644
index 000000000000..5c7f6cfafea1
--- /dev/null
+++ b/dev-lang/nasm/files/nasm-2.15-bsd-cp-doc.patch
@@ -0,0 +1,13 @@
+Avoid 'cp -u' as it's not portable.
+
+In this case we can unconditionally copy files.
+
+Reported-by: Michał Górny
+Bug: https://bugs.gentoo.org/655444
+--- a/doc/Makefile.in
++++ b/doc/Makefile.in
+@@ -28,3 +28,3 @@ RM_RF = rm -rf
+ CP_F = cp -f
+-CP_UF = cp -uf
++CP_UF = cp -f
+
diff --git a/dev-lang/nasm/nasm-2.15.ebuild b/dev-lang/nasm/nasm-2.15.ebuild
new file mode 100644
index 000000000000..1451280eeac2
--- /dev/null
+++ b/dev-lang/nasm/nasm-2.15.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="groovy little assembler"
+HOMEPAGE="https://www.nasm.us/"
+SRC_URI="https://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~ppc64 ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND=""
+# [fonts note] doc/psfonts.ph defines ordered list of font preference.
+# Currently 'media-fonts/source-pro' is most preferred and is able to
+# satisfy all 6 font flavours: tilt, chapter, head, etc.
+BDEPEND="
+ dev-lang/perl
+ doc? (
+ app-text/ghostscript-gpl
+ dev-perl/Font-TTF
+ dev-perl/Sort-Versions
+ media-fonts/source-pro
+ virtual/perl-File-Spec
+ )
+"
+
+S=${WORKDIR}/${P/_}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.15-bsd-cp-doc.patch
+)
+
+src_compile() {
+ default
+ use doc && emake doc
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install_rdf $(usex doc install_doc '')
+}