summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2019-04-11 12:07:16 +0800
committerYixun Lan <dlan@gentoo.org>2019-04-11 12:07:19 +0800
commit4d4f507034963974f35a339175819759305f0aed (patch)
tree2bb5630369019b511e3db73f53d049e79a78ba63 /dev-lang
parentdev-lang/tcc: add myself to maintainer list (diff)
downloadgentoo-4d4f507034963974f35a339175819759305f0aed.tar.gz
gentoo-4d4f507034963974f35a339175819759305f0aed.tar.bz2
gentoo-4d4f507034963974f35a339175819759305f0aed.zip
dev-lang/tcc: drop old ebuilds
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tcc/tcc-0.9.26-r1.ebuild66
-rw-r--r--dev-lang/tcc/tcc-0.9.26-r2.ebuild63
2 files changed, 0 insertions, 129 deletions
diff --git a/dev-lang/tcc/tcc-0.9.26-r1.ebuild b/dev-lang/tcc/tcc-0.9.26-r1.ebuild
deleted file mode 100644
index 07171a4fca78..000000000000
--- a/dev-lang/tcc/tcc-0.9.26-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="A very small C compiler for ix86/amd64"
-HOMEPAGE="https://bellard.org/tcc/"
-SRC_URI="https://download.savannah.gnu.org/releases/tinycc/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="dev-lang/perl" # doc generation
-# Both tendra and tinycc install /usr/bin/tcc
-RDEPEND="!dev-lang/tendra"
-IUSE="test"
-
-src_prepare() {
- # Don't strip
- sed -i -e 's|$(INSTALL) -s|$(INSTALL)|' Makefile || die
-
- # Fix examples
- sed -i -e '1{
- i#! /usr/bin/tcc -run
- /^#!/d
- }' examples/ex*.c || die
- sed -i -e '1s/$/ -lX11/' examples/ex4.c || die
-
- # fix texi2html invocation
- sed -i -e 's/-number//' Makefile || die
- sed -i -e 's/--sections//' Makefile || die
-}
-
-src_configure() {
- use test && unset CFLAGS LDFLAGS # Tests run with CC=tcc etc, they will fail hard otherwise
- # better fixes welcome, it feels wrong to hack the env like this
- # not autotools, so call configure directly
- ./configure --cc="$(tc-getCC)" \
- --bindir=/usr/bin \
- --libdir=/usr/$(get_libdir) \
- --tccdir=tcc \
- --includedir=/usr/include \
- --docdir=/usr/share/doc/${PF} \
- --mandir=/usr/share/man
-}
-
-src_compile() {
- emake AR="$(tc-getAR)"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc Changelog README TODO VERSION
- #dohtml tcc-doc.html
- exeinto /usr/share/doc/${PF}/examples
- doexe examples/ex*.c
-}
-
-src_test() {
- # this is using tcc bits that don't know as-needed etc.
- TCCFLAGS="" emake test
-}
diff --git a/dev-lang/tcc/tcc-0.9.26-r2.ebuild b/dev-lang/tcc/tcc-0.9.26-r2.ebuild
deleted file mode 100644
index 757cc7d58e06..000000000000
--- a/dev-lang/tcc/tcc-0.9.26-r2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="A very small C compiler for ix86/amd64"
-HOMEPAGE="https://bellard.org/tcc/"
-SRC_URI="https://download.savannah.gnu.org/releases/tinycc/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-
-DEPEND="dev-lang/perl" # doc generation
-# Both tendra and tinycc install /usr/bin/tcc
-RDEPEND="!dev-lang/tendra"
-IUSE="test"
-
-src_prepare() {
- # Don't strip
- sed -i -e 's|$(INSTALL) -s|$(INSTALL)|' Makefile || die
-
- # Fix examples
- sed -i -e '1{
- i#! /usr/bin/tcc -run
- /^#!/d
- }' examples/ex*.c || die
- sed -i -e '1s/$/ -lX11/' examples/ex4.c || die
-
- # fix texi2html invocation
- sed -i -e 's/-number//' Makefile || die
- sed -i -e 's/--sections//' Makefile || die
-}
-
-src_configure() {
- use test && unset CFLAGS LDFLAGS # Tests run with CC=tcc etc, they will fail hard otherwise
- # better fixes welcome, it feels wrong to hack the env like this
- # not autotools, so call configure directly
- ./configure --cc="$(tc-getCC)" \
- --prefix="${EPREFIX}/usr" \
- --libdir="${EPREFIX}/usr/$(get_libdir)" \
- --docdir="${EPREFIX}/usr/share/doc/${PF}"
-}
-
-src_compile() {
- emake AR="$(tc-getAR)"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc Changelog README TODO VERSION
- #dohtml tcc-doc.html
- exeinto /usr/share/doc/${PF}/examples
- doexe examples/ex*.c
-}
-
-src_test() {
- # this is using tcc bits that don't know as-needed etc.
- TCCFLAGS="" emake test
-}