summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-03-10 14:50:40 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-03-11 09:01:58 +0100
commit6374fe32293923ea25700041c76de92ec4a515fe (patch)
tree98436f586593b511eb4f2ca8e4815342e40bef89 /dev-lang
parentdev-util/breakpad: fix for gcc13, remove old (diff)
downloadgentoo-6374fe32293923ea25700041c76de92ec4a515fe.tar.gz
gentoo-6374fe32293923ea25700041c76de92ec4a515fe.tar.bz2
gentoo-6374fe32293923ea25700041c76de92ec4a515fe.zip
dev-lang/nim: drop old 1.6.6-r3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/nim/Manifest1
-rw-r--r--dev-lang/nim/nim-1.6.6-r3.ebuild108
2 files changed, 0 insertions, 109 deletions
diff --git a/dev-lang/nim/Manifest b/dev-lang/nim/Manifest
index cf65e8eb2065..a76838169d04 100644
--- a/dev-lang/nim/Manifest
+++ b/dev-lang/nim/Manifest
@@ -1,5 +1,4 @@
DIST nim-1.6.10.tar.xz 5216284 BLAKE2B d5b7bdc488086260b84700e3022ff7fc45b98d78574a3d2e288c95968a580fa644e47612dc60d6e63f5e85687f5b59a28128be746abc55bd6d4527344dc3ab14 SHA512 2ba6c4db68030ace2b4dd9b7f85d2b7c882c62e8f7f68bd0b82f548c91c300ab0e03c66f56c678127058f56b75a5550dec48d68eb6d666a179994cd1a6e2cc47
-DIST nim-1.6.6.tar.xz 5149956 BLAKE2B 2fd1b40f1ecc1200255052d9e013c55287d3e01337146d0b1386d0f3fc9c14fda1e8e82ee289e782c77a573c1ae0985ea7f900f61e6b9824a9eb4b5c803c7f71 SHA512 6ea8d3f61adae48184dd0e3ac393296fd3bd5ead818e7dee949f43eccbd0b6229ebfc474353ddd63cc734f82c3247998fbfe88362061983f978ad8d0ab7fa677
DIST nim-1.6.8.tar.xz 5219880 BLAKE2B 16eac6f302b4ef1df14deaa0350e0e5553c7613515cc3e79cbe025af70955bef29c8261a1f91ba901023d9c53f9f00d62116301eb5a4ee4bb5314bb1e25a5755 SHA512 dd046dd393136fdcb78f463e267756bdb990b08e80e3a8be7fec1995b47a930447468e12bb9a59db6ec5546117f62ff4ccd032959879ef2d1d06a7bc5c438f83
DIST nim-patches-1.6.6.tar.gz 1975 BLAKE2B 75490f4c61f4d920aadb2ad5908cb2773e270f80cee95f937ede8125bad5688b71840ed7f48659db892e4017437a0454b38eab18ae8b13c6b48207d0a7714371 SHA512 4d1590e7d05ad64432b943f8da9edb2b05213400181d1e07a0e40f479afbceb1997d0ea0f05a73d550afe60cf4b657f7e34840907ea16c3b9e96824e9f29e0e5
DIST nim-patches-1.6.6_p1.tar.gz 2632 BLAKE2B 64980d9510dc48e3c566473dc618d00cafba04783882d62b12015e8435c9c0515d7726da30f0b74dca6a41aa88a9c9aed2189a65b3325c28839d0051de8a3365 SHA512 7ba251675cd564452669bf5ec3748565db818324f58506f20a5036e4b54df10f4d7c149cece8cb97c853222cfa7d4d8d26856d92aaa25e613e31c6f5c2a8243d
diff --git a/dev-lang/nim/nim-1.6.6-r3.ebuild b/dev-lang/nim/nim-1.6.6-r3.ebuild
deleted file mode 100644
index 6314b192e44d..000000000000
--- a/dev-lang/nim/nim-1.6.6-r3.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 edo multiprocessing toolchain-funcs xdg-utils
-
-DESCRIPTION="compiled, garbage-collected systems programming language"
-HOMEPAGE="https://nim-lang.org/"
-SRC_URI="
- https://nim-lang.org/download/${P}.tar.xz
- experimental? (
- https://git.sr.ht/~cyber/${PN}-patches/archive/${PV}.tar.gz
- -> ${PN}-patches-${PV}.tar.gz
- )
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="experimental"
-RESTRICT="test" # need to sort out depends and numerous failures
-
-# BDEPEND="sys-process/parallel"
-# BDEPEND="test? ( net-libs/nodejs )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.20.0-paths.patch
- "${FILESDIR}"/${PN}-1.6.6-csources-flags.patch
-)
-
-# Borrowed from nim-utils.eclass (guru overlay).
-nim_gen_config() {
- cat > nim.cfg <<- EOF || die "Failed to create Nim config"
- cc:"gcc"
- gcc.exe:"$(tc-getCC)"
- gcc.linkerexe:"$(tc-getCC)"
- gcc.cpp.exe:"$(tc-getCXX)"
- gcc.cpp.linkerexe:"$(tc-getCXX)"
- gcc.options.speed:"${CFLAGS}"
- gcc.options.size:"${CFLAGS}"
- gcc.options.debug:"${CFLAGS}"
- gcc.options.always:"${CPPFLAGS}"
- gcc.options.linker:"${LDFLAGS}"
- gcc.cpp.options.speed:"${CXXFLAGS}"
- gcc.cpp.options.size:"${CXXFLAGS}"
- gcc.cpp.options.debug:"${CXXFLAGS}"
- gcc.cpp.options.always:"${CPPFLAGS}"
- gcc.cpp.options.linker:"${LDFLAGS}"
-
- $([[ "${NOCOLOR}" == true || "${NOCOLOR}" == yes ]] && echo '--colors:"off"')
- -d:"release"
- --parallelBuild:"$(makeopts_jobs)"
- EOF
-}
-
-src_prepare() {
- default
-
- # note: there are consumers in the ::guru overlay
- use experimental && eapply "${WORKDIR}"/${PN}-patches-${PV}
-}
-
-src_configure() {
- xdg_environment_reset # bug 667182
-
- unset NIMBLE_DIR
- tc-export CC CXX LD
-
- nim_gen_config
-}
-
-src_compile() {
- local -x PATH="${S}/bin:${PATH}"
-
- # Build from C sources
- # Compiling with sys-process/parallel fails for some reason but hopefully
- # we'll be able to enable it later...
- edo bash build.sh # --parallel "$(makeopts_jobs)"
-
- edo ./bin/nim compile koch
- edo ./koch boot -d:nimUseLinenoise --skipParentCfg:off
- edo ./koch tools
-}
-
-src_test() {
- local -x PATH="${S}/bin:${PATH}"
-
- edo ./koch test
-}
-
-src_install() {
- local -x PATH="${S}/bin:${PATH}"
-
- edo ./koch install "${ED}"
-
- # "./koch install" installs only "nim" binary
- # but not the rest
- exeinto /usr/bin
- local exe
- for exe in bin/* ; do
- [[ "${exe}" == bin/nim ]] && continue
- doexe "${exe}"
- done
-
- newbashcomp tools/nim.bash-completion nim
- newbashcomp dist/nimble/nimble.bash-completion nimble
-}