summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-04-28 08:42:25 -0700
committerZac Medico <zmedico@gentoo.org>2016-04-28 08:45:33 -0700
commit665cebe34f6e452bd138bc6749804e6ffc1cc865 (patch)
tree30111806e983fc74086c0f246f12c17cf59b2921 /dev-lang
parentdev-lang/go: ppc64le updates for #581278 (diff)
downloadgentoo-665cebe34f6e452bd138bc6749804e6ffc1cc865.tar.gz
gentoo-665cebe34f6e452bd138bc6749804e6ffc1cc865.tar.bz2
gentoo-665cebe34f6e452bd138bc6749804e6ffc1cc865.zip
dev-lang/go: fix gccgo support to use gcc-config --get-bin-path (bug 579958)
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/go-1.6.2.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-lang/go/go-1.6.2.ebuild b/dev-lang/go/go-1.6.2.ebuild
index 07d84b0ecdf0..88dace64fdc2 100644
--- a/dev-lang/go/go-1.6.2.ebuild
+++ b/dev-lang/go/go-1.6.2.ebuild
@@ -155,7 +155,7 @@ src_compile()
export GOROOT_BOOTSTRAP="${WORKDIR}"/go-$(go_os)-$(go_arch)-bootstrap
if use gccgo; then
mkdir -p "${GOROOT_BOOTSTRAP}/bin" || die
- local go_binary=$(type -P go-5 2>/dev/null)
+ local go_binary=$(gcc-config --get-bin-path)/go-5
[[ -x ${go_binary} ]] || go_binary=$(
find "${EPREFIX}"/usr/${CHOST}/gcc-bin/*/go-5 | sort -V | tail -n1)
[[ -x ${go_binary} ]] || die "go-5: command not found"