summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-31 18:26:54 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-31 18:54:36 +0100
commit766884661d3b10952f9136b1c8fe849d03eee984 (patch)
treeb02189bdedcee09c7ad22a55f8a7cc540cd89028 /dev-lang
parentdev-lang/typescript: drop old 4.8.4 (diff)
downloadgentoo-766884661d3b10952f9136b1c8fe849d03eee984.tar.gz
gentoo-766884661d3b10952f9136b1c8fe849d03eee984.tar.bz2
gentoo-766884661d3b10952f9136b1c8fe849d03eee984.zip
dev-lang/typescript: bump to 4.9.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/typescript/Manifest1
-rw-r--r--dev-lang/typescript/typescript-4.9.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/typescript/Manifest b/dev-lang/typescript/Manifest
index 6ac704b42c53..6993f97002ce 100644
--- a/dev-lang/typescript/Manifest
+++ b/dev-lang/typescript/Manifest
@@ -1,2 +1,3 @@
DIST typescript-4.9.3.tgz 11618300 BLAKE2B 8a11cae27e9873750ebc1c4d9f0116f0ac291b17138df277188d754d36a33668476acbef56b9903c082372e2780253728ef5a9cc2cf57d872014b6fad2842cd2 SHA512 0887c6cd37a56ca3449cba4b7461607722a11b6dc229d2a040f38173e39436b909dafafe292cec495e64ab989684441ba24faabb1806ceb02d1960b253bb479c
DIST typescript-4.9.4.tgz 11619457 BLAKE2B 97f19fe325ba7f74d845779eb94919895c44a9603ecec9f1aec5d332a49976f1b1133686a2969205e01c49dfe460c8f8b3eac384134d592478e49af1748a08fb SHA512 533f9d4d7633c575dbb05a4cf3a5a1ddd282c6b42a51c54cc70539e28af09498cea4eddaa3c2fb8f9947f9d59f4f0802c08b8cf4643692f568b736093174c166
+DIST typescript-4.9.5.tgz 11620433 BLAKE2B c253379a4aadd3fe16c93f27c5b450e5965c4c4de6841737c3489c74baa2cf8f8f5d9ca0414b5519e26eaac1db058e3826a3aa504bb450a89d36dce7e21b5f99 SHA512 d455e4f44d879be433650ef3f8c7098872f8356d45d84cccbbd36af62df301a1aa89b69fa98c02554e96c9602ec90451cce971a2ef31652c972c437ca0a8f6e2
diff --git a/dev-lang/typescript/typescript-4.9.5.ebuild b/dev-lang/typescript/typescript-4.9.5.ebuild
new file mode 100644
index 000000000000..598301d43b33
--- /dev/null
+++ b/dev-lang/typescript/typescript-4.9.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
+HOMEPAGE="https://www.typescriptlang.org/
+ https://github.com/microsoft/TypeScript/"
+SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+S="${WORKDIR}"/package
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+RDEPEND="net-libs/nodejs"
+BDEPEND=">=net-libs/nodejs-16[npm]"
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local myopts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}"/usr
+ --progress false
+ --verbose
+ )
+ npm ${myopts[@]} install "${DISTDIR}"/${P}.tgz || die "npm install failed"
+
+ dodoc *.md *.txt
+}