summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-03-09 11:48:44 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-03-09 11:53:59 +0100
commitc84c3e24f35da1e43bedf798dc3f5ea7e6215d93 (patch)
treea43e1b80538d4325e5195c4c4e8a8909faaea800 /dev-lang
parentdev-lang/zig: ensure 'zig' symlink is valid if possible (diff)
downloadgentoo-c84c3e24f35da1e43bedf798dc3f5ea7e6215d93.tar.gz
gentoo-c84c3e24f35da1e43bedf798dc3f5ea7e6215d93.tar.bz2
gentoo-c84c3e24f35da1e43bedf798dc3f5ea7e6215d93.zip
dev-lang/zig-bin: ensure 'zig' symlink is valid if possible
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/zig-bin/zig-bin-0.10.1-r1.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-lang/zig-bin/zig-bin-0.10.1-r1.ebuild b/dev-lang/zig-bin/zig-bin-0.10.1-r1.ebuild
index 81c98e238a76..30514b6b713a 100644
--- a/dev-lang/zig-bin/zig-bin-0.10.1-r1.ebuild
+++ b/dev-lang/zig-bin/zig-bin-0.10.1-r1.ebuild
@@ -46,6 +46,8 @@ src_install() {
}
pkg_postinst() {
+ eselect zig update ifunset
+
elog "0.10.1 release uses self-hosted compiler by default and fixes some bugs from 0.10.0"
elog "But your code still can be un-compilable since some features still not implemented or bugs not fixed"
elog "Upstream recommends:"
@@ -54,3 +56,7 @@ pkg_postinst() {
elog "Also see: https://ziglang.org/download/0.10.0/release-notes.html#Self-Hosted-Compiler"
elog "and https://ziglang.org/download/0.10.0/release-notes.html#How-to-Upgrade"
}
+
+pkg_postrm() {
+ eselect zig update ifunset
+}