summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2017-03-19 10:15:27 +0100
committerDirkjan Ochtman <djc@gentoo.org>2017-03-19 10:15:27 +0100
commitdf2c3c55094d285e75d2cca524043cd3a662778e (patch)
tree18492dac70497449e8f45c1e926804b90fbb6f7d /dev-lang
parentx11-misc/qtfm: Fix GCC-6 build (bug #612522) (diff)
downloadgentoo-df2c3c55094d285e75d2cca524043cd3a662778e.tar.gz
gentoo-df2c3c55094d285e75d2cca524043cd3a662778e.tar.bz2
gentoo-df2c3c55094d285e75d2cca524043cd3a662778e.zip
dev-lang/rust-bin: version bump to 1.16.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust-bin/Manifest2
-rw-r--r--dev-lang/rust-bin/rust-bin-1.16.0.ebuild101
2 files changed, 103 insertions, 0 deletions
diff --git a/dev-lang/rust-bin/Manifest b/dev-lang/rust-bin/Manifest
index cf5aef2b2de7..a3661dcea5d1 100644
--- a/dev-lang/rust-bin/Manifest
+++ b/dev-lang/rust-bin/Manifest
@@ -8,3 +8,5 @@ DIST rust-1.15.0-i686-unknown-linux-gnu.tar.gz 103875063 SHA256 3cff0c621a9c58df
DIST rust-1.15.0-x86_64-unknown-linux-gnu.tar.gz 101145605 SHA256 576fcced49744af5ea438afc4411395530426b0a3d4839c5205f646f15850663 SHA512 0f582e540241ca9cc9e36face8c28061d1e2814acba7480ab818b15fc0db98519d28aa9649c6cbb5ccea95c28c2e0927268b76cbfe7178b136e56cbcc6b25aaf WHIRLPOOL e031a9556df365780baa5ed7bd51ebb22b0166be38bd17aa2d23c09f97095cf3d1aae647fbd90940ec959e09ba8bd696fb95c4aecc41cdf43a5dae8ca45c22c5
DIST rust-1.15.1-i686-unknown-linux-gnu.tar.gz 103889253 SHA256 a93436b969d19a6576aac5264ff5b58cbbdf3514f15c34146a274c2586f7e052 SHA512 13d602842e7a2ef360c80d3ec84ecd5d6c742ea6dad642394a2a57b28554a7758905b37daaf2bcc549428c5f9383307270f8508e8685748b906fc2b9230bc4ad WHIRLPOOL 3b1487e049eb6d12ad269894f0547461d0e20e018c3e8903203cc9cabf178617058d643870f0f6bfa1f01947602d3fdafbd39c3d410b2dd53aaf1624730fbe0d
DIST rust-1.15.1-x86_64-unknown-linux-gnu.tar.gz 101140146 SHA256 b1e7c818a3cc8b010932f0efc1cf0ede7471958310f808d543b6e32d2ec748e7 SHA512 e089c455b1a7507aeed4652f05c0672c4e996e708c46f4405191f4b3a9d08403cab27f1a5a63f865d9a8f099f6ca980d2d2eef37aaa5e7e5bd751a3224e88b84 WHIRLPOOL 8983a5135bb34a6f54c8f015e8a02c2d9bd9c126589659b68fa57a8de928524af5a427b950f944d68ea80264e8acb54810c548b18910036ede080c1c8371a081
+DIST rust-1.16.0-i686-unknown-linux-gnu.tar.gz 106129219 SHA256 b5859161ebb182d3b75fa14a5741e5de87b088146fb0ef4a30f3b2439c6179c5 SHA512 7a780a107d98c6a8883f95dbb5a5ec95bad52fb1e735afba29b47411b450d464cbc8dfe73d35de1eb18b9a1f9ea727daa1ca9d3042e2a98c67ad570d328e139d WHIRLPOOL e7cbcfdb984a76ce8c7885cde6380582f75205ec498db904ccbaf7fac891caf7d1ef377c67e40265cdd998ad420d6cc55cf2a989abb167da0285d24319a36bd6
+DIST rust-1.16.0-x86_64-unknown-linux-gnu.tar.gz 103142459 SHA256 48621912c242753ba37cad5145df375eeba41c81079df46f93ffb4896542e8fd SHA512 f3d381c0e47e0af02eb116376422c3e48295c2854c6ad8c03d4c13e662f3cc1fdddf25923f7b3ef358c5cf670ed67d75e2197162434a81d5f9499e6e0e2d1054 WHIRLPOOL db9547a3b92471d5f46b431fc6c66d12cb2bcda22d548993904a03485f729b4a0f91813dbf2a5b3f46c9aeb0ca39332db1f95454cabb9f0684e4142fe3bfdcf3
diff --git a/dev-lang/rust-bin/rust-bin-1.16.0.ebuild b/dev-lang/rust-bin/rust-bin-1.16.0.ebuild
new file mode 100644
index 000000000000..319576f891af
--- /dev/null
+++ b/dev-lang/rust-bin/rust-bin-1.16.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils bash-completion-r1
+
+MY_P="rust-${PV}"
+
+DESCRIPTION="Systems programming language from Mozilla"
+HOMEPAGE="http://www.rust-lang.org/"
+SRC_URI="amd64? ( http://static.rust-lang.org/dist/${MY_P}-x86_64-unknown-linux-gnu.tar.gz )
+ x86? ( http://static.rust-lang.org/dist/${MY_P}-i686-unknown-linux-gnu.tar.gz )"
+
+LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
+SLOT="stable"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
+ !dev-lang/rust:0
+"
+RDEPEND="${DEPEND}"
+
+QA_PREBUILT="
+ opt/${P}/bin/rustc-bin-${PV}
+ opt/${P}/bin/rustdoc-bin-${PV}
+ opt/${P}/lib/*.so
+ opt/${P}/lib/rustlib/*/lib/*.so
+"
+
+src_unpack() {
+ default
+
+ local postfix
+ use amd64 && postfix=x86_64-unknown-linux-gnu
+ use x86 && postfix=i686-unknown-linux-gnu
+ mv "${WORKDIR}/${MY_P}-${postfix}" "${S}" || die
+}
+
+src_install() {
+ local std=$(grep 'std' ./components)
+ local components="rustc,${std}"
+ use doc && components="${components},rust-docs"
+ ./install.sh \
+ --components="${components}" \
+ --disable-verify \
+ --prefix="${D}/opt/${P}" \
+ --mandir="${D}/usr/share/${P}/man" \
+ --disable-ldconfig \
+ || die
+
+ local rustc=rustc-bin-${PV}
+ local rustdoc=rustdoc-bin-${PV}
+ local rustgdb=rust-gdb-bin-${PV}
+
+ mv "${D}/opt/${P}/bin/rustc" "${D}/opt/${P}/bin/${rustc}" || die
+ mv "${D}/opt/${P}/bin/rustdoc" "${D}/opt/${P}/bin/${rustdoc}" || die
+ mv "${D}/opt/${P}/bin/rust-gdb" "${D}/opt/${P}/bin/${rustgdb}" || die
+
+ dosym "/opt/${P}/bin/${rustc}" "/usr/bin/${rustc}"
+ dosym "/opt/${P}/bin/${rustdoc}" "/usr/bin/${rustdoc}"
+ dosym "/opt/${P}/bin/${rustgdb}" "/usr/bin/${rustgdb}"
+
+ cat <<-EOF > "${T}"/50${P}
+ LDPATH="/opt/${P}/lib"
+ MANPATH="/usr/share/${P}/man"
+ EOF
+ doenvd "${T}"/50${P}
+
+ cat <<-EOF > "${T}/provider-${P}"
+ /usr/bin/rustdoc
+ /usr/bin/rust-gdb
+ EOF
+ dodir /etc/env.d/rust
+ insinto /etc/env.d/rust
+ doins "${T}/provider-${P}"
+}
+
+pkg_postinst() {
+ eselect rust update --if-unset
+
+ elog "Rust installs a helper script for calling GDB now,"
+ elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV},"
+
+ if has_version app-editors/emacs || has_version app-editors/emacs-vcs; then
+ elog "install app-emacs/rust-mode to get emacs support for rust."
+ fi
+
+ if has_version app-editors/gvim || has_version app-editors/vim; then
+ elog "install app-vim/rust-vim to get vim support for rust."
+ fi
+
+ if has_version 'app-shells/zsh'; then
+ elog "install app-shells/rust-zshcomp to get zsh completion for rust."
+ fi
+}
+
+pkg_postrm() {
+ eselect rust unset --if-invalid
+}