summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-10-19 00:01:03 +1300
committerKent Fredric <kentnl@gentoo.org>2020-10-19 00:03:28 +1300
commitf714b1cdd9d3c661e6137941935a6780e5ab7107 (patch)
tree2e6bb846eabc44d3a149185258935f8d5d8ee780 /dev-lang
parentdev-haskell/js-flot: update to EAPI=7 (diff)
downloadgentoo-f714b1cdd9d3c661e6137941935a6780e5ab7107.tar.gz
gentoo-f714b1cdd9d3c661e6137941935a6780e5ab7107.tar.bz2
gentoo-f714b1cdd9d3c661e6137941935a6780e5ab7107.zip
dev-lang/perl: Add USE="minimal" for bootstrappers
Even though PDEPEND is "post" dependency, portage still *schedules* PDEPENDS to install *before* perl, where possible. This leads to a fun problem under cross/chroot/catalyst stuff, as it then necessitates you install perl-cleaner, and thus, portage-utils, before installing perl. And portage-utils in turn necessitates a lot of complexity by default, openmp, nettle, ... ssl... And if those fail, which is highly likely, portage doesn't try to install perl, even though it would compile just fine. And in reality, you don't actually need perl-cleaner to have a working perl interpreter. Its just strongly recommended and all systems should have it. Same goes for the virtuals and subsequent perl-core/ stuff, which also isn't strictly necessary for a working perl, at least, not when you're bootstrapping it, as this is mostly our safeguards against various security concerns. So pretty much 100% of what is in PDEPEND should be able to be turned off, if you're an adult and know what you're doing. Globally setting USE="minimal" is not officially supported, but bugs that result from it are welcome. Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/perl-5.30.3-r1.ebuild12
-rw-r--r--dev-lang/perl/perl-5.32.0-r1.ebuild12
-rw-r--r--dev-lang/perl/perl-5.32.0.ebuild12
3 files changed, 21 insertions, 15 deletions
diff --git a/dev-lang/perl/perl-5.30.3-r1.ebuild b/dev-lang/perl/perl-5.30.3-r1.ebuild
index 235bdb073230..b437e661e578 100644
--- a/dev-lang/perl/perl-5.30.3-r1.ebuild
+++ b/dev-lang/perl/perl-5.30.3-r1.ebuild
@@ -54,7 +54,7 @@ if [[ "${PV##*.}" != "9999" ]] && [[ "${PV/rc//}" == "${PV}" ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="berkdb debug doc gdbm ithreads"
+IUSE="berkdb debug doc gdbm ithreads minimal"
RDEPEND="
berkdb? ( sys-libs/db:= )
@@ -65,10 +65,12 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
PDEPEND="
- >=app-admin/perl-cleaner-2.5
- >=virtual/perl-File-Temp-0.230.400-r2
- >=virtual/perl-Data-Dumper-2.154.0
- virtual/perl-Test-Harness
+ !minimal? (
+ >=app-admin/perl-cleaner-2.5
+ >=virtual/perl-File-Temp-0.230.400-r2
+ >=virtual/perl-Data-Dumper-2.154.0
+ virtual/perl-Test-Harness
+ )
"
# bug 390719, bug 523624
# virtual/perl-Test-Harness is here for the bundled ExtUtils::MakeMaker
diff --git a/dev-lang/perl/perl-5.32.0-r1.ebuild b/dev-lang/perl/perl-5.32.0-r1.ebuild
index c4700dfc9a7d..0c5fdc0e83d1 100644
--- a/dev-lang/perl/perl-5.32.0-r1.ebuild
+++ b/dev-lang/perl/perl-5.32.0-r1.ebuild
@@ -56,7 +56,7 @@ KEYWORDS=""
# KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="berkdb debug doc gdbm ithreads"
+IUSE="berkdb debug doc gdbm ithreads minimal"
RDEPEND="
berkdb? ( sys-libs/db:= )
@@ -69,10 +69,12 @@ DEPEND="${RDEPEND}"
BDEPEND="${RDEPEND}"
PDEPEND="
- >=app-admin/perl-cleaner-2.5
- >=virtual/perl-File-Temp-0.230.400-r2
- >=virtual/perl-Data-Dumper-2.154.0
- virtual/perl-Test-Harness
+ !minimal? (
+ >=app-admin/perl-cleaner-2.5
+ >=virtual/perl-File-Temp-0.230.400-r2
+ >=virtual/perl-Data-Dumper-2.154.0
+ virtual/perl-Test-Harness
+ )
"
# bug 390719, bug 523624
# virtual/perl-Test-Harness is here for the bundled ExtUtils::MakeMaker
diff --git a/dev-lang/perl/perl-5.32.0.ebuild b/dev-lang/perl/perl-5.32.0.ebuild
index d5ab04c97359..b375dbc322bb 100644
--- a/dev-lang/perl/perl-5.32.0.ebuild
+++ b/dev-lang/perl/perl-5.32.0.ebuild
@@ -54,7 +54,7 @@ if [[ "${PV##*.}" != "9999" ]] && [[ "${PV/rc//}" == "${PV}" ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="berkdb debug doc gdbm ithreads"
+IUSE="berkdb debug doc gdbm ithreads minimal"
RDEPEND="
berkdb? ( sys-libs/db:= )
@@ -65,10 +65,12 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
PDEPEND="
- >=app-admin/perl-cleaner-2.5
- >=virtual/perl-File-Temp-0.230.400-r2
- >=virtual/perl-Data-Dumper-2.154.0
- virtual/perl-Test-Harness
+ !minimal? (
+ >=app-admin/perl-cleaner-2.5
+ >=virtual/perl-File-Temp-0.230.400-r2
+ >=virtual/perl-Data-Dumper-2.154.0
+ virtual/perl-Test-Harness
+ )
"
# bug 390719, bug 523624
# virtual/perl-Test-Harness is here for the bundled ExtUtils::MakeMaker