summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-06-27 20:15:38 -0400
committerAaron Bauman <bman@gentoo.org>2021-01-25 09:55:25 -0500
commitcc377d2f7bb63f022f3185c0fbf66b42d04d68da (patch)
tree92a87e98d8e3f1704b222e0db382566a72045ce0 /dev-libs/aml
parentapp-admin/undertaker-scripts: Package undertaker helper scripts (diff)
downloadgentoo-cc377d2f7bb63f022f3185c0fbf66b42d04d68da.tar.gz
gentoo-cc377d2f7bb63f022f3185c0fbf66b42d04d68da.tar.bz2
gentoo-cc377d2f7bb63f022f3185c0fbf66b42d04d68da.zip
dev-libs/aml: simple event loop
used as a real time even loop by neatvnc Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-libs/aml')
-rw-r--r--dev-libs/aml/Manifest1
-rw-r--r--dev-libs/aml/aml-0.2.0.ebuild28
-rw-r--r--dev-libs/aml/aml-9999.ebuild28
-rw-r--r--dev-libs/aml/metadata.xml15
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/aml/Manifest b/dev-libs/aml/Manifest
new file mode 100644
index 000000000000..4b5e3e0dab4e
--- /dev/null
+++ b/dev-libs/aml/Manifest
@@ -0,0 +1 @@
+DIST aml-0.2.0.tar.gz 20358 BLAKE2B 4be63726ea9069cbfe36fbf04e3a0b2229066d7df039aea1a41fdca27700d012fda9eda348115f8c0ef9d3f201640123722d0b96bc7b171841d920357a292152 SHA512 196cd891fdbaad47340d8b4ca9eb62a7f9e6b0969ae9ad744a3c9ea110a532691d53a1e39fde583bad0f8fdae4b51c3a4243bbdab65e952e5fc79ceb6efc3262
diff --git a/dev-libs/aml/aml-0.2.0.ebuild b/dev-libs/aml/aml-0.2.0.ebuild
new file mode 100644
index 000000000000..db62c0b53724
--- /dev/null
+++ b/dev-libs/aml/aml-0.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="event timer executor loop"
+HOMEPAGE="https://github.com/any1/aml/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/aml.git"
+else
+ SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="examples"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ )
+ meson_src_configure
+}
diff --git a/dev-libs/aml/aml-9999.ebuild b/dev-libs/aml/aml-9999.ebuild
new file mode 100644
index 000000000000..db62c0b53724
--- /dev/null
+++ b/dev-libs/aml/aml-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="event timer executor loop"
+HOMEPAGE="https://github.com/any1/aml/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/aml.git"
+else
+ SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="examples"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ )
+ meson_src_configure
+}
diff --git a/dev-libs/aml/metadata.xml b/dev-libs/aml/metadata.xml
new file mode 100644
index 000000000000..9e2438fd5155
--- /dev/null
+++ b/dev-libs/aml/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="examples">Build and install examples</flag>
+ </use>
+</pkgmetadata>