summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-01-30 13:18:44 +0100
committerPacho Ramos <pacho@gentoo.org>2016-01-30 13:23:44 +0100
commit2ac39fc92e09b2352f04a68e194823934a6c24c4 (patch)
tree0819f66175d84d2c62acddfa801b554e4535317b /dev-libs/appstream-glib
parentdev-libs/appstream-glib: Drop old (diff)
downloadgentoo-2ac39fc92e09b2352f04a68e194823934a6c24c4.tar.gz
gentoo-2ac39fc92e09b2352f04a68e194823934a6c24c4.tar.bz2
gentoo-2ac39fc92e09b2352f04a68e194823934a6c24c4.zip
dev-libs/appstream-glib: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-libs/appstream-glib')
-rw-r--r--dev-libs/appstream-glib/Manifest1
-rw-r--r--dev-libs/appstream-glib/appstream-glib-0.5.7.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/appstream-glib/Manifest b/dev-libs/appstream-glib/Manifest
index ae5e16665990..1af7e0b79b34 100644
--- a/dev-libs/appstream-glib/Manifest
+++ b/dev-libs/appstream-glib/Manifest
@@ -1,2 +1,3 @@
DIST appstream-glib-0.5.0.tar.xz 1818388 SHA256 35d63ca31664918905c3de634766766d98dadcd99d7271fb319f6279b846bf36 SHA512 1c1a1f41d6911c73a25a83396fb183d99ee139378766235b8885ee68c2b738137d55c108e7ea3ec2853e5ac5f17936b87df554bea45a1c19db3caea5bcee5d0d WHIRLPOOL 2a26ce1685ed3c78242c0ef29b4e5dea95ba070e531503f00f378f36974a8e1aa858b66640fe48ccc7c1ace9619671ff3c6d71aaf78e81a6ef5b55ab2be64090
DIST appstream-glib-0.5.5.tar.xz 1855288 SHA256 c539b261678b152554cd0548f973c371188403dfdb88e6ca979cc378ff50bbff SHA512 529cfcca989c501ab5666c98ce85fa085afe08df72de8217802d8baa6b606c5f6e1038adb57b29351a40ec2de71cf99c1dbf4b18289286d1b7ebb5a7f15be5de WHIRLPOOL b29fc6825cb4906e8951d81301e97bb41f2c79cdb6e78475a5a1b8daa8d15bfab531903f802c2036f2065d18245f609819f72018711d0d71a0b59348752893b7
+DIST appstream-glib-0.5.7.tar.xz 1858904 SHA256 6d7fe9c5a3dd4488398628ad283a6383cc5324a02f6ff504c73393adc4972264 SHA512 f91d06cdea924d64375bd163437b9c10f9aa99e99bd2e9a015abfb1d506a58877faebfb1e320d4883e84f87b951501f5ad3a3f13a34ee4b4ff121538a9e881d6 WHIRLPOOL d5b0d02d283d069e429f4890e304be6df4465b1a384cc011a12566c7dc6b1ae239cd08a828c6e037abef24ba9613612528f9b9a4090cf62aff7a43a4a2349d26
diff --git a/dev-libs/appstream-glib/appstream-glib-0.5.7.ebuild b/dev-libs/appstream-glib/appstream-glib-0.5.7.ebuild
new file mode 100644
index 000000000000..497fbbb55288
--- /dev/null
+++ b/dev-libs/appstream-glib/appstream-glib-0.5.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit bash-completion-r1 gnome2
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="http://people.freedesktop.org/~hughsient/appstream-glib/"
+SRC_URI="http://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/8" # soname version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection nls"
+
+# FIXME: yaml is optional with --enable-dep11 but not
+# properly handled in autofoo bug#????
+RDEPEND="
+ app-arch/gcab
+ app-arch/libarchive
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.45.8:2
+ dev-libs/libyaml
+ >=media-libs/fontconfig-2.11
+ >=media-libs/freetype-2.4:2
+ >=net-libs/libsoup-2.51.92:2.4
+ sys-apps/util-linux
+ >=x11-libs/gdk-pixbuf-2.31.5:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8:= )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+"
+# ${PN} superseeds appdata-tools, require dummy package until all ebuilds
+# are migrated to appstream-glib
+RDEPEND="${RDEPEND}
+ !<dev-util/appdata-tools-0.1.8-r1
+"
+PDEPEND=">=dev-util/appdata-tools-0.1.8-r1"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-builder \
+ --enable-firmware \
+ --disable-rpm \
+ --disable-static \
+ --enable-dep11 \
+ --enable-man \
+ $(use_enable nls) \
+ $(use_enable introspection) \
+ --with-bashcompletiondir="$(get_bashcompdir)"
+}