summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-12-28 23:33:54 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-12-29 00:09:46 +0100
commit610a16366d4c084b1605fb4e84acb9e841222f38 (patch)
tree4ba8530c1e9842d5109b6a75b30d4f10e7111815 /dev-libs/appstream-glib
parentapp-text/jabref-bin: Another RDEPEND fix for java. (diff)
downloadgentoo-610a16366d4c084b1605fb4e84acb9e841222f38.tar.gz
gentoo-610a16366d4c084b1605fb4e84acb9e841222f38.tar.bz2
gentoo-610a16366d4c084b1605fb4e84acb9e841222f38.zip
dev-libs/appstream-glib: version bump to 0.5.5
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs/appstream-glib')
-rw-r--r--dev-libs/appstream-glib/Manifest1
-rw-r--r--dev-libs/appstream-glib/appstream-glib-0.5.5.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/appstream-glib/Manifest b/dev-libs/appstream-glib/Manifest
index d6b567383449..7828585e9e28 100644
--- a/dev-libs/appstream-glib/Manifest
+++ b/dev-libs/appstream-glib/Manifest
@@ -2,3 +2,4 @@ DIST appstream-glib-0.3.4.tar.xz 1814472 SHA256 97b948ad992cb985e5bed533446fb5d2
DIST appstream-glib-0.4.0.tar.xz 1837552 SHA256 f4dee0e86549009f248d38eb643061e82ff0d542f06e1f4af6b36af2f97c2e13 SHA512 54769b47f11f8792ee85ab0922d8a256800c00558ca9e2fcaab30845e3fbd9f4a08d311608f0b600f8ad070d79d5227cd9ac4b644ef6d94e1772e4695c4f1afe WHIRLPOOL da036564be55acc4c0b3d5320f165ac98d6f4754ed74dda8b06d31c7bfd91b10ff3f4ff0d85b141bfa804391befcadecd714a9b110d422cf9286c899714ad58d
DIST appstream-glib-0.5.0.tar.xz 1818388 SHA256 35d63ca31664918905c3de634766766d98dadcd99d7271fb319f6279b846bf36 SHA512 1c1a1f41d6911c73a25a83396fb183d99ee139378766235b8885ee68c2b738137d55c108e7ea3ec2853e5ac5f17936b87df554bea45a1c19db3caea5bcee5d0d WHIRLPOOL 2a26ce1685ed3c78242c0ef29b4e5dea95ba070e531503f00f378f36974a8e1aa858b66640fe48ccc7c1ace9619671ff3c6d71aaf78e81a6ef5b55ab2be64090
DIST appstream-glib-0.5.3.tar.xz 1853508 SHA256 842688933d182c4789843f0d7b288622a9fd3f75fbe645849cacc6195bdfceab SHA512 18ff35dcaed26072c0c3f84dc7310f1838e0626f733d2bf7cb8aeb7e36a963fa07a9b2c917e7cb423a5fab1b329977ff9ec8836be9c3a988724a624d4d77f4a8 WHIRLPOOL d8c10c5e669cb2d52c55217fe97e08f6b29119a57254d63df9187ea82fb98b174345b8a4e314b548e8f40cf2066a3d42ae189a3e89199e14d60f5f8a6f0f2c54
+DIST appstream-glib-0.5.5.tar.xz 1855288 SHA256 c539b261678b152554cd0548f973c371188403dfdb88e6ca979cc378ff50bbff SHA512 529cfcca989c501ab5666c98ce85fa085afe08df72de8217802d8baa6b606c5f6e1038adb57b29351a40ec2de71cf99c1dbf4b18289286d1b7ebb5a7f15be5de WHIRLPOOL b29fc6825cb4906e8951d81301e97bb41f2c79cdb6e78475a5a1b8daa8d15bfab531903f802c2036f2065d18245f609819f72018711d0d71a0b59348752893b7
diff --git a/dev-libs/appstream-glib/appstream-glib-0.5.5.ebuild b/dev-libs/appstream-glib/appstream-glib-0.5.5.ebuild
new file mode 100644
index 000000000000..d207a6c8183c
--- /dev/null
+++ b/dev-libs/appstream-glib/appstream-glib-0.5.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit bash-completion-r1 gnome2
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="http://people.freedesktop.org/~hughsient/appstream-glib/"
+SRC_URI="http://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/8" # soname version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection nls"
+
+# FIXME: yaml is optional with --enable-dep11 but not
+# properly handled in autofoo bug#????
+RDEPEND="
+ app-arch/gcab
+ app-arch/libarchive
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.45.8:2
+ dev-libs/libyaml
+ >=media-libs/fontconfig-2.11
+ >=media-libs/freetype-2.4:2
+ >=net-libs/libsoup-2.51.92:2.4
+ sys-apps/util-linux
+ >=x11-libs/gdk-pixbuf-2.31.5:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8:= )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+"
+# ${PN} superseeds appdata-tools, require dummy package until all ebuilds
+# are migrated to appstream-glib
+RDEPEND="${RDEPEND}
+ !<dev-util/appdata-tools-0.1.8-r1
+"
+PDEPEND=">=dev-util/appdata-tools-0.1.8-r1"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-builder \
+ --enable-firmware \
+ --disable-ostree \
+ --disable-rpm \
+ --disable-static \
+ --enable-dep11 \
+ --enable-man \
+ $(use_enable nls) \
+ $(use_enable introspection) \
+ --with-bashcompletiondir="$(get_bashcompdir)"
+}