summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-21 23:47:19 +0000
committerSam James <sam@gentoo.org>2020-12-21 23:47:30 +0000
commitd1b87c017eb2b01fdb500c6ea20a7155c7106cb0 (patch)
treef3eb9419c1cd2c8875d55e71a57a0a0862469b1a /dev-libs/botan
parentvirtual/cblas: fix MissingVirtualKeywords (diff)
downloadgentoo-d1b87c017eb2b01fdb500c6ea20a7155c7106cb0.tar.gz
gentoo-d1b87c017eb2b01fdb500c6ea20a7155c7106cb0.tar.bz2
gentoo-d1b87c017eb2b01fdb500c6ea20a7155c7106cb0.zip
dev-libs/botan: bump to 2.17.3
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/Manifest1
-rw-r--r--dev-libs/botan/botan-2.17.3.ebuild130
2 files changed, 131 insertions, 0 deletions
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index aa1b4d94151f..d93a88883cd8 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -1,2 +1,3 @@
DIST Botan-2.16.0.tar.xz 5938644 BLAKE2B a4b7bb48aee0dbf0f8b81a407b6a39707c3e6040a2bb93f9c34208ab87ea64879b2e56af66f090a73d66b64156e333c89e490d206e666e665a5eb4fbcd98d13e SHA512 12550425c695119d7f448a47b7956565de373e1bc86b8fdfa0a2a5b9fed1ef93a36101b6480e7a2f78e9262c988904c353fa021b681543691d09bf5b00495bd4
DIST Botan-2.17.2.tar.xz 5940964 BLAKE2B 009df11c9d4379a15a48697554a82df3baffad0fff98af995f9a5b9b3223e4db42837650d41b7081170b07fb70d62ab347c5577ef2480a8f7011b40e1cf1764d SHA512 fa9bd30d02540c4544646971c7b82d3873f32362668d2496b4bc1a92f47d52f75ec9533d5848a7d8e9b9077c7ae2866b55d70d39101c705eec0edf9dbf01d6cf
+DIST Botan-2.17.3.tar.xz 5937596 BLAKE2B 605e71c959889b459bc26f17d310a33f26c9a51fe00db91db407ac5b96c9ff57bef67a401f71826e83e0d4eda2289c22685957289e6bb357f3693a1bce60f44d SHA512 ead0f144dfb9eca66d0e81e376d0d49f4b0b6bc1599f8cf52299e1753645b5b20100efa004ef5f9571f7bea88958f35db38367fc26f2603890f8f199cc890dbc
diff --git a/dev-libs/botan/botan-2.17.3.ebuild b/dev-libs/botan/botan-2.17.3.ebuild
new file mode 100644
index 000000000000..c15f5000f25c
--- /dev/null
+++ b/dev-libs/botan/botan-2.17.3.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit python-r1 toolchain-funcs
+
+MY_P="Botan-${PV}"
+
+DESCRIPTION="C++ crypto library"
+HOMEPAGE="https://botan.randombit.net/"
+SRC_URI="https://botan.randombit.net/releases/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD-2"
+SLOT="2/$(ver_cut 1-2)" # soname version
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+IUSE="bindist bzip2 boost doc libressl lzma python sqlite ssl static-libs zlib"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ ')
+"
+
+# NOTE: Boost is needed at runtime too for the CLI tool.
+DEPEND="
+ boost? ( >=dev-libs/boost-1.48:= )
+ bzip2? ( >=app-arch/bzip2-1.0.5:= )
+ lzma? ( app-arch/xz-utils:= )
+ python? ( ${PYTHON_DEPS} )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ sqlite? ( dev-db/sqlite:3= )
+ zlib? ( >=sys-libs/zlib-1.2.3:= )
+"
+
+RDEPEND="${DEPEND}"
+
+# NOTE: Considering patching Botan?
+# Please see upstream's guidance:
+# https://botan.randombit.net/handbook/packaging.html#minimize-distribution-patches
+
+python_check_deps() {
+ if use doc ; then
+ has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]" || return 1
+ fi
+}
+
+src_configure() {
+ local disable_modules=()
+ use boost || disable_modules+=( "boost" )
+ use bindist && disable_modules+=( "ecdsa" )
+ elog "Disabling module(s): ${disable_modules[@]}"
+
+ # Enable v9 instructions for sparc64
+ local chostarch="${CHOST%%-*}"
+ if [[ "${PROFILE_ARCH}" = "sparc64" ]] ; then
+ chostarch="sparc32-v9"
+ fi
+
+ local myos=
+ case ${CHOST} in
+ *-darwin*) myos=darwin ;;
+ *) myos=linux ;;
+ esac
+
+ case ${CHOST} in
+ hppa*) chostarch=parisc ;;
+ esac
+
+ local pythonvers=()
+ if use python ; then
+ _append() {
+ pythonvers+=( ${EPYTHON/python/} )
+ }
+
+ python_foreach_impl _append
+ fi
+
+ # Don't install Python bindings automatically
+ # (do it manually later in the right place)
+ # https://bugs.gentoo.org/723096
+ local myargs=(
+ $(use_enable static-libs static-library)
+ $(use_with boost)
+ $(use_with bzip2)
+ $(use_with doc documentation)
+ $(use_with doc sphinx)
+ $(use_with lzma)
+ $(use_with sqlite sqlite3)
+ $(use_with ssl openssl)
+ $(use_with zlib)
+ $(usex hppa --without-stack-protector '')
+ --cpu=${chostarch}
+ --disable-modules=$( IFS=","; echo "${disable_modules[*]}" )
+ --docdir=share/doc
+ --libdir=$(get_libdir)
+ --os=${myos}
+ --distribution-info="Gentoo ${PVR}"
+ --prefix="${EPREFIX}/usr"
+ --with-endian="$(tc-endian)"
+ --with-python-version=$( IFS=","; echo "${pythonvers[*]}" )
+ --without-doxygen
+ --no-install-python-module
+ )
+
+ tc-export CC CXX AR
+
+ ./configure.py "${myargs[@]}" || die "configure.py failed"
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
+}
+
+src_install() {
+ default
+
+ # Manually install the Python bindings (bug #723096)
+ if use python ; then
+ python_foreach_impl python_domodule src/python/botan2.py
+ fi
+}