summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2016-11-30 11:15:48 -0700
committerChristoph Junghans <junghans@gentoo.org>2016-11-30 11:17:26 -0700
commitc7800fed27e6e871a64ff5469b98e66330028906 (patch)
tree3c143dc2d7309d23744179d50a802de2a26f821c /dev-libs/caliper/caliper-1.5.0.ebuild
parentdev-python/sphinx: Enable pypy3 (diff)
downloadgentoo-c7800fed27e6e871a64ff5469b98e66330028906.tar.gz
gentoo-c7800fed27e6e871a64ff5469b98e66330028906.tar.bz2
gentoo-c7800fed27e6e871a64ff5469b98e66330028906.zip
dev-libs/caliper: initial commit
This includes patches from LLNL/Caliper#23, LLNL/Caliper#24 and LLNL/Caliper#25 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs/caliper/caliper-1.5.0.ebuild')
-rw-r--r--dev-libs/caliper/caliper-1.5.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/caliper/caliper-1.5.0.ebuild b/dev-libs/caliper/caliper-1.5.0.ebuild
new file mode 100644
index 000000000000..006b140b1688
--- /dev/null
+++ b/dev-libs/caliper/caliper-1.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Application Introspection System"
+HOMEPAGE="http://computation.llnl.gov/projects/caliper"
+SRC_URI="https://github.com/LLNL/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ net-misc/curl
+ sys-libs/libunwind
+ dev-libs/papi
+ "
+RDEPEND="${DEPEND}"
+
+#thttps://github.com/LLNL/Caliper/pull/23
+#thttps://github.com/LLNL/Caliper/pull/24
+#thttps://github.com/LLNL/Caliper/pull/25
+PATCHES=( "${FILESDIR}/${P}-cmake.patch"
+ "${FILESDIR}/${P}-python2.patch"
+ "${FILESDIR}/${P}-multilib.patch"
+ )
+
+S="${WORKDIR}/${P^c}"