summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-07-05 11:48:20 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-07-05 11:56:06 +0100
commitd0ab3d5f0d37a1444ae171760052d930299ffd22 (patch)
tree6ef5e695ba4d9f22312a9da878621ebd42ebf15d /dev-libs/capstone
parentdev-lang/nasm: drop old (diff)
downloadgentoo-d0ab3d5f0d37a1444ae171760052d930299ffd22.tar.gz
gentoo-d0ab3d5f0d37a1444ae171760052d930299ffd22.tar.bz2
gentoo-d0ab3d5f0d37a1444ae171760052d930299ffd22.zip
dev-libs/capstone: drop old
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-libs/capstone')
-rw-r--r--dev-libs/capstone/capstone-4.0.2-r1.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/dev-libs/capstone/capstone-4.0.2-r1.ebuild b/dev-libs/capstone/capstone-4.0.2-r1.ebuild
deleted file mode 100644
index 6de5971d2cdc..000000000000
--- a/dev-libs/capstone/capstone-4.0.2-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit cmake-utils distutils-r1 toolchain-funcs
-
-DESCRIPTION="disassembly/disassembler framework + bindings"
-HOMEPAGE="http://www.capstone-engine.org/"
-SRC_URI="https://github.com/aquynh/${PN}/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/4" # libcapstone.so.4
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-RESTRICT="!test? ( test )"
-
-IUSE="python static-libs test"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- python? ( dev-python/setuptools[${PYTHON_USEDEP}] )
-"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-S=${WORKDIR}/${P/_rc/-rc}
-
-wrap_python() {
- if use python; then
- pushd bindings/python >/dev/null || die
- distutils-r1_${1} "$@"
- popd >/dev/null
- fi
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- wrap_python ${FUNCNAME}
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCAPSTONE_BUILD_TESTS="$(usex test)"
- -DCAPSTONE_BUILD_STATIC="$(usex static-libs)"
- )
- cmake-utils_src_configure
-
- wrap_python ${FUNCNAME}
-}
-
-src_compile() {
- cmake-utils_src_compile
-
- wrap_python ${FUNCNAME}
-}
-
-src_test() {
- cmake-utils_src_test
-
- wrap_python ${FUNCNAME}
-}
-
-src_install() {
- cmake-utils_src_install
-
- wrap_python ${FUNCNAME}
-}