summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/check/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/check/files')
-rw-r--r--dev-libs/check/files/check-0.9.10-AM_PATH_CHECK.patch33
-rw-r--r--dev-libs/check/files/check-0.9.6-64bitsafe.patch13
-rw-r--r--dev-libs/check/files/check-0.9.6-AM_PATH_CHECK.patch12
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-libs/check/files/check-0.9.10-AM_PATH_CHECK.patch b/dev-libs/check/files/check-0.9.10-AM_PATH_CHECK.patch
new file mode 100644
index 000000000000..a433549a3639
--- /dev/null
+++ b/dev-libs/check/files/check-0.9.10-AM_PATH_CHECK.patch
@@ -0,0 +1,33 @@
+Index: doc/example/tests/Makefile.am
+===================================================================
+--- doc/example/tests/Makefile.am (revision 747)
++++ doc/example/tests/Makefile.am (working copy)
+@@ -3,5 +3,5 @@
+ TESTS = check_money
+ check_PROGRAMS = check_money
+ check_money_SOURCES = check_money.c $(top_builddir)/src/money.h
+-check_money_CFLAGS = @CHECK_CFLAGS@
+-check_money_LDADD = $(top_builddir)/src/libmoney.la @CHECK_LIBS@
++check_money_CFLAGS = $(CHECK_CFLAGS)
++check_money_LDADD = $(top_builddir)/src/libmoney.la $(CHECK_LIBS)
+Index: doc/example/configure.ac
+===================================================================
+--- doc/example/configure.ac (revision 747)
++++ doc/example/configure.ac (working copy)
+@@ -20,12 +20,10 @@
+
+ # Checks for libraries.
+
+-# This macro is defined in check.m4 and tests if check.h and
+-# libcheck.a are installed in your system. It sets CHECK_CFLAGS and
+-# CHECK_LIBS accordingly.
+-# AM_PATH_CHECK([MINIMUM-VERSION,
+-# [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
+-AM_PATH_CHECK()
++# Use pkg-config instead of upstream-provided and possibly-broken
++# AM_PATH_CHECK. This command sets CHECK_CFLAGS and CHECK_LIBS
++# appropriately.
++PKG_CHECK_MODULES([CHECK], [check])
+
+ # Checks for header files.
+ AC_HEADER_STDC
diff --git a/dev-libs/check/files/check-0.9.6-64bitsafe.patch b/dev-libs/check/files/check-0.9.6-64bitsafe.patch
new file mode 100644
index 000000000000..ec73ed6a0ea5
--- /dev/null
+++ b/dev-libs/check/files/check-0.9.6-64bitsafe.patch
@@ -0,0 +1,13 @@
+Index: check-0.9.6/configure.ac
+===================================================================
+--- check-0.9.6.orig/configure.ac
++++ check-0.9.6/configure.ac
+@@ -17,6 +17,8 @@ AC_CONFIG_AUX_DIR([build-aux])
+ # really severe build strictness
+ AM_INIT_AUTOMAKE([-Wall -Werror gnits 1.9.6])
+
++AC_USE_SYSTEM_EXTENSIONS
++
+ # FIXME: find the other places this stuff is used
+
+ CHECK_MAJOR_VERSION=0
diff --git a/dev-libs/check/files/check-0.9.6-AM_PATH_CHECK.patch b/dev-libs/check/files/check-0.9.6-AM_PATH_CHECK.patch
new file mode 100644
index 000000000000..7bb306187206
--- /dev/null
+++ b/dev-libs/check/files/check-0.9.6-AM_PATH_CHECK.patch
@@ -0,0 +1,12 @@
+diff -Naur check-0.9.5-orig/doc/example/configure.ac check-0.9.5/doc/example/configure.ac
+--- check-0.9.5-orig/doc/example/configure.ac 2006-11-21 17:19:14.000000000 -0600
++++ check-0.9.5/doc/example/configure.ac 2008-12-04 21:45:13.000000000 -0600
+@@ -25,7 +25,7 @@
+ # CHECK_LIBS accordingly.
+ # AM_PATH_CHECK([MINIMUM-VERSION,
+ # [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
+-AM_PATH_CHECK()
++PKG_CHECK_MODULES([check], [], [])
+
+ # Checks for header files.
+ AC_HEADER_STDC