summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-04-21 09:48:33 +0100
committerMarek Szuba <marecki@gentoo.org>2023-04-21 09:56:16 +0100
commit7577acd87b1984be61d6cd0ef5a5282045d95a34 (patch)
tree417d69a8764b88f190ec9dc4ec1e65520aac5381 /dev-libs/clhpp
parentdev-libs/opencl-icd-loader: add 2023.04.17 (diff)
downloadgentoo-7577acd87b1984be61d6cd0ef5a5282045d95a34.tar.gz
gentoo-7577acd87b1984be61d6cd0ef5a5282045d95a34.tar.bz2
gentoo-7577acd87b1984be61d6cd0ef5a5282045d95a34.zip
dev-libs/clhpp: add 2023.04.17
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-libs/clhpp')
-rw-r--r--dev-libs/clhpp/Manifest1
-rw-r--r--dev-libs/clhpp/clhpp-2023.04.17.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/clhpp/Manifest b/dev-libs/clhpp/Manifest
index 0c4457479866..65c9a396443f 100644
--- a/dev-libs/clhpp/Manifest
+++ b/dev-libs/clhpp/Manifest
@@ -1 +1,2 @@
DIST clhpp-2023.02.06.tar.gz 106874 BLAKE2B c57cdff048fe80b8fd95f14a77883f0d3eb7a64f7b9fea2661e0127172783ece911f908d7b6597e1b1b2cdfc86c1d841a3047d295a85408ba4c25cb5c8a262f8 SHA512 30252a832287375d550a5e184779881d5b22207a636298c7f52f277c219d3a1ae6983259cfea7bf4f90f0840fec114ee0e7a8c1e6a6fe48c24fd3b5119e7a7f8
+DIST clhpp-2023.04.17.tar.gz 115042 BLAKE2B df0db751eda9fe2f23a5e3ef97f263885a09ca4b341b24c9580522e84a192e9afe526a441d0e3660e8819492945b2ff89bff7c96cd1fd1b3bd6a177042ec759e SHA512 1e37af647a37737240de1622bd772e1f154a07c2d27e020487163c42d0833096c1a2f2f2185b8f6371889c2cad3992f0c7a9d233c36941367da743ee7ee8e486
diff --git a/dev-libs/clhpp/clhpp-2023.04.17.ebuild b/dev-libs/clhpp/clhpp-2023.04.17.ebuild
new file mode 100644
index 000000000000..a9a4c55d1789
--- /dev/null
+++ b/dev-libs/clhpp/clhpp-2023.04.17.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PN="OpenCL-CLHPP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Khronos OpenCL C++ bindings"
+HOMEPAGE="https://github.com/KhronosGroup/OpenCL-CLHPP/"
+SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Khronos-CLHPP"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+
+# Tests require CMock (NOT cmocka), which is currently not in Gentoo
+# and has been found to be extremely awkward to package.
+# Should it ever get packaged, consult git history for how to set things up
+# for the clhpp test suite.
+RESTRICT="test"
+
+RDEPEND="virtual/opencl"
+DEPEND="${RDEPEND}
+ >=dev-util/opencl-headers-${PV}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCS=OFF
+ -DBUILD_EXAMPLES=OFF
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}