summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2019-07-08 16:21:25 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2019-07-08 16:31:14 +0300
commit57980c409d0770cf99b2b9ab89e1b02220c5a4fa (patch)
tree358697d4f464434978d6e368e070af6936aaf36e /dev-libs/crypto++
parentdev-db/mariadb: Fix one further EAPI 7 path (diff)
downloadgentoo-57980c409d0770cf99b2b9ab89e1b02220c5a4fa.tar.gz
gentoo-57980c409d0770cf99b2b9ab89e1b02220c5a4fa.tar.bz2
gentoo-57980c409d0770cf99b2b9ab89e1b02220c5a4fa.zip
dev-libs/crypto++: USE cpu_flags_x86_sha->preview-cpu_flags_x86_sha
A temporary solution until cpu_flags_x86_sha available. Closes: https://bugs.gentoo.org/show_bug.cgi?id=689476 Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-libs/crypto++')
-rw-r--r--dev-libs/crypto++/crypto++-8.2.0-r2.ebuild4
-rw-r--r--dev-libs/crypto++/metadata.xml2
2 files changed, 3 insertions, 3 deletions
diff --git a/dev-libs/crypto++/crypto++-8.2.0-r2.ebuild b/dev-libs/crypto++/crypto++-8.2.0-r2.ebuild
index 41b85ded0216..77fc17f4d982 100644
--- a/dev-libs/crypto++/crypto++-8.2.0-r2.ebuild
+++ b/dev-libs/crypto++/crypto++-8.2.0-r2.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://www.cryptopp.com/cryptopp${PV//.}.zip"
LICENSE="Boost-1.0"
SLOT="0/8" # subslot is so version
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
-IUSE="+asm cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_pclmul cpu_flags_x86_sha cpu_flags_x86_sse2 cpu_flags_x86_sse4_2 cpu_flags_x86_ssse3 static-libs"
+IUSE="+asm cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_pclmul preview-cpu_flags_x86_sha cpu_flags_x86_sse2 cpu_flags_x86_sse4_2 cpu_flags_x86_ssse3 static-libs"
BDEPEND="app-arch/unzip"
@@ -40,7 +40,7 @@ src_prepare() {
use cpu_flags_x86_avx || config_add CRYPTOPP_DISABLE_AVX
use cpu_flags_x86_avx2 || config_add CRYPTOPP_DISABLE_AVX2
use cpu_flags_x86_pclmul || config_add CRYPTOPP_DISABLE_CLMUL
- use cpu_flags_x86_sha || config_add CRYPTOPP_DISABLE_SHANI
+ use preview-cpu_flags_x86_sha || config_add CRYPTOPP_DISABLE_SHANI
use cpu_flags_x86_sse2 || config_add CRYPTOPP_DISABLE_SSE2
use cpu_flags_x86_sse4_2 || config_add CRYPTOPP_DISABLE_SSE4
use cpu_flags_x86_ssse3 || config_add CRYPTOPP_DISABLE_SSSE3
diff --git a/dev-libs/crypto++/metadata.xml b/dev-libs/crypto++/metadata.xml
index 4ceb05b8abe2..f21838966449 100644
--- a/dev-libs/crypto++/metadata.xml
+++ b/dev-libs/crypto++/metadata.xml
@@ -11,7 +11,7 @@
</maintainer>
<use>
<flag name="asm">Support assembly hand optimized crypto functions (i.e. faster run time)</flag>
- <flag name="cpu_flags_x86_sha">Enable support for Intel's SHA instruction set (SHA-NI)</flag>
+ <flag name="preview-cpu_flags_x86_sha">Enable support for Intel's SHA instruction set (SHA-NI)</flag>
</use>
<upstream>
<remote-id type="github">weidai11/cryptopp</remote-id>