summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/cvector
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/cvector')
-rw-r--r--dev-libs/cvector/Manifest2
-rw-r--r--dev-libs/cvector/cvector-1.0.3-r1.ebuild44
-rw-r--r--dev-libs/cvector/cvector-1.0.3.1.ebuild44
-rw-r--r--dev-libs/cvector/files/1.0.3-LDFLAGS.patch17
-rw-r--r--dev-libs/cvector/files/1.0.3-dynlib.patch36
-rw-r--r--dev-libs/cvector/files/cvector-1.0.3.1-LDFLAGS.patch17
-rw-r--r--dev-libs/cvector/metadata.xml11
7 files changed, 171 insertions, 0 deletions
diff --git a/dev-libs/cvector/Manifest b/dev-libs/cvector/Manifest
new file mode 100644
index 000000000000..185df49b53c1
--- /dev/null
+++ b/dev-libs/cvector/Manifest
@@ -0,0 +1,2 @@
+DIST CVector-1.0.3.1.tar.gz 19761 SHA256 6492b2beb26c3179cdd19abc90dc47a685be471c594d5ab664283e1d3586acdc SHA512 41300e46873efa8a2cfc44c76788025385fa7b7a108cf9dd95e4e28d515d825d4a44786a7ffb130d727a42907d56e4f62e6f75a02c96333b6afdc06c336d538e WHIRLPOOL 507a2bf047bf84e7f5dab06fc6e715384bf013944331b1f8356cbb6e5fa2997442bfe1c3b95b426154e13cd9253a0330f0abb58b93f13b957836ba80fc49f9d6
+DIST CVector-1.0.3.tar.gz 41642 SHA256 d3fa92de3cd5ba8697abdbb52080248b2c252a81cf40a8ec639be301518d0ce3 SHA512 f43030d95aeb6ef230dada13903ad56049acd15379a0c04e08b6ce8d7df7baffa3bac166af0c3c93f018e00058e07680af655e71bc0d542a6da2ad1f18e95788 WHIRLPOOL 67c3a9c043388c05a418973f687eb5aee9e09a297b127deb93c1166eda5159f0b0fc63015ec68b5097551966ffe4229c60bdda671362b0e5470fd8891bd37413
diff --git a/dev-libs/cvector/cvector-1.0.3-r1.ebuild b/dev-libs/cvector/cvector-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..02c24e49df69
--- /dev/null
+++ b/dev-libs/cvector/cvector-1.0.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit base eutils toolchain-funcs versionator
+
+MY_PN=CVector
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="An ANSI C implementation of dynamic arrays to provide a crude approximation to the C++ vector class"
+HOMEPAGE="http://cvector.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-LDFLAGS.patch
+ "${FILESDIR}"/${PV}-dynlib.patch
+ )
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ CFLAGS="${CFLAGS}" \
+ all || die
+}
+
+src_install() {
+ dolib.so *.so.${PV} || die
+ dosym libCVector.so.${PV} /usr/$(get_libdir)/libCVector.so.$(get_version_component_range 1-2) || die
+ dosym libCVector.so.${PV} /usr/$(get_libdir)/libCVector.so.$(get_major_version) || die
+ dosym libCVector.so.${PV} /usr/$(get_libdir)/libCVector.so || die
+
+ insinto /usr/include
+ doins *.h || die
+
+ dodoc README_CVector.txt || die
+}
diff --git a/dev-libs/cvector/cvector-1.0.3.1.ebuild b/dev-libs/cvector/cvector-1.0.3.1.ebuild
new file mode 100644
index 000000000000..0f8dc7bfab4f
--- /dev/null
+++ b/dev-libs/cvector/cvector-1.0.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base eutils toolchain-funcs versionator
+
+MY_PN=CVector
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="An ANSI C implementation of dynamic arrays to provide a crude approximation to the C++ vector class"
+HOMEPAGE="http://cvector.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${MY_PN}-$(get_version_component_range 1-3)/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-LDFLAGS.patch
+ "${FILESDIR}"/1.0.3-dynlib.patch
+ )
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ CFLAGS="${CFLAGS}" \
+ all
+}
+
+src_install() {
+ ln -sf libCVector.so.$(get_version_component_range 1-3) libCVector.so.$(get_major_version) || die
+ ln -sf libCVector.so.$(get_version_component_range 1-3) libCVector.so || die
+ dolib.so libCVector.so*
+
+ doheader *.h
+
+ dodoc README_CVector.txt
+}
diff --git a/dev-libs/cvector/files/1.0.3-LDFLAGS.patch b/dev-libs/cvector/files/1.0.3-LDFLAGS.patch
new file mode 100644
index 000000000000..7e54e8120245
--- /dev/null
+++ b/dev-libs/cvector/files/1.0.3-LDFLAGS.patch
@@ -0,0 +1,17 @@
+--- Makefile 2009-07-08 04:02:56.000000000 +0200
++++ Makefile.new 2009-07-25 11:59:27.000000000 +0200
+@@ -89,10 +89,10 @@
+ endif
+
+ COMPILE_COMMAND = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c
+-LIBRARY_LINK_COMMAND = $(LIBTOOL) --mode=link $(CC) -version-info $(VERSION) -release $(RELEASE) -no-undefined -rpath $(INSTALL_PREFIX)/lib
+-BUILD_COMMAND_LOCAL = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(INCLUDES)
+-BUILD_COMMAND_DYNAMIC = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -shared -I $(INSTALL_PREFIX)/include
+-BUILD_COMMAND_STATIC = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -static -I $(INSTALL_PREFIX)/include
++LIBRARY_LINK_COMMAND = $(LIBTOOL) --mode=link $(CC) -version-info $(VERSION) -release $(RELEASE) -no-undefined $(LDFLAGS)
++BUILD_COMMAND_LOCAL = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(INCLUDES) $(LDFLAGS)
++BUILD_COMMAND_DYNAMIC = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -shared
++BUILD_COMMAND_STATIC = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -static
+ INSTALL_COMMAND = $(LIBTOOL) --mode=install cp
+ INSTALL_FINISH_COMMAND = $(LIBTOOL) --mode=finish
+
diff --git a/dev-libs/cvector/files/1.0.3-dynlib.patch b/dev-libs/cvector/files/1.0.3-dynlib.patch
new file mode 100644
index 000000000000..219f258136ed
--- /dev/null
+++ b/dev-libs/cvector/files/1.0.3-dynlib.patch
@@ -0,0 +1,36 @@
+diff --git a/Makefile b/Makefile
+index 865db81..2691108 100644
+--- a/Makefile
++++ b/Makefile
+@@ -96,8 +96,8 @@ BUILD_COMMAND_STATIC = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -static -I $(IN
+ INSTALL_COMMAND = $(LIBTOOL) --mode=install cp
+ INSTALL_FINISH_COMMAND = $(LIBTOOL) --mode=finish
+
+-OBJ_EXT = lo
+-LIB_EXT = la
++OBJ_EXT = o
++LIB_EXT = so
+
+ ######################################################################
+ # You should not need to make modifications below this line #
+@@ -181,8 +181,7 @@ default:
+ # Compile the library and examples
+ #
+ all: $(LIB) $(BIN) $(SOURCE) $(HEADERS) \
+- $(LIB)/libCVector.$(LIB_EXT) \
+- $(BIN)/CVectorBasicTest
++ $(LIB)/libCVector.$(LIB_EXT)
+
+ install: all $(INSTALL_PREFIX) $(INSTALL_PREFIX)/lib $(INSTALL_PREFIX)/include \
+ $(INC) $(LIB)/libCVector.$(LIB_EXT) $(INC)/CVector.h
+@@ -232,8 +231,8 @@ $(BIN):
+ # CVector library
+ #
+ $(LIB)/libCVector.$(LIB_EXT): $(SOURCE) $(HEADERS) $(COMMONDEP)
+- $(COMPILE_COMMAND) -c $(SOURCE)
+- $(LIBRARY_LINK_COMMAND) -o $(LIB)/libCVector.$(LIB_EXT) *.$(OBJ_EXT)
++ $(CC) $(CFLAGS) -fPIC -c $(SOURCE) -o CVector.o -I.
++ $(CC) $(LDFLAGS) -Wl,--soname,libCVector.so.1 -shared -o libCVector.so.$(RELEASE) *.$(OBJ_EXT) -lm
+
+ #
+ # CVectorBasicTest example program
diff --git a/dev-libs/cvector/files/cvector-1.0.3.1-LDFLAGS.patch b/dev-libs/cvector/files/cvector-1.0.3.1-LDFLAGS.patch
new file mode 100644
index 000000000000..8bed3ab01546
--- /dev/null
+++ b/dev-libs/cvector/files/cvector-1.0.3.1-LDFLAGS.patch
@@ -0,0 +1,17 @@
+--- Makefile 2009-07-08 04:02:56.000000000 +0200
++++ Makefile.new 2009-07-25 11:59:27.000000000 +0200
+@@ -89,10 +89,10 @@
+ endif
+
+ COMPILE_COMMAND = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c
+-LIBRARY_LINK_COMMAND = $(LIBTOOL) --mode=link $(CC) -version-info $(VERSION) -release $(RELEASE) -no-undefined -rpath $(INSTALL_PREFIX)/lib
+-BUILD_COMMAND_LOCAL = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(INCLUDES)
+-BUILD_COMMAND_DYNAMIC = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -dynamic -I $(INSTALL_PREFIX)/include
+-BUILD_COMMAND_STATIC = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -static -I $(INSTALL_PREFIX)/include
++LIBRARY_LINK_COMMAND = $(LIBTOOL) --mode=link $(CC) -version-info $(VERSION) -release $(RELEASE) -no-undefined $(LDFLAGS)
++BUILD_COMMAND_LOCAL = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(INCLUDES) $(LDFLAGS)
++BUILD_COMMAND_DYNAMIC = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -shared
++BUILD_COMMAND_STATIC = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -static
+ INSTALL_COMMAND = $(LIBTOOL) --mode=install cp
+ INSTALL_FINISH_COMMAND = $(LIBTOOL) --mode=finish
+
diff --git a/dev-libs/cvector/metadata.xml b/dev-libs/cvector/metadata.xml
new file mode 100644
index 000000000000..b85f98e6bb05
--- /dev/null
+++ b/dev-libs/cvector/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>sci@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">cvector</remote-id>
+ </upstream>
+</pkgmetadata>