summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/djb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/djb')
-rw-r--r--dev-libs/djb/Manifest1
-rw-r--r--dev-libs/djb/djb-0.5.2.ebuild40
-rw-r--r--dev-libs/djb/metadata.xml7
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/djb/Manifest b/dev-libs/djb/Manifest
new file mode 100644
index 000000000000..9bb8b28c9b11
--- /dev/null
+++ b/dev-libs/djb/Manifest
@@ -0,0 +1 @@
+DIST djb-0.5.2.tar.bz2 51048 SHA256 96ab53512aa85878b282a7607ebbaaf9bd2f20ca734aac76851bf608ec7321b4 SHA512 9c3f5d9e61e2e9ed11dddfd5edbaac9a35cca94ed7ced7cbfdaf0ed9dd311b16b2cd11259757d17bfa711ccbf0998a10e9a45ae8db643b21138b630cc665cef8 WHIRLPOOL c39bda737bb4ec767dc2f8b6e936bf1c5d313ca987878ffb447724502e7970792be2e2911cd0942b3a4a31aa6c8aba2d9400ef9c68f0ae38c8777c1aaf384cbb
diff --git a/dev-libs/djb/djb-0.5.2.ebuild b/dev-libs/djb/djb-0.5.2.ebuild
new file mode 100644
index 000000000000..f5aae997590a
--- /dev/null
+++ b/dev-libs/djb/djb-0.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs fixheadtails
+
+DESCRIPTION="Library created from code by Dan Bernstein"
+HOMEPAGE="http://www.fefe.de/djb/"
+SRC_URI="http://www.fefe.de/djb/djb-${PV}.tar.bz2"
+
+LICENSE="all-rights-reserved public-domain"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+RESTRICT="mirror bindist"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ht_fix_file */Makefile.static
+ for cc in */conf-cc ; do echo "$(tc-getCC) ${CFLAGS}" > ${cc} ; done
+ for ld in */conf-ld ; do echo "$(tc-getCC) ${LDFLAGS}" > ${ld} ; done
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ for lib in */*.a ; do
+ newlib.a ${lib} libdjb-$(basename ${lib}) || die "newlib failed"
+ done
+ for man in */*.3 ; do
+ newman ${man} ${PN}-$(basename ${man})
+ done
+ exeinto /usr/lib/${PN}
+ doexe *.pl || die "doexe .pl failed"
+ dodoc CHANGES TODO
+}
diff --git a/dev-libs/djb/metadata.xml b/dev-libs/djb/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/dev-libs/djb/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>