summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/ecore
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/ecore')
-rw-r--r--dev-libs/ecore/Manifest1
-rw-r--r--dev-libs/ecore/ecore-1.7.10.ebuild201
-rw-r--r--dev-libs/ecore/ecore-9999.ebuild201
-rw-r--r--dev-libs/ecore/metadata.xml67
4 files changed, 470 insertions, 0 deletions
diff --git a/dev-libs/ecore/Manifest b/dev-libs/ecore/Manifest
new file mode 100644
index 000000000000..c94ec78a030b
--- /dev/null
+++ b/dev-libs/ecore/Manifest
@@ -0,0 +1 @@
+DIST ecore-1.7.10.tar.bz2 3455136 SHA256 c3f27ab18517b85b286871c6c7ccf8e22347f0661502db0fbf401537fa5a4bb6 SHA512 24fbe064913c566f885a2e51185b1f1d37c62c0d03ba0d549e9715ba516fb6b3f630ad331f89f66e91de1401b06b01b16916650448dda11d5e1efa24e52eaf39 WHIRLPOOL 93c187d8e8481f016aef07cefc99621eed136f43055387d31936c1745ac7929f71443f40cd26873b0cca891342dbff818e31b709cfb28385414dc78c890edcae
diff --git a/dev-libs/ecore/ecore-1.7.10.ebuild b/dev-libs/ecore/ecore-1.7.10.ebuild
new file mode 100644
index 000000000000..37a00d0e05bb
--- /dev/null
+++ b/dev-libs/ecore/ecore-1.7.10.ebuild
@@ -0,0 +1,201 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+# virtualx is required for tests, which are currently broken
+#inherit virtualx
+inherit enlightenment eutils
+
+DESCRIPTION="Enlightenment's core event abstraction layer and OS abstraction layer"
+
+LICENSE="BSD-2"
+IUSE="ares curl directfb +evas examples fbcon gles glib gnutls +inotify ipv6 opengl sdl ssl static-libs +threads tslib wayland +X xcb xinerama xprint xscreensaver"
+
+RDEPEND=">=dev-libs/eina-${PV}
+ ares? ( net-dns/c-ares )
+ glib? ( dev-libs/glib )
+ curl? ( net-misc/curl )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )
+ evas? (
+ >=media-libs/evas-${PV}[directfb?,fbcon?,opengl?,X?,xcb?]
+ opengl? ( virtual/opengl )
+ wayland? (
+ >=media-libs/evas-${PV}[directfb?,fbcon?,gles?,opengl?,wayland?,X?,xcb?]
+ )
+ )
+ directfb? ( >=dev-libs/DirectFB-0.9.16 )
+ tslib? ( x11-libs/tslib )
+ sdl? ( media-libs/libsdl )
+ wayland? ( dev-libs/wayland )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ xinerama? ( x11-libs/libXinerama x11-libs/libXrandr )
+ xprint? ( x11-libs/libXp )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ )
+ !X? ( xcb? (
+ x11-libs/pixman
+ x11-libs/xcb-util
+ ) )"
+DEPEND="${RDEPEND}"
+
+# tests depend on temp data from eina WORKDIR.
+RESTRICT="test"
+
+src_configure() {
+ local ssl_flags=() evas_flags=() x_flags=()
+
+ if use gnutls && use ssl; then
+ einfo "You have enabled both 'ssl' and 'gnutls', so we will use"
+ einfo "gnutls and not openssl for ecore-con support."
+ fi
+ ssl_flags=(
+ $(usex gnutls "--disable-openssl" "$(use_enable ssl openssl)")
+ $(use_enable gnutls)
+ )
+
+ local x_or_xcb=$(usex X "X" "$(usev xcb)")
+
+ if use evas; then
+ if use opengl && [[ -z ${x_or_xcb} ]]; then
+ ewarn "Ecore/Evas usage of OpenGL requires X11."
+ ewarn "Compile dev-libs/ecore with USE=X or xcb."
+ ewarn "Compiling without opengl support."
+ evas_flags=(
+ --disable-ecore-evas-software-x11
+ --disable-ecore-evas-software-16-x11
+ )
+ else
+ evas_flags=(
+ --enable-ecore-evas-software-x11
+ --enable-ecore-evas-software-16-x11
+ )
+ fi
+ evas_flags+=(
+ $(use_enable directfb ecore-evas-directfb)
+ $(use_enable fbcon ecore-evas-fb)
+ $(use_enable opengl ecore-evas-opengl-x11)
+ $(use_enable wayland ecore-evas-wayland-shm)
+ $(usex wayland "--disable-ecore-evas-wayland-egl" "$(use_enable gles ecore-evas-wayland-egl)")
+ )
+ else
+ evas_flags=(
+ --disable-ecore-evas-directfb
+ --disable-ecore-evas-fb
+ --disable-ecore-evas-software-x11
+ --disable-ecore-evas-software-16-x11
+ --disable-ecore-evas-opengl-x11
+ --disable-ecore-evas-wayland-shm
+ --disable-ecore-evas-wayland-egl
+ )
+ if use opengl; then
+ ewarn "Ecore usage of OpenGL is dependent on media-libs/evas."
+ ewarn "Compile dev-libs/ecore with USE=evas."
+ fi
+ fi
+
+ if use X; then
+ if use xcb; then
+ ewarn "You have enabled both 'X' and 'xcb', so we will use"
+ ewarn "X as it's considered the most stable for ecore-x."
+ fi
+ x_flags=(
+ --enable-ecore-x
+ --disable-ecore-x-xcb
+ )
+ elif use xcb; then
+ x_flags=(
+ --enable-ecore-x
+ --enable-ecore-x-xcb
+ )
+ else
+ x_flags=(
+ --disable-ecore-x
+ --disable-ecore-x-xcb
+ )
+ fi
+
+ if [[ -n ${x_or_xcb} ]]; then
+ x_flags+=(
+ $(use_enable xinerama ecore-x-xinerama)
+ $(use_enable xprint ecore-x-xprint)
+ $(use_enable xscreensaver ecore-x-screensaver)
+ )
+ else
+ x_flags+=(
+ --disable-ecore-x-xinerama
+ --disable-ecore-x-xprint
+ --disable-ecore-x-screensaver
+ )
+ fi
+
+ if use tslib && ! use fbcon; then
+ ewarn "Ecore just uses tslib for framebuffer input."
+ ewarn "Compile dev-libs/ecore with USE=fbcon."
+ fi
+
+ E_ECONF=(
+ --enable-ecore-con
+ --enable-ecore-ipc
+ --enable-ecore-file
+ --enable-ecore-imf
+ --enable-ecore-input
+ --disable-ecore-win32
+ --disable-ecore-wince
+ --disable-ecore-evas-software-gdi
+ --disable-ecore-evas-software-ddraw
+ --disable-ecore-evas-direct3d
+ --disable-ecore-evas-opengl-glew
+ --disable-ecore-evas-software-16-ddraw
+ --disable-ecore-evas-software-16-wince
+ --disable-ecore_imf_scim
+ $(use_enable ares cares)
+ $(use_enable curl)
+ $(use_enable directfb ecore-directfb)
+ $(use_enable doc)
+ $(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ $(use_enable evas ecore-evas)
+ $(use_enable evas ecore-input-evas)
+ $(use_enable evas ecore-imf-evas)
+ $(use_enable evas ecore-evas-software-buffer)
+ $(use_enable fbcon ecore-fb)
+ $(use_enable glib)
+ $(use_enable inotify)
+ $(use_enable ipv6)
+ $(use_enable sdl ecore-sdl)
+ $(use_enable test tests)
+ $(use_enable threads posix-threads)
+ $(use_enable tslib)
+ $(use_enable wayland ecore-wayland)
+ $(use_enable X xim)
+ "${ssl_flags[@]}"
+ "${evas_flags[@]}"
+ "${x_flags[@]}"
+ )
+ enlightenment_src_configure
+}
+
+src_test() {
+ Xemake check
+}
diff --git a/dev-libs/ecore/ecore-9999.ebuild b/dev-libs/ecore/ecore-9999.ebuild
new file mode 100644
index 000000000000..37a00d0e05bb
--- /dev/null
+++ b/dev-libs/ecore/ecore-9999.ebuild
@@ -0,0 +1,201 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+# virtualx is required for tests, which are currently broken
+#inherit virtualx
+inherit enlightenment eutils
+
+DESCRIPTION="Enlightenment's core event abstraction layer and OS abstraction layer"
+
+LICENSE="BSD-2"
+IUSE="ares curl directfb +evas examples fbcon gles glib gnutls +inotify ipv6 opengl sdl ssl static-libs +threads tslib wayland +X xcb xinerama xprint xscreensaver"
+
+RDEPEND=">=dev-libs/eina-${PV}
+ ares? ( net-dns/c-ares )
+ glib? ( dev-libs/glib )
+ curl? ( net-misc/curl )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )
+ evas? (
+ >=media-libs/evas-${PV}[directfb?,fbcon?,opengl?,X?,xcb?]
+ opengl? ( virtual/opengl )
+ wayland? (
+ >=media-libs/evas-${PV}[directfb?,fbcon?,gles?,opengl?,wayland?,X?,xcb?]
+ )
+ )
+ directfb? ( >=dev-libs/DirectFB-0.9.16 )
+ tslib? ( x11-libs/tslib )
+ sdl? ( media-libs/libsdl )
+ wayland? ( dev-libs/wayland )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ xinerama? ( x11-libs/libXinerama x11-libs/libXrandr )
+ xprint? ( x11-libs/libXp )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ )
+ !X? ( xcb? (
+ x11-libs/pixman
+ x11-libs/xcb-util
+ ) )"
+DEPEND="${RDEPEND}"
+
+# tests depend on temp data from eina WORKDIR.
+RESTRICT="test"
+
+src_configure() {
+ local ssl_flags=() evas_flags=() x_flags=()
+
+ if use gnutls && use ssl; then
+ einfo "You have enabled both 'ssl' and 'gnutls', so we will use"
+ einfo "gnutls and not openssl for ecore-con support."
+ fi
+ ssl_flags=(
+ $(usex gnutls "--disable-openssl" "$(use_enable ssl openssl)")
+ $(use_enable gnutls)
+ )
+
+ local x_or_xcb=$(usex X "X" "$(usev xcb)")
+
+ if use evas; then
+ if use opengl && [[ -z ${x_or_xcb} ]]; then
+ ewarn "Ecore/Evas usage of OpenGL requires X11."
+ ewarn "Compile dev-libs/ecore with USE=X or xcb."
+ ewarn "Compiling without opengl support."
+ evas_flags=(
+ --disable-ecore-evas-software-x11
+ --disable-ecore-evas-software-16-x11
+ )
+ else
+ evas_flags=(
+ --enable-ecore-evas-software-x11
+ --enable-ecore-evas-software-16-x11
+ )
+ fi
+ evas_flags+=(
+ $(use_enable directfb ecore-evas-directfb)
+ $(use_enable fbcon ecore-evas-fb)
+ $(use_enable opengl ecore-evas-opengl-x11)
+ $(use_enable wayland ecore-evas-wayland-shm)
+ $(usex wayland "--disable-ecore-evas-wayland-egl" "$(use_enable gles ecore-evas-wayland-egl)")
+ )
+ else
+ evas_flags=(
+ --disable-ecore-evas-directfb
+ --disable-ecore-evas-fb
+ --disable-ecore-evas-software-x11
+ --disable-ecore-evas-software-16-x11
+ --disable-ecore-evas-opengl-x11
+ --disable-ecore-evas-wayland-shm
+ --disable-ecore-evas-wayland-egl
+ )
+ if use opengl; then
+ ewarn "Ecore usage of OpenGL is dependent on media-libs/evas."
+ ewarn "Compile dev-libs/ecore with USE=evas."
+ fi
+ fi
+
+ if use X; then
+ if use xcb; then
+ ewarn "You have enabled both 'X' and 'xcb', so we will use"
+ ewarn "X as it's considered the most stable for ecore-x."
+ fi
+ x_flags=(
+ --enable-ecore-x
+ --disable-ecore-x-xcb
+ )
+ elif use xcb; then
+ x_flags=(
+ --enable-ecore-x
+ --enable-ecore-x-xcb
+ )
+ else
+ x_flags=(
+ --disable-ecore-x
+ --disable-ecore-x-xcb
+ )
+ fi
+
+ if [[ -n ${x_or_xcb} ]]; then
+ x_flags+=(
+ $(use_enable xinerama ecore-x-xinerama)
+ $(use_enable xprint ecore-x-xprint)
+ $(use_enable xscreensaver ecore-x-screensaver)
+ )
+ else
+ x_flags+=(
+ --disable-ecore-x-xinerama
+ --disable-ecore-x-xprint
+ --disable-ecore-x-screensaver
+ )
+ fi
+
+ if use tslib && ! use fbcon; then
+ ewarn "Ecore just uses tslib for framebuffer input."
+ ewarn "Compile dev-libs/ecore with USE=fbcon."
+ fi
+
+ E_ECONF=(
+ --enable-ecore-con
+ --enable-ecore-ipc
+ --enable-ecore-file
+ --enable-ecore-imf
+ --enable-ecore-input
+ --disable-ecore-win32
+ --disable-ecore-wince
+ --disable-ecore-evas-software-gdi
+ --disable-ecore-evas-software-ddraw
+ --disable-ecore-evas-direct3d
+ --disable-ecore-evas-opengl-glew
+ --disable-ecore-evas-software-16-ddraw
+ --disable-ecore-evas-software-16-wince
+ --disable-ecore_imf_scim
+ $(use_enable ares cares)
+ $(use_enable curl)
+ $(use_enable directfb ecore-directfb)
+ $(use_enable doc)
+ $(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ $(use_enable evas ecore-evas)
+ $(use_enable evas ecore-input-evas)
+ $(use_enable evas ecore-imf-evas)
+ $(use_enable evas ecore-evas-software-buffer)
+ $(use_enable fbcon ecore-fb)
+ $(use_enable glib)
+ $(use_enable inotify)
+ $(use_enable ipv6)
+ $(use_enable sdl ecore-sdl)
+ $(use_enable test tests)
+ $(use_enable threads posix-threads)
+ $(use_enable tslib)
+ $(use_enable wayland ecore-wayland)
+ $(use_enable X xim)
+ "${ssl_flags[@]}"
+ "${evas_flags[@]}"
+ "${x_flags[@]}"
+ )
+ enlightenment_src_configure
+}
+
+src_test() {
+ Xemake check
+}
diff --git a/dev-libs/ecore/metadata.xml b/dev-libs/ecore/metadata.xml
new file mode 100644
index 000000000000..0d3f182ac50c
--- /dev/null
+++ b/dev-libs/ecore/metadata.xml
@@ -0,0 +1,67 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>enlightenment</herd>
+<use>
+ <flag name="ares">Enables support for asynchronous DNS using the <pkg>net-dns/c-ares</pkg> library</flag>
+ <flag name="gles">Add gles support to the ecore-evas-wayland module</flag>
+ <flag name="glib">Enable <pkg>dev-libs/glib</pkg> eventloop support</flag>
+ <flag name="xprint">Enable X11 Xprint support</flag>
+ <flag name="inotify">Enable support for inotify</flag>
+ <flag name="evas">Provides easy to use canvas by gluing <pkg>media-libs/evas</pkg> and various input/output systems.</flag>
+ <flag name="tslib">Build with tslib support for touchscreen devices.</flag>
+ <flag name="wayland">Add support for <pkg>dev-libs/wayland</pkg></flag>
+</use>
+<longdescription>
+Ecore is a clean and tiny event loop library with many modules to do
+lots of convenient things for a programmer, to save time and effort.
+
+It's small and lean, designed to work on embedded systems all the way
+to large and powerful multi-cpu workstations. It serialises all system
+signals, events etc. into a single event queue, that is easily
+processed without needing to worry about concurrency. A properly
+written, event-driven program using this kind of programming doesn't
+need threads, nor has to worry about concurrency. It turns a program
+into a state machine, and makes it very robust and easy to follow.
+
+Ecore gives you other handy primitives, such as timers to tick over
+for you and call specified functions at particular times so the
+programmer can use this to do things, like animate, or time out on
+connections or tasks that take too long etc.
+
+Idle handlers are provided too, as well as calls on entering an idle
+state (often a very good time to update the state of the program). All
+events that enter the system are passed to specific callback functions
+that the program sets up to handle those events. Handling them is
+simple and other Ecore modules produce more events on the queue,
+coming from other sources such as file descriptors etc.
+
+Ecore also lets you have functions called when file descriptors become
+active for reading or writing, allowing for streamlined, non-blocking
+IO.
+
+Ecore may provide (if enabled) the following libraries:
+
+ * ecore: main loop, signals, and base;
+
+ * ecore_con: http/ftp (curl) access;
+
+ * ecore_file: easy file manipulation (copy, move, symlink, remove),
+ monitoring and directory (mkdir, mkdir -p, rm -fr);
+
+ * ecore_txt: text charset conversion (iconv wrapper);
+
+ * ecore_evas: integrates <pkg>media-libs/evas</pkg> into different
+ input and output systems, providing easy to use canvas;
+
+ * ecore_x, ecore_sdl, ecore_quartz, ecore_directfb, ecore_win32,
+ ecore_wince, ecore_fb: access to different input/output systems,
+ mapping them to ecore main loop and events;
+
+ * ecore_imf, ecore_imf_evas: input-method framework used to integrate
+ with different input methods such as virtual keyboards;
+
+ * ecore_input, ecore_input_evas: abstraction of input events.
+
+</longdescription>
+</pkgmetadata>