summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-02-07 19:07:25 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-02-07 19:10:10 +0000
commit0896a41030c4e795e49e48241823e01686c8de69 (patch)
treecabb753126cf7d465e4656050a43fe05939fdd63 /dev-libs/elfutils
parentprofiles/prefix/darwin/macos/11.0/arm64: mask SSP with GCC (diff)
downloadgentoo-0896a41030c4e795e49e48241823e01686c8de69.tar.gz
gentoo-0896a41030c4e795e49e48241823e01686c8de69.tar.bz2
gentoo-0896a41030c4e795e49e48241823e01686c8de69.zip
dev-libs/elfutils: bump up to 0.183
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-libs/elfutils')
-rw-r--r--dev-libs/elfutils/Manifest1
-rw-r--r--dev-libs/elfutils/elfutils-0.183.ebuild87
-rw-r--r--dev-libs/elfutils/files/elfutils-0.183-CC-quote.patch40
3 files changed, 128 insertions, 0 deletions
diff --git a/dev-libs/elfutils/Manifest b/dev-libs/elfutils/Manifest
index 1b1bbed5921f..d75fa38fc21d 100644
--- a/dev-libs/elfutils/Manifest
+++ b/dev-libs/elfutils/Manifest
@@ -1,2 +1,3 @@
DIST elfutils-0.181.tar.bz2 9088984 BLAKE2B 3f35f1a494986ff23d755188aab2b8f5ca9729927dd0e01725abf8477ac09721f751ff79686aafeff3878cf52e0c3f3e06d794fdf6371382a1bffc85c0de3411 SHA512 d565541d5817f409dc89ebb1ee593366f69c371a1531308eeb67ff934b14a0fab0c9009fd7c23240efbaa1b4e04edac5c425e47d80e3e66ba03dcaf000afea36
DIST elfutils-0.182.tar.bz2 9096742 BLAKE2B 59efd76c921a90a5ac18a62a00845080b574f167ae633d32b14acce554523736d0ccfdf539ba61e8ec1511b3294b486e0fa512887582a2e5cc34e71954e87e73 SHA512 8ab0735bbe11b4383169341bf674ace360038b6ae5239f1d5a991c46260cd4bce545e078735b7de3b8fab132bb5da41f60689ff1b1d7ebccfada117a954a2c81
+DIST elfutils-0.183.tar.bz2 9109254 BLAKE2B 8dd92e7c2df13d51bb51085f6cf762ea1ec7b803dcebf1202a4441ba152ed0e3332b1267276de4650d5ed5c5bed656f72f4c4e9bbf20700be45312a202351574 SHA512 bdafdd738a33cebe4f87849e5e6f1133881e77ef71b27faa0f0234ff80e9674f506957898326c2a55fd8438cbd189f7930597d0b4b9ca6c77921cc0cbd83b6b7
diff --git a/dev-libs/elfutils/elfutils-0.183.ebuild b/dev-libs/elfutils/elfutils-0.183.ebuild
new file mode 100644
index 000000000000..d12889034536
--- /dev/null
+++ b/dev-libs/elfutils/elfutils-0.183.ebuild
@@ -0,0 +1,87 @@
+# Copyright 2003-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multilib-minimal toolchain-funcs
+
+DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
+HOMEPAGE="http://elfutils.org/"
+SRC_URI="https://sourceware.org/elfutils/ftp/${PV}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2+ LGPL-3+ ) utils? ( GPL-3+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 lzma nls static-libs test +threads +utils valgrind zstd"
+
+RDEPEND=">=sys-libs/zlib-1.2.8-r1[static-libs?,${MULTILIB_USEDEP}]
+ bzip2? ( >=app-arch/bzip2-1.0.6-r4[static-libs?,${MULTILIB_USEDEP}] )
+ lzma? ( >=app-arch/xz-utils-5.0.5-r1[static-libs?,${MULTILIB_USEDEP}] )
+ zstd? ( app-arch/zstd:=[static-libs?,${MULTILIB_USEDEP}] )
+ !dev-libs/libelf
+"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )
+"
+BDEPEND="nls? ( sys-devel/gettext )
+ >=sys-devel/flex-2.5.4a
+ sys-devel/m4
+"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.175-disable-biarch-test-PR24158.patch
+ "${FILESDIR}"/${PN}-0.177-disable-large.patch
+ "${FILESDIR}"/${PN}-0.180-PaX-support.patch
+ "${FILESDIR}"/${PN}-0.183-CC-quote.patch
+)
+
+src_prepare() {
+ default
+
+ if ! use static-libs; then
+ sed -i -e '/^lib_LIBRARIES/s:=.*:=:' -e '/^%.os/s:%.o$::' lib{asm,dw,elf}/Makefile.in || die
+ fi
+ # https://sourceware.org/PR23914
+ sed -i 's:-Werror::' */Makefile.in || die
+}
+
+src_configure() {
+ use test && append-flags -g #407135
+
+ # Symbol aliases are implemented as asm statements.
+ # Will require porting: https://gcc.gnu.org/PR48200
+ filter-flags '-flto*'
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable nls) \
+ $(use_enable threads thread-safety) \
+ $(use_enable valgrind) \
+ --disable-debuginfod \
+ --disable-libdebuginfod \
+ --program-prefix="eu-" \
+ --with-zlib \
+ $(use_with bzip2 bzlib) \
+ $(use_with lzma) \
+ $(use_with zstd)
+}
+
+multilib_src_test() {
+ env LD_LIBRARY_PATH="${BUILD_DIR}/libelf:${BUILD_DIR}/libebl:${BUILD_DIR}/libdw:${BUILD_DIR}/libasm" \
+ LC_ALL="C" \
+ emake check VERBOSE=1
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dodoc NOTES
+ # These build quick, and are needed for most tests, so don't
+ # disable their building when the USE flag is disabled.
+ if ! use utils; then
+ rm -rf "${ED}"/usr/bin || die
+ fi
+}
diff --git a/dev-libs/elfutils/files/elfutils-0.183-CC-quote.patch b/dev-libs/elfutils/files/elfutils-0.183-CC-quote.patch
new file mode 100644
index 000000000000..8dc59bec262a
--- /dev/null
+++ b/dev-libs/elfutils/files/elfutils-0.183-CC-quote.patch
@@ -0,0 +1,40 @@
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -528,7 +528,7 @@ installed_TESTS_ENVIRONMENT = libdir=$(DESTDIR)$(libdir); \
+ export LC_ALL; export LANG; export VALGRIND_CMD; \
+ unset DEBUGINFOD_URLS; \
+ NM=$(NM); export NM; \
+- CC=$(CC); export CC;
++ CC="$(CC)"; export CC;
+ installed_LOG_COMPILER = $(abs_srcdir)/test-wrapper.sh \
+ installed $(tests_rpath) \
+ '$(program_transform_name)'
+@@ -540,7 +540,7 @@ TESTS_ENVIRONMENT = LC_ALL=C; LANG=C; VALGRIND_CMD=$(valgrind_cmd); \
+ export LC_ALL; export LANG; export VALGRIND_CMD; \
+ unset DEBUGINFOD_URLS; \
+ NM=$(NM); export NM; \
+- CC=$(CC); export CC;
++ CC="$(CC)"; export CC;
+ LOG_COMPILER = $(abs_srcdir)/test-wrapper.sh \
+ $(abs_top_builddir)/libdw:$(abs_top_builddir)/backends:$(abs_top_builddir)/libelf:$(abs_top_builddir)/libasm:$(abs_top_builddir)/debuginfod
+
+--- a/tests/Makefile.in
++++ b/tests/Makefile.in
+@@ -1568,7 +1568,7 @@ installed_TESTS_ENVIRONMENT = libdir=$(DESTDIR)$(libdir); \
+ export LC_ALL; export LANG; export VALGRIND_CMD; \
+ unset DEBUGINFOD_URLS; \
+ NM=$(NM); export NM; \
+- CC=$(CC); export CC;
++ CC="$(CC)"; export CC;
+
+ installed_LOG_COMPILER = $(abs_srcdir)/test-wrapper.sh \
+ installed $(tests_rpath) \
+@@ -1582,7 +1582,7 @@ TESTS_ENVIRONMENT = LC_ALL=C; LANG=C; VALGRIND_CMD=$(valgrind_cmd); \
+ export LC_ALL; export LANG; export VALGRIND_CMD; \
+ unset DEBUGINFOD_URLS; \
+ NM=$(NM); export NM; \
+- CC=$(CC); export CC;
++ CC="$(CC)"; export CC;
+
+ LOG_COMPILER = $(abs_srcdir)/test-wrapper.sh \
+ $(abs_top_builddir)/libdw:$(abs_top_builddir)/backends:$(abs_top_builddir)/libelf:$(abs_top_builddir)/libasm:$(abs_top_builddir)/debuginfod