summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-08-07 22:54:46 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-08-07 22:54:56 +0100
commit0b7fca2f0fc7284950bf7204942fb45cdb3879ba (patch)
tree2dde373db1429557410a2f2c541d007ad4722bb9 /dev-libs/elfutils
parentdev-libs/elfutils: Version bump to 0.170 (diff)
downloadgentoo-0b7fca2f0fc7284950bf7204942fb45cdb3879ba.tar.gz
gentoo-0b7fca2f0fc7284950bf7204942fb45cdb3879ba.tar.bz2
gentoo-0b7fca2f0fc7284950bf7204942fb45cdb3879ba.zip
dev-libs/elfutils: make patch appliable with -p1
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-libs/elfutils')
-rw-r--r--dev-libs/elfutils/elfutils-0.170.ebuild4
-rw-r--r--dev-libs/elfutils/files/elfutils-0.118-PaX-support.patch8
2 files changed, 7 insertions, 5 deletions
diff --git a/dev-libs/elfutils/elfutils-0.170.ebuild b/dev-libs/elfutils/elfutils-0.170.ebuild
index c6b460b456ef..bf9aa9d2e541 100644
--- a/dev-libs/elfutils/elfutils-0.170.ebuild
+++ b/dev-libs/elfutils/elfutils-0.170.ebuild
@@ -23,9 +23,11 @@ DEPEND="${RDEPEND}
>=sys-devel/flex-2.5.4a
sys-devel/m4"
+PATCHES=("${FILESDIR}"/${PN}-0.118-PaX-support.patch)
+
src_prepare() {
default
- epatch "${FILESDIR}"/${PN}-0.118-PaX-support.patch
+
if use static-libs; then
sed -i -e '/^lib_LIBRARIES/s:=.*:=:' -e '/^%.os/s:%.o$::' lib{asm,dw,elf}/Makefile.in || die
fi
diff --git a/dev-libs/elfutils/files/elfutils-0.118-PaX-support.patch b/dev-libs/elfutils/files/elfutils-0.118-PaX-support.patch
index 083f32ff8553..0ae359fe7dbb 100644
--- a/dev-libs/elfutils/files/elfutils-0.118-PaX-support.patch
+++ b/dev-libs/elfutils/files/elfutils-0.118-PaX-support.patch
@@ -4,8 +4,8 @@ Patch by Kevin F. Quinn <kevquinn@gentoo.org>
http://bugs.gentoo.org/115100
---- libelf/elf.h
-+++ libelf/elf.h
+--- a/libelf/elf.h
++++ b/libelf/elf.h
@@ -568,6 +568,7 @@
#define PT_GNU_EH_FRAME 0x6474e550 /* GCC .eh_frame_hdr segment */
#define PT_GNU_STACK 0x6474e551 /* Indicates stack executability */
@@ -14,8 +14,8 @@ http://bugs.gentoo.org/115100
#define PT_LOSUNW 0x6ffffffa
#define PT_SUNWBSS 0x6ffffffa /* Sun Specific segment */
#define PT_SUNWSTACK 0x6ffffffb /* Stack segment */
---- src/elflint.c
-+++ src/elflint.c
+--- a/src/elflint.c
++++ b/src/elflint.c
@@ -3187,6 +3187,7 @@
if (phdr->p_type >= PT_NUM && phdr->p_type != PT_GNU_EH_FRAME