summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/fampp2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/fampp2')
-rw-r--r--dev-libs/fampp2/Manifest2
-rw-r--r--dev-libs/fampp2/fampp2-6.0.1.ebuild33
-rw-r--r--dev-libs/fampp2/fampp2-7.0.1.ebuild50
-rw-r--r--dev-libs/fampp2/metadata.xml11
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-libs/fampp2/Manifest b/dev-libs/fampp2/Manifest
new file mode 100644
index 000000000000..9ba494d20929
--- /dev/null
+++ b/dev-libs/fampp2/Manifest
@@ -0,0 +1,2 @@
+DIST fampp2-6.0.1.tar.bz2 282852 SHA256 8f54e0226cac5ab94f80aff1c11104d305a63183a88267e259b86059c93d58c0 SHA512 f61ff11596c22bdbca21d280a19500110b0df1caaec33abee7ac304b046f301222dfa5908de1137e4fd84cbb69de297fa313acb333c3a5f54f5788d5ff5c11c0 WHIRLPOOL af51b86054c5589ae3312980112e0244666460bf394f48319b3b1c8d84901156c7b913b3706fdc89ed3ba8189ea1abd748227a909b53a276fd22804748e5de99
+DIST fampp2-7.0.1.tar.bz2 288073 SHA256 2bfcc28755dbec832b395bad63b8cf40896b0d4bfbca02c57477a164ca2f0244 SHA512 317a5cfd383418265cafea0840af8b7c714a04b34265ebfba73230ff2492df8f7884797529916693ab489bdbc94799ca83e015cf0bcfffaea6b28b3a7f9ccbd0 WHIRLPOOL 513b6c9f42f9fdacb089079420212d5f79394aec339061d5edd0e7faa34e0b20f33ae98258771a9d60f958683f8bdb6cedae4cd1067f76266f7ee79053b0d9a7
diff --git a/dev-libs/fampp2/fampp2-6.0.1.ebuild b/dev-libs/fampp2/fampp2-6.0.1.ebuild
new file mode 100644
index 000000000000..ad02d1830eb1
--- /dev/null
+++ b/dev-libs/fampp2/fampp2-6.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+DESCRIPTION="C++ wrapper for fam"
+HOMEPAGE="https://sourceforge.net/projects/fampp/"
+SRC_URI="mirror://sourceforge/fampp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/fam
+ dev-libs/STLport
+ dev-libs/ferrisloki
+ >=dev-libs/libsigc++-2.0.0
+ =dev-libs/glib-2*
+ =x11-libs/gtk+-2*"
+
+src_prepare() {
+ sed -ri \
+ -e '/^C(XX)?FLAGS/s:-O0 -g::' \
+ -e '/^LDFLAGS/s:-Wl,-O1 -Wl,--hash-style=both::' \
+ configure
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/dev-libs/fampp2/fampp2-7.0.1.ebuild b/dev-libs/fampp2/fampp2-7.0.1.ebuild
new file mode 100644
index 000000000000..ddc05a83891d
--- /dev/null
+++ b/dev-libs/fampp2/fampp2-7.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="C++ wrapper for fam"
+HOMEPAGE="https://sourceforge.net/projects/fampp/"
+SRC_URI="mirror://sourceforge/fampp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples stlport"
+
+RDEPEND="virtual/fam
+ stlport? ( dev-libs/STLport )
+ >=dev-libs/ferrisloki-2.0.3[stlport?]
+ dev-libs/libsigc++:2
+ dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -ri \
+ -e '/^C(XX)?FLAGS/s:-O0 -g::' \
+ -e '/^LDFLAGS/s:-Wl,-O1 -Wl,--hash-style=both::' \
+ configure || die "sed failed"
+}
+
+src_configure() {
+ # glib and gtk+ are only required for some examples
+ econf \
+ --disable-glibtest \
+ --disable-gtktest \
+ --with-stlport=/usr/include/stlport \
+ $(use_enable stlport)
+
+ if ! use examples ; then
+ sed -i -e '/^SUBDIRS/ s/examples//' Makefile.in || die "sed failed"
+ fi
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/fampp2/metadata.xml b/dev-libs/fampp2/metadata.xml
new file mode 100644
index 000000000000..4cacf085b0a3
--- /dev/null
+++ b/dev-libs/fampp2/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cpp</herd>
+ <use>
+ <flag name='stlport'>Include support for <pkg>dev-libs/STLport</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type='sourceforge'>fampp</remote-id>
+ </upstream>
+</pkgmetadata>