summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-09-22 22:02:53 +0200
committerAaron Bauman <bman@gentoo.org>2019-02-09 15:12:32 -0500
commitaccc18e7b62e2d9991ea8e827491e62251d2616c (patch)
treec50d53ae5da66376dd2ed173b4fda8533e1ca2d5 /dev-libs/faxpp
parentwww-apps/gitea: remove unused file (diff)
downloadgentoo-accc18e7b62e2d9991ea8e827491e62251d2616c.tar.gz
gentoo-accc18e7b62e2d9991ea8e827491e62251d2616c.tar.bz2
gentoo-accc18e7b62e2d9991ea8e827491e62251d2616c.zip
dev-libs/faxpp: EAPI7 revbump, improve ebuild
Closes: https://bugs.gentoo.org/666772 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/9952 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-libs/faxpp')
-rw-r--r--dev-libs/faxpp/faxpp-0.4-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/faxpp/faxpp-0.4-r1.ebuild b/dev-libs/faxpp/faxpp-0.4-r1.ebuild
new file mode 100644
index 000000000000..70d50bbaeaaf
--- /dev/null
+++ b/dev-libs/faxpp/faxpp-0.4-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Small, fast and conformant XML pull parser written in C"
+HOMEPAGE="http://faxpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+src_install() {
+ default
+
+ if use doc; then
+ docinto html
+ dodoc -r docs/api/
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}