summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2018-04-10 18:40:33 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2018-04-10 18:40:33 +0200
commit81057e83b3f4f4d8829f8f2156355457dfc2aa6f (patch)
treeabf447ccb578bb3cb7c057c0b39d8aee3f7e7e33 /dev-libs/ffcall
parentdev-php/maxmind-db-reader: Version bump to 1.3.0 (diff)
downloadgentoo-81057e83b3f4f4d8829f8f2156355457dfc2aa6f.tar.gz
gentoo-81057e83b3f4f4d8829f8f2156355457dfc2aa6f.tar.bz2
gentoo-81057e83b3f4f4d8829f8f2156355457dfc2aa6f.zip
dev-libs/ffcall: Version bump to 2.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-libs/ffcall')
-rw-r--r--dev-libs/ffcall/Manifest1
-rw-r--r--dev-libs/ffcall/ffcall-2.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/ffcall/Manifest b/dev-libs/ffcall/Manifest
index 4dad06986392..bc3bc2c59912 100644
--- a/dev-libs/ffcall/Manifest
+++ b/dev-libs/ffcall/Manifest
@@ -1,2 +1,3 @@
DIST libffcall-1.13.tar.gz 985185 BLAKE2B 78d9b9f046185a9a658ed2864167c64e373359e709cde7abc9360b21959c015b201423b46b8048120b98edfd0047dd20184c5f543c7d1d33a7ffad983036c043 SHA512 c059fa89eb3e85bad22d045de074bfc88fae42454821e10905ffd67209b6e6ea44eeab120b869696f77b816aacb9a5af3e4b51c640512e876df1b6da6f296bd4
DIST libffcall-2.0.tar.gz 938605 BLAKE2B 1e6fcae8f1dcaad52ca84d0dcf97f8dde5bb8153244bbb9047dbab5f6a1dade0a00f149507e6bb14225369a7081cadb069d23c8bc7cdcfaec937d7b9d47d08c1 SHA512 d75aa1df97b14692a9137745bae5b24c4d8f739cb1c7f854e7ed47e4a77a49759122abd6b0e445efa56381f47932c13cd21a154b2783649afb9c7a39e73fea04
+DIST libffcall-2.1.tar.gz 943235 BLAKE2B ae82663174db084e830b6ff77ceedf8641b3edeb7800952ac4e2772d9033da3e45f46159e6fdae86615dc69fceba39f48d6c75e6cbd41be98f1986fa69d50b3b SHA512 da73375fb45b7d764c06437a517c2a90abf7d5de6afe0a8ca19e6dfafd2a8c7107e39d230ecbc8edfdd5926b16a0c13b7bb9319287047c47de1241b2f6ae805e
diff --git a/dev-libs/ffcall/ffcall-2.1.ebuild b/dev-libs/ffcall/ffcall-2.1.ebuild
new file mode 100644
index 000000000000..b4762103c805
--- /dev/null
+++ b/dev-libs/ffcall/ffcall-2.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_PV="libffcall-${PV}"
+
+DESCRIPTION="Build foreign function call interfaces in embedded interpreter"
+HOMEPAGE="https://www.gnu.org/software/libffcall/"
+SRC_URI="mirror://gnu/libffcall/${MY_PV}.tar.gz"
+
+# "Ffcall is under GNU GPL. As a special exception, if used in GNUstep
+# or in derivate works of GNUstep, the included parts of ffcall are
+# under GNU LGPL." -ffcall author
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+S=${WORKDIR}/${MY_PV}
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ # The build system is a strange mix of autogenerated
+ # files and manual tweaks on top. Uses $CFLAGS / $LDFLAGS randomly.
+ # We are adding them consistently here and a bit over the top:
+ # bugs: #334581
+
+ for mfi in {,*/,*/*/,}Makefile.in
+ do
+ elog "Patching '${mfi}'"
+ # usually uses only assembler here, but -march=
+ # and -Wa, are a must to pass here.
+ sed -e 's/$(CC) /&$(CFLAGS) /g' \
+ -i "${mfi}" || die
+ done
+ eapply_user
+}
+
+src_configure() {
+ append-flags -fPIC
+
+ # Doc goes in datadir
+ econf \
+ --datadir="${EPREFIX}"/usr/share/doc/${PF} \
+ --enable-shared \
+ --disable-static
+}
+
+src_compile() {
+ # TODO. Remove -j1
+ emake -j1
+}
+
+src_install() {
+ dodoc NEWS README
+ dodir /usr/share/man
+ default
+ prune_libtool_files
+}