summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-25 11:01:13 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-25 14:19:30 +0200
commitc741e21e1c5ef06ad5fc04ab29b8b2f76347155f (patch)
treeb961dca52643616410cd620cd4d197bc83d764b2 /dev-libs/gdl
parentdev-libs/gdl: Drop old (diff)
downloadgentoo-c741e21e1c5ef06ad5fc04ab29b8b2f76347155f.tar.gz
gentoo-c741e21e1c5ef06ad5fc04ab29b8b2f76347155f.tar.bz2
gentoo-c741e21e1c5ef06ad5fc04ab29b8b2f76347155f.zip
dev-libs/gdl: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-libs/gdl')
-rw-r--r--dev-libs/gdl/Manifest1
-rw-r--r--dev-libs/gdl/gdl-3.20.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/gdl/Manifest b/dev-libs/gdl/Manifest
index 6d319248d6e7..69d1d4b8a5ee 100644
--- a/dev-libs/gdl/Manifest
+++ b/dev-libs/gdl/Manifest
@@ -1 +1,2 @@
DIST gdl-3.18.0.tar.xz 527728 SHA256 1499884e4fce375a963cf2b98b90e6724144f9b1f1ac8b84d765f4c85a2140b2 SHA512 6ef634242a53c8ae8610305a3ee1dbb61867f974fc1b3922404cd7f01ff95ac2ffa3ce3c5c5fc6bc327f7973f7c2ca401e7c29d3dcf0e98716e3848a85360d45 WHIRLPOOL 28fe56651e64f06444f590cb057dc57e48cd86b90c90a662115d50b276615ee2c694dc2ca92ddc97123eb9fbe14f70345eec9d82adec7744b42d5bc4d82b07ad
+DIST gdl-3.20.0.tar.xz 527736 SHA256 53d3a3bb9b9be25b3a40c644fdbbb57a5a63ee1f5f839c2266d1cd9779360e8b SHA512 94f04a6a7348a1649a846cbbb834fd297de3088b5ec31f77d4681c7b1c92cf5186d51790632b6715a7181e931e746246ff35e46aea0a5d30d947a7b17d57ae30 WHIRLPOOL 10f71a81379ce9fd4c1c0e928aa0958ca88c89b5903e0254f36ead1809e4388ced07dd7a2cc4d90efe517341ff02d7ab1052e2deb52e42db86bb67537437da3c
diff --git a/dev-libs/gdl/gdl-3.20.0.ebuild b/dev-libs/gdl/gdl-3.20.0.ebuild
new file mode 100644
index 000000000000..85fd5d2b917d
--- /dev/null
+++ b/dev-libs/gdl/gdl-3.20.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="GNOME docking library"
+HOMEPAGE="https://git.gnome.org/browse/gdl"
+
+LICENSE="LGPL-2.1+"
+SLOT="3/5" # subslot = libgdl-3 soname version
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=x11-libs/gtk+-3.0.0:3[introspection?]
+ >=dev-libs/libxml2-2.4:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.40.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure $(use_enable introspection)
+}