summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-10-12 23:18:49 -0400
committerMike Frysinger <vapier@gentoo.org>2015-10-12 23:24:00 -0400
commit638a72c75b7c4c0cd3c524ccf138e00b30732055 (patch)
tree5036cfd7f00399e57aeccd413fb18bb47b6cfd19 /dev-libs/glib/glib-2.44.1-r1.ebuild
parentapp-arch/snappy: correct typo in name (diff)
downloadgentoo-638a72c75b7c4c0cd3c524ccf138e00b30732055.tar.gz
gentoo-638a72c75b7c4c0cd3c524ccf138e00b30732055.tar.bz2
gentoo-638a72c75b7c4c0cd3c524ccf138e00b30732055.zip
dev-libs/glib: add various cross-compile settings
The upstream configure script has many tests that fail when cross-compiling, so add proper settings until the upstream bugs are resolved.
Diffstat (limited to 'dev-libs/glib/glib-2.44.1-r1.ebuild')
-rw-r--r--dev-libs/glib/glib-2.44.1-r1.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-libs/glib/glib-2.44.1-r1.ebuild b/dev-libs/glib/glib-2.44.1-r1.ebuild
index 9534f7adb4f5..d5302bc47c26 100644
--- a/dev-libs/glib/glib-2.44.1-r1.ebuild
+++ b/dev-libs/glib/glib-2.44.1-r1.ebuild
@@ -182,6 +182,19 @@ multilib_src_configure() {
export LIBFFI_LIBS="-lffi"
fi
+ # These configure tests don't work when cross-compiling.
+ if tc-is-cross-compiler ; then
+ # https://bugzilla.gnome.org/show_bug.cgi?id=756473
+ case ${CHOST} in
+ hppa*|metag*) export glib_cv_stack_grows=yes ;;
+ *) export glib_cv_stack_grows=no ;;
+ esac
+ # https://bugzilla.gnome.org/show_bug.cgi?id=756474
+ export glib_cv_uscore=no
+ # https://bugzilla.gnome.org/show_bug.cgi?id=756475
+ export ac_cv_func_posix_get{pwuid,grgid}_r=yes
+ fi
+
local myconf
case "${CHOST}" in