summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-22 22:02:54 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-22 22:03:03 +0100
commitc97e26f4584d8359ad9e618b325072bd05cb0283 (patch)
tree8a0d216f35b7fb6fe232df9f7c3545fe27d96a27 /dev-libs/go-fuse/go-fuse-0_p20150422.ebuild
parentdev-go/go-oauth2: Use egit_clean to clean workdir (diff)
downloadgentoo-c97e26f4584d8359ad9e618b325072bd05cb0283.tar.gz
gentoo-c97e26f4584d8359ad9e618b325072bd05cb0283.tar.bz2
gentoo-c97e26f4584d8359ad9e618b325072bd05cb0283.zip
dev-libs/go-fuse: Use egit_clean to clean workdir
* Sort global scope according to skel.ebuild * Add missing die Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-libs/go-fuse/go-fuse-0_p20150422.ebuild')
-rw-r--r--dev-libs/go-fuse/go-fuse-0_p20150422.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild b/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild
index 839de1e5a8a1..60eefb5676b9 100644
--- a/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild
+++ b/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild
@@ -1,29 +1,33 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-KEYWORDS="~amd64"
-RESTRICT="strip"
-DESCRIPTION="FUSE bindings for Go"
+inherit eutils
+
GO_PN=github.com/hanwen/${PN}
-HOMEPAGE="https://${GO_PN}"
EGIT_COMMIT="ffed29ec8b88f61c1b8954134cc48ef03bb26ce1"
+
+HOMEPAGE="https://${GO_PN}"
+DESCRIPTION="FUSE bindings for Go"
SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD"
+
SLOT="0"
+LICENSE="BSD"
KEYWORDS="~amd64"
IUSE=""
DEPEND=">=dev-lang/go-1.3"
RDEPEND=""
+RESTRICT="strip"
+
src_unpack() {
default_src_unpack
mkdir -p "${S}/src/${GO_PN%/*}" || die
mv ${PN}-${EGIT_COMMIT} "${S}/src/${GO_PN}" || die
- find "${S}" -name .gitignore -delete || die
+ egit_clean
}
call_go() {