summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-15 03:23:28 +0100
committerSam James <sam@gentoo.org>2021-04-16 12:15:35 +0100
commitfdf44522fc1dc8df5c06865fb1a8d6e0a14e535a (patch)
tree2dbe0ad66c808866a92a1ab2492cd5ae47c12c12 /dev-libs/go-usb
parentdev-libs/go-fuse: eutils-- (diff)
downloadgentoo-fdf44522fc1dc8df5c06865fb1a8d6e0a14e535a.tar.gz
gentoo-fdf44522fc1dc8df5c06865fb1a8d6e0a14e535a.tar.bz2
gentoo-fdf44522fc1dc8df5c06865fb1a8d6e0a14e535a.zip
dev-libs/go-usb: multilib--, style fix
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/go-usb')
-rw-r--r--dev-libs/go-usb/go-usb-9999.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/dev-libs/go-usb/go-usb-9999.ebuild b/dev-libs/go-usb/go-usb-9999.ebuild
index 7c84be80dbe4..1cc0b177b86e 100644
--- a/dev-libs/go-usb/go-usb-9999.ebuild
+++ b/dev-libs/go-usb/go-usb-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit git-r3 multilib
+inherit git-r3
DESCRIPTION="CGO bindings for libusb"
HOMEPAGE="https://github.com/hanwen/usb"
@@ -11,22 +11,19 @@ EGIT_REPO_URI="https://github.com/hanwen/usb.git"
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
-IUSE=""
DEPEND=">=dev-lang/go-1.4"
-RDEPEND=""
# Tests require a connected mtp device
RESTRICT="test"
GO_PN="/usr/lib/go/src/github.com/hanwen/usb"
+src_test() {
+ go test -ldflags '-extldflags=-fno-PIC' ${GO_PN} || die
+}
+
src_install() {
insinto "${GO_PN}"
doins *.go LICENSE
}
-
-src_test() {
- go test -ldflags '-extldflags=-fno-PIC' ${GO_PN} || die
-}