summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-20 18:13:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-20 18:17:08 +0200
commit9172613e8e9a5a480e75c409765524bb3e46f640 (patch)
treec18ace0398674fa315e86c7ad17581e90632b87d /dev-libs/grantlee/grantlee-5.1.0.ebuild
parentapp-portage/pfl: Revision bump to pfl-3.0.1-r2. (diff)
downloadgentoo-9172613e8e9a5a480e75c409765524bb3e46f640.tar.gz
gentoo-9172613e8e9a5a480e75c409765524bb3e46f640.tar.bz2
gentoo-9172613e8e9a5a480e75c409765524bb3e46f640.zip
dev-libs/grantlee: EAPI-7 bump, fix build with >=cmake-3.15
Closes: https://bugs.gentoo.org/690226 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/grantlee/grantlee-5.1.0.ebuild')
-rw-r--r--dev-libs/grantlee/grantlee-5.1.0.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-libs/grantlee/grantlee-5.1.0.ebuild b/dev-libs/grantlee/grantlee-5.1.0.ebuild
index d8de4e45a9f6..8bcda9a613cb 100644
--- a/dev-libs/grantlee/grantlee-5.1.0.ebuild
+++ b/dev-libs/grantlee/grantlee-5.1.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
VIRTUALX_REQUIRED="test"
inherit cmake-utils virtualx
@@ -15,25 +15,26 @@ SLOT="5"
KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
IUSE="debug doc test"
+BDEPEND="
+ doc? ( app-doc/doxygen[dot] )
+"
RDEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtscript:5
"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )
test? ( dev-qt/qttest:5 )
"
# bug 682258
RESTRICT="test"
-DOCS=( AUTHORS CHANGELOG README.md )
-
PATCHES=(
"${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
"${FILESDIR}/${P}-slot.patch"
"${FILESDIR}/${P}-qt-5.13.patch"
+ "${FILESDIR}/${P}-cxx11.patch"
)
src_prepare() {