summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-20 21:23:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-21 10:28:23 +0100
commit57d851ef6924085f05624ff7d34340ea2a94badd (patch)
tree76635370ab9dabfb48157b12949d71ac442cd3fb /dev-libs/grantlee
parentsys-cluster/slurm: re-introduce sview disabling (diff)
downloadgentoo-57d851ef6924085f05624ff7d34340ea2a94badd.tar.gz
gentoo-57d851ef6924085f05624ff7d34340ea2a94badd.tar.bz2
gentoo-57d851ef6924085f05624ff7d34340ea2a94badd.zip
dev-libs/grantlee: 0.5.2 version bump
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/grantlee')
-rw-r--r--dev-libs/grantlee/Manifest1
-rw-r--r--dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch9
-rw-r--r--dev-libs/grantlee/files/grantlee-5.2.0-slot.patch67
-rw-r--r--dev-libs/grantlee/grantlee-5.2.0.ebuild60
4 files changed, 134 insertions, 3 deletions
diff --git a/dev-libs/grantlee/Manifest b/dev-libs/grantlee/Manifest
index 78e73378a73c..d0d20f2b0388 100644
--- a/dev-libs/grantlee/Manifest
+++ b/dev-libs/grantlee/Manifest
@@ -1 +1,2 @@
DIST grantlee-5.1.0.tar.gz 1175380 BLAKE2B 6468c0131a334c3ac52b841a64171093a41605686e4ec2af1a60bbb829f652d388fb48e501a0c1f5eef54ff3253c10b0d6ebd5a4439ed2852f8746188011f9e4 SHA512 2b806a0770b9c6d02f207d5b4939ae8cae325de4fa01901320ffef5c8442ef0f1c10dd799966d0bf0d223e6541f93db8568aaf922ea1b334bcb2f85f6373a936
+DIST grantlee-5.2.0.tar.gz 1166467 BLAKE2B 89f66fefe3c5bbd087cdaed0f83a6b9ca2456629465dfd68d32c6f316d6d4533ece09e5a1444833897c70abbeb8258e0ca9faba09388dcbf40245c04f72f5040 SHA512 94b53d103aa775e6d45357d44d5634a5214d12ea7178d251fda30c5a88ddc2682ae44501ee8b7dc475793b84fa0998eb0bc13eea3f2e10ab29b1489db6ea60bd
diff --git a/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch b/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch
index a25f52b3c63d..b35dc46586e5 100644
--- a/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch
+++ b/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch
@@ -1,6 +1,9 @@
-diff -ruN grantlee-0.3.0.orig/CMakeLists.txt grantlee-0.3.0/CMakeLists.txt
---- grantlee-0.3.0.orig/CMakeLists.txt 2012-11-01 21:14:18.000000000 +0100
-+++ grantlee-0.3.0/CMakeLists.txt 2013-03-09 12:25:56.498096399 +0100
+Do not make linker warnings fatal.
+
+Gentoo-bug: 430968
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
@@ -62,8 +62,8 @@
endif()
diff --git a/dev-libs/grantlee/files/grantlee-5.2.0-slot.patch b/dev-libs/grantlee/files/grantlee-5.2.0-slot.patch
new file mode 100644
index 000000000000..9490df2327ec
--- /dev/null
+++ b/dev-libs/grantlee/files/grantlee-5.2.0-slot.patch
@@ -0,0 +1,67 @@
+From 0bf2a3f667a958b3cc7859cc2fe60ca8a7ccac08 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 30 Nov 2019 11:55:33 +0100
+Subject: [PATCH] Install headers to a custom location to permit slotting
+
+That was previously necessary with Qt4 version, let's keep it while
+Qt6 is around the corner.
+
+Amended with target_include_directories fix by jospezial.
+
+---
+ templates/lib/CMakeLists.txt | 5 +++--
+ textdocument/lib/CMakeLists.txt | 5 +++--
+ 2 files changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/templates/lib/CMakeLists.txt b/templates/lib/CMakeLists.txt
+index 5058481..3ef29a4 100644
+--- a/templates/lib/CMakeLists.txt
++++ b/templates/lib/CMakeLists.txt
+@@ -101,6 +101,7 @@ if (Qt5Qml_FOUND)
+
+ target_sources(Grantlee_Templates PRIVATE ${scriptabletags_SRCS})
+ target_include_directories(Grantlee_Templates PRIVATE ../scriptabletags)
++ target_include_directories(Grantlee_Templates INTERFACE "$<INSTALL_INTERFACE:include/grantlee5>")
+ target_link_libraries(Grantlee_Templates
+ PRIVATE Qt5::Qml
+ )
+@@ -152,10 +153,10 @@ install(FILES
+ token.h
+ util.h
+ variable.h
+- DESTINATION include/grantlee COMPONENT Templates
++ DESTINATION include/grantlee5/grantlee COMPONENT Templates
+ )
+
+ install(FILES
+ grantlee_templates.h
+- DESTINATION include COMPONENT Templates
++ DESTINATION include/grantlee5 COMPONENT Templates
+ )
+diff --git a/textdocument/lib/CMakeLists.txt b/textdocument/lib/CMakeLists.txt
+index 2c5a96f..c42d32a 100644
+--- a/textdocument/lib/CMakeLists.txt
++++ b/textdocument/lib/CMakeLists.txt
+@@ -34,6 +34,7 @@ if (CMAKE_GENERATOR MATCHES "Visual Studio")
+ )
+ endforeach()
+ endif()
++target_include_directories(Grantlee_TextDocument INTERFACE "$<INSTALL_INTERFACE:include/grantlee5>")
+
+ target_link_libraries(Grantlee_TextDocument
+ PUBLIC Qt5::Gui
+@@ -59,10 +60,10 @@ install(FILES
+ texthtmlbuilder.h
+ mediawikimarkupbuilder.h
+ ${CMAKE_CURRENT_BINARY_DIR}/grantlee_textdocument_export.h
+- DESTINATION include/grantlee COMPONENT TextDocument
++ DESTINATION include/grantlee5/grantlee COMPONENT TextDocument
+ )
+
+ install(FILES
+ grantlee_textdocument.h
+- DESTINATION include COMPONENT TextDocument
++ DESTINATION include/grantlee5 COMPONENT TextDocument
+ )
+--
+2.24.0
diff --git a/dev-libs/grantlee/grantlee-5.2.0.ebuild b/dev-libs/grantlee/grantlee-5.2.0.ebuild
new file mode 100644
index 000000000000..9d5b5a2b9586
--- /dev/null
+++ b/dev-libs/grantlee/grantlee-5.2.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit cmake-utils virtualx
+
+DESCRIPTION="C++ string template engine based on the Django template system"
+HOMEPAGE="https://github.com/steveire/grantlee"
+SRC_URI="http://downloads.grantlee.org/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc test"
+
+BDEPEND="
+ doc? ( app-doc/doxygen[dot] )
+ test? ( dev-qt/linguist-tools:5 )
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+RESTRICT+=" !test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
+ "${FILESDIR}/${P}-slot.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use doc && cmake-utils_src_compile docs
+}
+
+src_test() {
+ virtx cmake-utils_src_test
+}
+
+src_install() {
+ use doc && local HTML_DOCS=("${BUILD_DIR}/apidox/")
+
+ cmake-utils_src_install
+}