summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-21 12:09:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-29 14:03:42 +0100
commitce86df7eb9cdd27b8da28b84541ed0894fac4b53 (patch)
tree3924362d6b5210d43d0502e02ac8f34b776b09c9 /dev-libs/grantlee
parentkde5.eclass: Switch to cmake.eclass (diff)
downloadgentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.tar.gz
gentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.tar.bz2
gentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.zip
*/*: Switch kde proj packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/grantlee')
-rw-r--r--dev-libs/grantlee/grantlee-5.2.0.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-libs/grantlee/grantlee-5.2.0.ebuild b/dev-libs/grantlee/grantlee-5.2.0.ebuild
index 9d5b5a2b9586..5f7dff2d6d27 100644
--- a/dev-libs/grantlee/grantlee-5.2.0.ebuild
+++ b/dev-libs/grantlee/grantlee-5.2.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
VIRTUALX_REQUIRED="test"
-inherit cmake-utils virtualx
+inherit cmake virtualx
DESCRIPTION="C++ string template engine based on the Django template system"
HOMEPAGE="https://github.com/steveire/grantlee"
@@ -40,21 +40,21 @@ src_configure() {
-DBUILD_TESTS=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
- use doc && cmake-utils_src_compile docs
+ use doc && cmake_src_compile docs
}
src_test() {
- virtx cmake-utils_src_test
+ virtx cmake_src_test
}
src_install() {
use doc && local HTML_DOCS=("${BUILD_DIR}/apidox/")
- cmake-utils_src_install
+ cmake_src_install
}