summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-05-22 15:42:58 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-05-22 15:43:58 +0200
commit6cec5ed8f017a8d6869deaa00c6a364f2230d209 (patch)
tree584b34aec0e8c412e07b9e15b0c840ac6d26469e /dev-libs/grok/files/grok-0.9.2-build-with-gperf-3.1.patch
parentdev-libs/grok: Fix compilation against PCRE >=8.34 (diff)
downloadgentoo-6cec5ed8f017a8d6869deaa00c6a364f2230d209.tar.gz
gentoo-6cec5ed8f017a8d6869deaa00c6a364f2230d209.tar.bz2
gentoo-6cec5ed8f017a8d6869deaa00c6a364f2230d209.zip
dev-libs/grok: Rev bump to allow building against >=gperf-3.1
Closes: https://github.com/jordansissel/grok/issues/29 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-libs/grok/files/grok-0.9.2-build-with-gperf-3.1.patch')
-rw-r--r--dev-libs/grok/files/grok-0.9.2-build-with-gperf-3.1.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/grok/files/grok-0.9.2-build-with-gperf-3.1.patch b/dev-libs/grok/files/grok-0.9.2-build-with-gperf-3.1.patch
new file mode 100644
index 000000000000..89300eb5f6e9
--- /dev/null
+++ b/dev-libs/grok/files/grok-0.9.2-build-with-gperf-3.1.patch
@@ -0,0 +1,26 @@
+Closes: https://github.com/jordansissel/grok/issues/28
+Closes: https://github.com/jordansissel/grok/issues/29
+
+--- a/Makefile
++++ b/Makefile
+@@ -213,8 +213,8 @@ grok_capture_xdr.h: grok_capture.x
+ rpcgen -h $< -o $@
+
+ %.c: %.gperf
+- @if $(GPERF) --version | head -1 | egrep -v '3\.[0-9]+\.[0-9]+' ; then \
+- echo "We require gperf version >= 3.0.3" ; \
++ @if $(GPERF) --version | head -1 | grep --quiet -E '[0-2]\.[0-9]\.[0-9]+|3\.0\.[0-9]+' ; then \
++ echo "We require gperf version >= 3.1.0" ; \
+ exit 1; \
+ fi
+ $(GPERF) $< > $@
+--- a/grok_matchconf_macro.h
++++ b/grok_matchconf_macro.h
+@@ -19,6 +19,6 @@ struct strmacro {
+ #endif
+
+ /* this function is generated by gperf */
+-const struct strmacro *patname2macro(const char *str, unsigned int len);
++const struct strmacro *patname2macro(const char *str, size_t len);
+
+ #endif /* _GROK_MATCHCONF_MACRO_ */