summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/guiloader-c++
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/guiloader-c++')
-rw-r--r--dev-libs/guiloader-c++/Manifest2
-rw-r--r--dev-libs/guiloader-c++/guiloader-c++-2.21.0.ebuild37
-rw-r--r--dev-libs/guiloader-c++/guiloader-c++-2.99.0.ebuild40
-rw-r--r--dev-libs/guiloader-c++/metadata.xml15
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-libs/guiloader-c++/Manifest b/dev-libs/guiloader-c++/Manifest
new file mode 100644
index 000000000000..ab188bd2c2e7
--- /dev/null
+++ b/dev-libs/guiloader-c++/Manifest
@@ -0,0 +1,2 @@
+DIST guiloader-c++-2.21.0.tar.bz2 301239 SHA256 e8e9bfcf35ebca28b9cf725bbd54bbdc2bf427a16b80d907b91d9c2f91a7ece4 SHA512 5dcc412200dcec738c12b11873e6741505370a92f2b8a091f07bb0f3966bb542e07470932fc17c7c28b990ffd30cc935ac1569e312f26a859a936feae6c280de WHIRLPOOL 4a184eec8bc7445216f86d73af004e7060bb5a7b2d1105bc5d5d84fa5496bdb99ee069b563e406d06f5ab49c693763162ef34fc75767493c3aa473b914558df3
+DIST guiloader-c++-2.99.0.tar.xz 261316 SHA256 f08dcfac3d7e5ca7ce10041c4cf0f156549e713527d2e56a928b449dac33478c SHA512 dda4bbacc582012333fad949861e3d346645c90d7ba121974fe035d8fc4db50949c68c69bde7bf91463851eea6c781dda8b422a839d0f20331afc068ed014910 WHIRLPOOL 37359734b49b7cebda12a7673fdcc6216ab8259a9441f9446e0c7453d7ce83a2a4a57927d1f791322036155d77bd581d1237590ef2cd0d33c2538b658b3aebab
diff --git a/dev-libs/guiloader-c++/guiloader-c++-2.21.0.ebuild b/dev-libs/guiloader-c++/guiloader-c++-2.21.0.ebuild
new file mode 100644
index 000000000000..ae5434ece929
--- /dev/null
+++ b/dev-libs/guiloader-c++/guiloader-c++-2.21.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+DESCRIPTION="C++ binding to GuiLoader library"
+HOMEPAGE="http://www.crowdesigner.org"
+SRC_URI="http://nothing-personal.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+LANGS="ru"
+
+RDEPEND=">=dev-libs/guiloader-2.21
+ >=dev-cpp/gtkmm-2.22:2.4
+ >=dev-cpp/glibmm-2.24:2"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.18 )"
+
+for x in ${LANGS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/{authors.txt,news.en.txt,readme.en.txt} || die
+}
diff --git a/dev-libs/guiloader-c++/guiloader-c++-2.99.0.ebuild b/dev-libs/guiloader-c++/guiloader-c++-2.99.0.ebuild
new file mode 100644
index 000000000000..831352145646
--- /dev/null
+++ b/dev-libs/guiloader-c++/guiloader-c++-2.99.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="C++ binding to GuiLoader library"
+HOMEPAGE="http://www.crowdesigner.org"
+SRC_URI="http://nothing-personal.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+LANGS="ru"
+
+RDEPEND=">=dev-libs/guiloader-2.99
+ dev-cpp/gtkmm:3.0
+ >=dev-cpp/glibmm-2.28:2"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.18 )"
+
+for x in ${LANGS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/{authors.txt,news.en.txt,readme.en.txt}
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/dev-libs/guiloader-c++/metadata.xml b/dev-libs/guiloader-c++/metadata.xml
new file mode 100644
index 000000000000..08f29d5e92f8
--- /dev/null
+++ b/dev-libs/guiloader-c++/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">GuiLoader/C++ is a C++ binding to GuiLoader library. It is a convenience
+ layer that simplifies development of GuiLoader based applications
+ written in C++ language by introducing exception safety, binding GTK+
+ objects d efined in GuiXml to C++ variables and type-safe dynamic
+ connection to signals.</longdescription>
+ <upstream>
+ <remote-id type="google-code">nothing-personal</remote-id>
+ </upstream>
+</pkgmetadata>