summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-05-21 12:16:15 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-05-21 12:16:38 +0200
commitbbc9fb5e55563c8187146a1bd9edb0f8455fdadf (patch)
tree5634c36631690503c1cd1394ee3a0abb4c3657dc /dev-libs/icu-le-hb
parentgames-emulation/advancemame: Add missing autoconf-archive dep (diff)
downloadgentoo-bbc9fb5e55563c8187146a1bd9edb0f8455fdadf.tar.gz
gentoo-bbc9fb5e55563c8187146a1bd9edb0f8455fdadf.tar.bz2
gentoo-bbc9fb5e55563c8187146a1bd9edb0f8455fdadf.zip
dev-libs/icu-le-hb: Don't install archive files
Closes: https://bugs.gentoo.org/724432 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/icu-le-hb')
-rw-r--r--dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild (renamed from dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild)12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild b/dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild
index 303b08a82b8a..bc67bb2c0d34 100644
--- a/dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild
+++ b/dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools multilib-minimal
@@ -22,8 +22,8 @@ RDEPEND="
media-libs/harfbuzz:=[${MULTILIB_USEDEP}]
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig[${MULTILIB_USEDEP}]
"
@@ -33,5 +33,9 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE="${S}" econf
+ ECONF_SOURCE="${S}" econf --disable-static
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "*.la" -delete || die
}