summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-12-03 16:16:40 +0100
committerFabian Groffen <grobian@gentoo.org>2017-12-03 16:17:11 +0100
commit77165b807efc2a976f20c98dd6e07c24aa349656 (patch)
tree7f0d2597c3138f91bf1d3b2c57e147246e2ae062 /dev-libs/icu/icu-58.2-r1.ebuild
parentapp-admin/syslog-ng: version bump to 3.12.1. (diff)
downloadgentoo-77165b807efc2a976f20c98dd6e07c24aa349656.tar.gz
gentoo-77165b807efc2a976f20c98dd6e07c24aa349656.tar.bz2
gentoo-77165b807efc2a976f20c98dd6e07c24aa349656.zip
dev-libs/icu: add Prefix support
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-libs/icu/icu-58.2-r1.ebuild')
-rw-r--r--dev-libs/icu/icu-58.2-r1.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/dev-libs/icu/icu-58.2-r1.ebuild b/dev-libs/icu/icu-58.2-r1.ebuild
index 1eaa578e41b3..cb2f808c5fc5 100644
--- a/dev-libs/icu/icu-58.2-r1.ebuild
+++ b/dev-libs/icu/icu-58.2-r1.ebuild
@@ -13,7 +13,7 @@ LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
IUSE="debug doc examples static-libs"
DEPEND="
@@ -34,6 +34,7 @@ PATCHES=(
"${FILESDIR}/${PN}-58.1-iterator.patch"
"${FILESDIR}/${PN}-58.2-CVE-2017-7867.patch"
"${FILESDIR}/${PN}-58.2-glibc226.patch"
+ "${FILESDIR}/${PN}-58.2-darwin.patch"
)
pkg_pretend() {
@@ -66,6 +67,12 @@ src_prepare() {
-e 's:icudefs.mk:icudefs.mk Doxyfile:' \
configure.ac || die
+ # Fix compilation on Solaris due to enabling of conflicting standards
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e '/define _XOPEN_SOURCE_EXTENDED/s/_XOPEN/no_XOPEN/' \
+ common/uposixdefs.h || die
+ fi
+
eautoreconf
}
@@ -116,6 +123,12 @@ multilib_src_configure() {
# icu tries to use clang by default
tc-export CC CXX
+ # make sure we configure with the same shell as we run icu-config
+ # with, or ECHO_N, ECHO_T and ECHO_C will be wrongly defined
+ export CONFIG_SHELL=${EPREFIX}/bin/sh
+ # probably have no /bin/sh in prefix-chain
+ [[ -x ${CONFIG_SHELL} ]] || CONFIG_SHELL=${BASH}
+
ECONF_SOURCE=${S} \
econf "${myeconfargs[@]}"
}