summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-29 17:55:13 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-29 17:55:13 +0200
commit317e4ee74f991fdda6fcb80c56cf8c9f4b7edb5b (patch)
tree7c5152944215dd9fd39a43f620486cdb95f476f2 /dev-libs/igraph
parentmedia-video/subtitlecomposer: Fix .desktop file (diff)
downloadgentoo-317e4ee74f991fdda6fcb80c56cf8c9f4b7edb5b.tar.gz
gentoo-317e4ee74f991fdda6fcb80c56cf8c9f4b7edb5b.tar.bz2
gentoo-317e4ee74f991fdda6fcb80c56cf8c9f4b7edb5b.zip
dev-libs/igraph: version bump to 0.8.2
* new maintainer + taken by science project Closes: https://github.com/gentoo/gentoo/pull/17640 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/igraph')
-rw-r--r--dev-libs/igraph/Manifest1
-rw-r--r--dev-libs/igraph/files/igraph-0.8.2-unbundle.patch150
-rw-r--r--dev-libs/igraph/igraph-0.8.2.ebuild59
-rw-r--r--dev-libs/igraph/metadata.xml19
4 files changed, 223 insertions, 6 deletions
diff --git a/dev-libs/igraph/Manifest b/dev-libs/igraph/Manifest
index 545b292f7865..f2dcaf5efb1c 100644
--- a/dev-libs/igraph/Manifest
+++ b/dev-libs/igraph/Manifest
@@ -1 +1,2 @@
DIST igraph-0.7.1.tar.gz 2967134 BLAKE2B 27f0a2f51e561a3ea2e2e6d31853fe10ffd66f9f67603d77f2c0449a4c2bcd4d45c98516b526fb0f23a871ebe3db1fcf0c691551714d044124778faa147bd30f SHA512 ac7d7e3fbc6d27ae69079224881ca03db2c7e0b50d016706f3e167c614e2c9332c675d2fcd3cde12874e13a8fc402d42222308c6195afadee15152cec93f94dd
+DIST igraph-0.8.2.tar.gz 3625308 BLAKE2B b3be5a28b6507c98c88a96c4a14e6b9c45645985f5b16aaae0739412a5f26a1ccdbda3180fac5d12525b4da2f5fc3d6caad3928cd1306b151b89104bbbb5f6e8 SHA512 e1035ed22541c7d253c201da5d2f8c5ceb154a6bf4be1b41981a02d6bbe72038647bf011432e2446307e615c27aa8079d4ef2c4447c2eba3764788e26e8f790b
diff --git a/dev-libs/igraph/files/igraph-0.8.2-unbundle.patch b/dev-libs/igraph/files/igraph-0.8.2-unbundle.patch
new file mode 100644
index 000000000000..859c6387b7f5
--- /dev/null
+++ b/dev-libs/igraph/files/igraph-0.8.2-unbundle.patch
@@ -0,0 +1,150 @@
+diff --git a/configure.ac b/configure.ac
+index b422caf..dae8647 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -333,6 +333,8 @@ else
+ internal_glpk=no
+ fi
+
++PKG_CHECK_MODULES([CS],[cxsparse])
++
+ # Link time optimization feature in newer gcc/g++
+ # based on http://svn.r-project.org/R/trunk/configure.ac
+ AC_ARG_ENABLE([lto],
+diff --git a/examples/simple/igraph_sparsemat2.c b/examples/simple/igraph_sparsemat2.c
+index 24877c2..0f4b45c 100644
+--- a/examples/simple/igraph_sparsemat2.c
++++ b/examples/simple/igraph_sparsemat2.c
+@@ -21,7 +21,7 @@
+
+ */
+
+-#include <cs/cs.h>
++#include <cs.h>
+ #include <igraph.h>
+ #include "igraph_blas_internal.h"
+ #include "igraph_arpack_internal.h"
+diff --git a/examples/simple/igraph_sparsemat3.c b/examples/simple/igraph_sparsemat3.c
+index 09329f0..31d4f1f 100644
+--- a/examples/simple/igraph_sparsemat3.c
++++ b/examples/simple/igraph_sparsemat3.c
+@@ -21,7 +21,7 @@
+
+ */
+
+-#include <cs/cs.h>
++#include <cs.h>
+ #include <igraph.h>
+
+ int permute(const igraph_matrix_t *M,
+diff --git a/examples/simple/igraph_sparsemat4.c b/examples/simple/igraph_sparsemat4.c
+index 3a33979..c0ea489 100644
+--- a/examples/simple/igraph_sparsemat4.c
++++ b/examples/simple/igraph_sparsemat4.c
+@@ -21,7 +21,7 @@
+
+ */
+
+-#include <cs/cs.h>
++#include <cs.h>
+ #include <igraph.h>
+
+ igraph_bool_t check_solution(const igraph_sparsemat_t *A,
+diff --git a/src/Makefile.am b/src/Makefile.am
+index f9d02d2..8ab3385 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -9,9 +9,6 @@ AM_YFLAGS = -d
+
+ lib_LTLIBRARIES = libigraph.la
+
+-include lapack/blas.inc
+-include lapack/lapack.inc
+-include lapack/arpack.inc
+ include plfit/plfit.inc
+
+ F2C = f2c/abort_.c f2c/dolio.c f2c/r_sin.c\
+@@ -99,8 +96,6 @@ if INTERNAL_ARPACK
+ ARPACK_LIB = libarpack.la
+ endif
+
+-include ../optional/glpk/glpk.inc
+-
+ if INTERNAL_GLPK
+ libglpk_la_SOURCES = $(GLPK)
+ libglpk_la_CFLAGS = -I$(top_srcdir)/optional/glpk
+@@ -365,7 +360,7 @@ SOURCES = basic_query.c games.c cocitation.c iterators.c \
+ drl_layout_3d.cpp drl_graph_3d.cpp \
+ DensityGrid_3d.cpp \
+ foreign-dl-parser.y foreign-dl-lexer.l \
+- $(CS) sparsemat.c mixing.c bigint.c bignum.c \
++ sparsemat.c mixing.c bigint.c bignum.c \
+ version.c optimal_modularity.c \
+ igraph_fixed_vectorlist.c separators.c \
+ igraph_marked_queue.c igraph_estack.c st-cuts.c \
+@@ -408,7 +403,7 @@ libigraph_la_CXXFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include $(W
+ libigraph_la_LDFLAGS = -no-undefined
+ libigraph_la_LIBADD = -lm $(XML2_LIBS) $(F2C_LIB) $(BLAS_LIB) \
+ $(LAPACK_LIB) $(ARPACK_LIB) $(GLPK_LIB) $(PRPACK_LIB) \
+- $(PLFIT_LIB)
++ $(PLFIT_LIB) $(CS_LIBS)
+
+ if INTERNAL_GLPK
+ libigraph_la_CFLAGS += -I$(top_srcdir)/optional/glpk
+diff --git a/src/Makefile.in b/src/Makefile.in
+index 56703d4..cc30d48 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -2411,7 +2411,7 @@ SOURCES = basic_query.c games.c cocitation.c iterators.c \
+ gengraph_powerlaw.cpp gengraph_random.cpp decomposition.c \
+ bipartite.c drl_layout_3d.cpp drl_graph_3d.cpp \
+ DensityGrid_3d.cpp foreign-dl-parser.y foreign-dl-lexer.l \
+- $(CS) sparsemat.c mixing.c bigint.c bignum.c version.c \
++ sparsemat.c mixing.c bigint.c bignum.c version.c \
+ optimal_modularity.c igraph_fixed_vectorlist.c separators.c \
+ igraph_marked_queue.c igraph_estack.c st-cuts.c \
+ cohesive_blocks.c statusbar.c lapack.c complex.c eigen.c \
+diff --git a/src/sparsemat.c b/src/sparsemat.c
+index 0ed4678..4fb724d 100644
+--- a/src/sparsemat.c
++++ b/src/sparsemat.c
+@@ -23,7 +23,7 @@
+
+ #include "config.h"
+
+-#include "cs/cs.h"
++#include <cs.h>
+
+ #include "igraph_sparsemat.h"
+ #include "igraph_error.h"
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index d350f11..31a1f5a 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -13,7 +13,7 @@ $(srcdir)/package.m4: $(top_srcdir)/configure.ac
+ echo 'm4_define([AT_PACKAGE_BUGREPORT], [@PACKAGE_BUGREPORT@])'; \
+ } >$(srcdir)/package.m4
+
+-EXTRA_DIST += package.m4
++#EXTRA_DIST += package.m4
+
+ TESTSUITE_AT = \
+ testsuite.at \
+diff --git a/tests/mt.at b/tests/mt.at
+index 050974a..b154ce1 100644
+--- a/tests/mt.at
++++ b/tests/mt.at
+@@ -23,11 +23,11 @@ AT_BANNER([[Thread-safety tests]])
+
+ AT_SETUP([Simple error handling test :])
+ AT_KEYWORDS([thread-safe])
+-AT_COMPILE_CHECK([simple/tls1.c], [], [], [], [-lpthread])
++AT_COMPILE_CHECK([simple/tls1.c], [], [], [], [-lpthread $(${PKG_CONFIG} --libs arpack)])
+ AT_CLEANUP
+
+ AT_SETUP([Thread-safe ARPACK:])
+ AT_KEYWORDS([thread-safe ARPACK])
+ AT_COMPILE_CHECK([simple/tls2.c], [simple/tls2.out], [], [internal],
+- [-lpthread])
++ [-lpthread $(${PKG_CONFIG} --libs arpack)])
+ AT_CLEANUP
diff --git a/dev-libs/igraph/igraph-0.8.2.ebuild b/dev-libs/igraph/igraph-0.8.2.ebuild
new file mode 100644
index 000000000000..fbacf2931bef
--- /dev/null
+++ b/dev-libs/igraph/igraph-0.8.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Creating and manipulating undirected and directed graphs"
+HOMEPAGE="http://www.igraph.org/"
+SRC_URI="https://github.com/igraph/igraph/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/gmp:0
+ dev-libs/libxml2
+ sci-libs/arpack
+ sci-libs/cxsparse
+ sci-mathematics/glpk
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-unbundle.patch )
+
+src_prepare() {
+ default
+ rm -r src/lapack optional/glpk src/cs || die
+ eautoreconf
+}
+
+src_configure() {
+ # even with --with-external-f2c
+ # we don't need f2c as none of
+ # arpack lapack blas
+ # are internal
+ tc-export PKG_CONFIG
+ econf \
+ $(use_enable debug) \
+ --enable-gmp \
+ --disable-static \
+ --disable-tls \
+ --with-external-arpack \
+ --with-external-blas \
+ --with-external-lapack \
+ --with-external-f2c \
+ --with-external-glpk
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/igraph/metadata.xml b/dev-libs/igraph/metadata.xml
index 6ba23eeb564f..91a6671aeaf2 100644
--- a/dev-libs/igraph/metadata.xml
+++ b/dev-libs/igraph/metadata.xml
@@ -1,13 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
<longdescription lang="en">
-igraph is a free software package for creating and manipulating undirected and
-directed graphs. It includes implementations for classic graph theory problems
-like minimum spanning trees and network flow, and also implements algorithms for
-some recent network analysis methods, like community structure search.
-</longdescription>
+ igraph is a free software package for creating and manipulating undirected and
+ directed graphs. It includes implementations for classic graph theory problems
+ like minimum spanning trees and network flow, and also implements algorithms for
+ some recent network analysis methods, like community structure search.
+ </longdescription>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
<upstream>
<remote-id type="sourceforge">igraph</remote-id>
</upstream>