summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-23 19:01:34 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-23 19:01:34 +0200
commite807e60264c21329d8f8b8b8bb5fc04ed294895a (patch)
tree433bdba697047124c0f86b3e7313985289abc910 /dev-libs/igraph
parentsci-mathematics/glpk: Remove libtool archives (diff)
downloadgentoo-e807e60264c21329d8f8b8b8bb5fc04ed294895a.tar.gz
gentoo-e807e60264c21329d8f8b8b8bb5fc04ed294895a.tar.bz2
gentoo-e807e60264c21329d8f8b8b8bb5fc04ed294895a.zip
dev-libs/igraph: Remove libtool archives
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/igraph')
-rw-r--r--dev-libs/igraph/igraph-0.7.1-r2.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/dev-libs/igraph/igraph-0.7.1-r2.ebuild b/dev-libs/igraph/igraph-0.7.1-r2.ebuild
index 83c2185d5b3e..b920276602c3 100644
--- a/dev-libs/igraph/igraph-0.7.1-r2.ebuild
+++ b/dev-libs/igraph/igraph-0.7.1-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools toolchain-funcs
@@ -22,8 +22,8 @@ RDEPEND="
>=sci-libs/cxsparse-3
sci-mathematics/glpk
gmp? ( dev-libs/gmp:0 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/${P}-unbundle.patch )
@@ -37,6 +37,7 @@ src_configure() {
econf \
$(use_enable gmp) \
$(use_enable debug) \
+ --disable-static \
--disable-tls \
--with-external-arpack \
--with-external-blas \
@@ -44,3 +45,10 @@ src_configure() {
--with-external-f2c \
--with-external-glpk
}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}