summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/iniparser/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/iniparser/files')
-rw-r--r--dev-libs/iniparser/files/iniparser-3.0-autotools.patch46
-rw-r--r--dev-libs/iniparser/files/iniparser-3.0b-cpp.patch47
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-libs/iniparser/files/iniparser-3.0-autotools.patch b/dev-libs/iniparser/files/iniparser-3.0-autotools.patch
new file mode 100644
index 000000000000..68eca7ed601c
--- /dev/null
+++ b/dev-libs/iniparser/files/iniparser-3.0-autotools.patch
@@ -0,0 +1,46 @@
+diff --git Makefile.am Makefile.am
+new file mode 100644
+index 0000000..63ca53b
+--- /dev/null
++++ Makefile.am
+@@ -0,0 +1,10 @@
++ACLOCAL_AMFLAGS = -I config
++
++lib_LTLIBRARIES = libiniparser.la
++
++libiniparser_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
++libiniparser_la_SOURCES = src/dictionary.c src/iniparser.c
++
++include_HEADERS = src/dictionary.h src/iniparser.h
++
++
+diff --git configure.ac configure.ac
+new file mode 100644
+index 0000000..1eac717
+--- /dev/null
++++ configure.ac
+@@ -0,0 +1,24 @@
++AC_PREREQ([2.65])
++AC_INIT([iniparser], [3.0], [ndevilla@free.fr])
++
++AC_CONFIG_AUX_DIR(config)
++AC_CONFIG_MACRO_DIR(config)
++
++AM_INIT_AUTOMAKE([1.8 foreign])
++
++SHARED_VERSION_INFO="0"
++AC_SUBST(SHARED_VERSION_INFO)
++
++
++# Checks for programs.
++AC_PROG_CC
++
++LT_INIT
++# Checks for header files.
++AC_CHECK_HEADERS([ ctype.h stdio.h stdlib.h string.h ])
++
++# Checks for library functions.
++AC_CHECK_FUNCS([strcmp])
++
++AC_CONFIG_FILES([Makefile])
++AC_OUTPUT
diff --git a/dev-libs/iniparser/files/iniparser-3.0b-cpp.patch b/dev-libs/iniparser/files/iniparser-3.0b-cpp.patch
new file mode 100644
index 000000000000..cb331b813093
--- /dev/null
+++ b/dev-libs/iniparser/files/iniparser-3.0b-cpp.patch
@@ -0,0 +1,47 @@
+diff -ur iniparser3.0b/src/dictionary.c iniparser3.0b-patched/src/dictionary.c
+--- iniparser3.0b/src/dictionary.c 2007-11-24 05:39:18.000000000 +0800
++++ iniparser3.0b-patched/src/dictionary.c 2009-04-01 21:38:09.000000000 +0800
+@@ -38,6 +38,9 @@
+ /*---------------------------------------------------------------------------
+ Private functions
+ ---------------------------------------------------------------------------*/
++#ifdef __cplusplus
++extern "C" {
++#endif
+
+ /* Doubles the allocated size associated to a pointer */
+ /* 'size' is the current allocated size. */
+@@ -401,5 +404,10 @@
+ dictionary_del(d);
+ return 0 ;
+ }
++
++#ifdef __cplusplus
++}
++#endif
++
+ #endif
+ /* vim: set ts=4 et sw=4 tw=75 */
+diff -ur iniparser3.0b/src/iniparser.h iniparser3.0b-patched/src/iniparser.h
+--- iniparser3.0b/src/iniparser.h 2007-11-24 05:38:19.000000000 +0800
++++ iniparser3.0b-patched/src/iniparser.h 2009-04-01 21:38:02.000000000 +0800
+@@ -41,6 +41,10 @@
+ #define iniparser_getstr(d, k) iniparser_getstring(d, k, NULL)
+ #define iniparser_setstr iniparser_setstring
+
++#ifdef __cplusplus
++extern "C" {
++#endif
++
+ /*-------------------------------------------------------------------------*/
+ /**
+ @brief Get number of sections in a dictionary
+@@ -277,4 +281,8 @@
+ /*--------------------------------------------------------------------------*/
+ void iniparser_freedict(dictionary * d);
+
++#ifdef __cplusplus
++}
++#endif
++
+ #endif