summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-09-13 22:36:10 +0200
committerMarek Szuba <marecki@gentoo.org>2020-09-13 22:39:53 +0200
commit885af02f92e9367bf2d6e8479be92d983e8adb8f (patch)
tree873463cccde773896419f1861b971ee4a3dde57f /dev-libs/intel-neo
parentprofiles: Last rites for app-shells/mpv-bash-completion (diff)
downloadgentoo-885af02f92e9367bf2d6e8479be92d983e8adb8f.tar.gz
gentoo-885af02f92e9367bf2d6e8479be92d983e8adb8f.tar.bz2
gentoo-885af02f92e9367bf2d6e8479be92d983e8adb8f.zip
dev-libs/intel-neo: bump to 20.36.17813
Interestingly enough, seems to work (in addition to testing the ebuild itself I have made an out-of-tree build with the test suite enabled) in spite of dev-util/intel-graphics-compiler being rather out of date. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-libs/intel-neo')
-rw-r--r--dev-libs/intel-neo/Manifest1
-rw-r--r--dev-libs/intel-neo/intel-neo-20.36.17813.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/intel-neo/Manifest b/dev-libs/intel-neo/Manifest
index 19b3c6efd7db..6450279bbc46 100644
--- a/dev-libs/intel-neo/Manifest
+++ b/dev-libs/intel-neo/Manifest
@@ -1 +1,2 @@
DIST intel-neo-20.16.16582.tar.gz 3042531 BLAKE2B adfc0aee2a315e67ccb3e4fe39ab09b618930607d3de931d1367881642d8e542385589299f593d3ab1cd6e16de7a8fce7b55fa1b4259097e15da7e55034d344b SHA512 700bee3ccf72c2bc89f5c8a75591de9dafbfe0a6480e3216258842c6b68ce1b527569d5fe1327a0a80cfbf79dca1d956820f060b602feefa83fc9b47cb46d7d0
+DIST intel-neo-20.36.17813.tar.gz 3459305 BLAKE2B 81996bb5946ff6334dc06aceed7e5f01f1ec1e417de7a600d41af43e0f74e3003b293f2981ad742e4f9df630aa81e9a21f6a0a04e9615ee4caa97fae4fe682bf SHA512 366120e785e068393bc0b1c2345eb3d2eca46d6c7485736d7e2aeece91d404f9b802230873b6f868fdd9d7a9852112a8aa216cde1210ab51d430dcef9601d968
diff --git a/dev-libs/intel-neo/intel-neo-20.36.17813.ebuild b/dev-libs/intel-neo/intel-neo-20.36.17813.ebuild
new file mode 100644
index 000000000000..6f29828a72b3
--- /dev/null
+++ b/dev-libs/intel-neo/intel-neo-20.36.17813.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_PN="compute-runtime"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Intel Graphics Compute Runtime for L0 and OpenCL, for Broadwell and beyond"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="l0 vaapi"
+
+BDEPEND="virtual/pkgconfig"
+COMMON=">=virtual/opencl-3
+ >=dev-util/intel-graphics-compiler-1.0.3826
+ >=media-libs/gmmlib-20.2.5
+ l0? ( >=dev-libs/level-zero-1.0.0 )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )"
+DEPEND="${COMMON}
+ media-libs/mesa" # for Khronos OpenGL headers
+RDEPEND="${COMMON}"
+
+DOCS=(
+ README.md
+ FAQ.md
+)
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ local mycmakeargs=(
+ -DKHRONOS_GL_HEADERS_DIR="${EPREFIX}/usr/include"
+ -DBUILD_WITH_L0=$(usex l0)
+ -DDISABLE_LIBVA=$(usex vaapi "no" "yes")
+ # If enabled, tests are automatically run during the compile phase
+ # - and we cannot run them because they require permissions to access
+ # the hardware.
+ -DSKIP_UNIT_TESTS=ON
+ )
+ cmake_src_configure
+}