summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory A. Pratt <anarchy@gentoo.org>2015-11-26 15:57:51 -0600
committerJory A. Pratt <anarchy@gentoo.org>2015-11-26 15:57:51 -0600
commita33db0173c8be4e192c2c136950548c4e358e12c (patch)
treeefdffceedbd2ed88c7fe73497ce128d766b9af23 /dev-libs/jemalloc/jemalloc-4.0.4.ebuild
parentdev-libs/nss - basic version bump 3.21 (diff)
downloadgentoo-a33db0173c8be4e192c2c136950548c4e358e12c.tar.gz
gentoo-a33db0173c8be4e192c2c136950548c4e358e12c.tar.bz2
gentoo-a33db0173c8be4e192c2c136950548c4e358e12c.zip
dev-libs/jemalloc - version bump 4.0.4, makor bug fixes
Diffstat (limited to 'dev-libs/jemalloc/jemalloc-4.0.4.ebuild')
-rw-r--r--dev-libs/jemalloc/jemalloc-4.0.4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/jemalloc/jemalloc-4.0.4.ebuild b/dev-libs/jemalloc/jemalloc-4.0.4.ebuild
new file mode 100644
index 000000000000..e28720045391
--- /dev/null
+++ b/dev-libs/jemalloc/jemalloc-4.0.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-multilib eutils
+
+DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
+HOMEPAGE="http://www.canonware.com/jemalloc/"
+SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~x64-macos"
+IUSE="debug static-libs stats"
+HTML_DOCS=( doc/jemalloc.html )
+PATCHES=( "${FILESDIR}/${PN}-3.5.1-strip-optimization.patch"
+ "${FILESDIR}/${PN}-3.5.1_fix_html_install.patch"
+)
+MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
+# autotools-utils.eclass auto-adds configure options when static-libs is in IUSE
+# but jemalloc doesn't implement them in its configure; need this here to
+# supress the warnings until automagic is removed from the eclass
+QA_CONFIGURE_OPTIONS="--enable-static --disable-static --enable-shared --disable-shared"
+src_configure() {
+ myeconfargs=(
+ $(use_enable debug)
+ $(use_enable stats)
+ )
+ autotools-multilib_src_configure
+}
+
+multilib_src_install() {
+ # Copy man file which the Makefile looks for
+ cp "${S}/doc/jemalloc.3" "${BUILD_DIR}/doc" || die
+ emake DESTDIR="${D}" install
+}
+
+src_install() {
+ autotools-multilib_src_install
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # fixup install_name, #437362
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libjemalloc.1.dylib \
+ "${ED}"/usr/$(get_libdir)/libjemalloc.1.dylib || die
+ fi
+ use static-libs || find "${ED}" -name '*.a' -delete
+}